aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2014-04-03 17:07:05 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2014-04-03 17:07:05 +0000
commitd4076495066a3539ade9dc869200d0b77480ef8d (patch)
treee296c2d9eacd4fb3c5b274cb5179a8891ed4dbf6 /dns
parent098da320bec07b14faaf6702a4ee4a2827e12c55 (diff)
downloadports-d4076495066a3539ade9dc869200d0b77480ef8d.tar.gz
ports-d4076495066a3539ade9dc869200d0b77480ef8d.zip
- Fix race during build of DJB ports that could lead to files leaking out of
STAGEDIR. The auto_home.c/auto_qmail.c (depending on which conf- file is used) must be deleted to or else this might not be executed depending on how quickly build and pre-install run: ./auto-str auto_home `sed 1q conf-home` > auto_home.c - Move STAGEDIR fixing to post-build with a message explaining the rebuild. - Bump PORTREVISION as pkg_install packages may have been built without some files.
Notes
Notes: svn path=/head/; revision=350029
Diffstat (limited to 'dns')
-rw-r--r--dns/djbdns/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/dns/djbdns/Makefile b/dns/djbdns/Makefile
index 0f82d569299c..56cd0c5ef94c 100644
--- a/dns/djbdns/Makefile
+++ b/dns/djbdns/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= djbdns
PORTVERSION?= ${DJBDNS_VER}
-PORTREVISION?= 18
+PORTREVISION?= 19
PORTEPOCH?= 1
CATEGORIES?= dns
MASTER_SITES= http://cr.yp.to/djbdns/ \
@@ -131,10 +131,11 @@ post-patch:
@${ECHO_CMD} "${CC} ${STRIP} ${LDFLAGS}" > ${WRKSRC}/conf-ld
@${ECHO_CMD} "${PREFIX}" > ${WRKSRC}/conf-home
-pre-install:
+post-build:
+ @${ECHO_MSG} "===> Rebuilding DJB installer to respect STAGEDIR"
@${MV} -f ${WRKSRC}/conf-home ${WRKSRC}/conf-home.sav
@${ECHO_CMD} "${STAGEDIR}${PREFIX}" > ${WRKSRC}/conf-home
- @cd ${WRKSRC} ; ${RM} -f install instcheck install.o instcheck.o hier.o auto_home.o
+ @cd ${WRKSRC} ; ${RM} -f install instcheck install.o instcheck.o hier.o auto_home.o auto_home.c
@cd ${WRKSRC} ; ${MAKE_CMD} install instcheck
@${TOUCH} ${WRKSRC}/*-conf
@${MV} -f ${WRKSRC}/conf-home.sav ${WRKSRC}/conf-home