aboutsummaryrefslogtreecommitdiff
path: root/editors/abiword
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2005-11-05 05:44:53 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2005-11-05 05:44:53 +0000
commitb0e6fb00cb878e4aec86223fb04eef64a7865954 (patch)
tree6131369dce7905879dbe6528976f1bf4ba902f6e /editors/abiword
parent0c336c82da6c56c16d195f9c87e977346a517a8b (diff)
downloadports-b0e6fb00cb878e4aec86223fb04eef64a7865954.tar.gz
ports-b0e6fb00cb878e4aec86223fb04eef64a7865954.zip
- Update to 2.4.1, see the release note for details:
http://www.abisource.com/release-notes/2.4.1.phtml - Replace from pkg-install to plist by use '@exec /bin/mkdir -p...', it's easier that way. - Correct the plist for plugins by add '@unexec /bin/rmdir....true' - Re-enable install the .server and .xml files for bonobo/ui stuff, only happen if GNOME is enable (autocheck by libgnomeui). - Add CONFLICTS with abiword(-plugins)-devel now. - As for plugins, grammar-checker, OpenWriter and OpenDocument have been added.
Notes
Notes: svn path=/head/; revision=147283
Diffstat (limited to 'editors/abiword')
-rw-r--r--editors/abiword/Makefile33
-rw-r--r--editors/abiword/distinfo4
-rw-r--r--editors/abiword/files/patch-GNUmakefile.in10
-rw-r--r--editors/abiword/files/patch-abiword.desktop4
-rw-r--r--editors/abiword/files/patch-aq10
-rw-r--r--editors/abiword/files/patch-ar1
-rw-r--r--editors/abiword/files/patch-src_af_util_xp_ut_iconv.cpp8
-rw-r--r--editors/abiword/pkg-install5
-rw-r--r--editors/abiword/pkg-plist19
9 files changed, 49 insertions, 45 deletions
diff --git a/editors/abiword/Makefile b/editors/abiword/Makefile
index b4b9f1d34d05..0c27040b1395 100644
--- a/editors/abiword/Makefile
+++ b/editors/abiword/Makefile
@@ -3,10 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/editors/abiword/Makefile,v 1.2 2005/10/29 22:31:16 marcus Exp $
#
PORTNAME= abiword
-PORTVERSION= 2.2.8
+PORTVERSION= 2.4.1
CATEGORIES= editors
MASTER_SITES= http://www.abisource.com/downloads/%SUBDIR%/${PORTVERSION}/source/
MASTER_SITE_SUBDIR= abiword
@@ -26,7 +27,7 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
USE_BZIP2= yes
USE_GMAKE= yes
USE_ICONV= yes
-USE_GNOME= gnomehier libglade2 libxml2
+USE_GNOME= libglade2 libxml2 libgnomeprintui desktopfileutils
WANT_GNOME= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
@@ -41,14 +42,14 @@ CONFIGURE_ARGS= --enable-xft \
--disable-peer-config
MAKEFILE= GNUmakefile
-EXCLUDE_EXTRACT= MSVC6 MSVC71 abipbx abiword-docs abiword-plugins expat \
- fribidi libiconv libpng pbx popt wv zlib
-EXTRACT_AFTER_ARGS= | ${TAR} -xf - ${EXCLUDE_EXTRACT:S/^/--exclude /}
-
-ABIVERSION= 2.2
+ABIVERSION= 2.4
PLIST_SUB+= ABIVERSION=${ABIVERSION}
WRKSRC= ${WRKDIR}/abiword-${PORTVERSION}/abi
+EXTERNALS= MSVC* abipbx abiword-docs abiword-plugins expat fribidi \
+ libiconv libpng pbx popt wv zlib
+EXTRACT_AFTER_ARGS=| ${TAR} -xpf - ${EXTERNALS:C,^,--exclude ${DISTNAME}/,}
+
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug \
--enable-symbols
@@ -64,10 +65,10 @@ PLIST_SUB+= DICT:=""
.include <bsd.port.pre.mk>
-.if ${HAVE_GNOME:Mlibgnomeprintui}!=""
-USE_GNOME+= libgnomeprintui libgnomeui desktopfileutils
+.if ${HAVE_GNOME:Mlibgnomeui}!=""
+USE_GNOME+= libgnomeui
CONFIGURE_ARGS+= --enable-gnome
-PKGNAMESUFFIX= -gnome
+PKGNAMESUFFIX:= -gnome
GNOME_ENABLED= yes
.endif
@@ -97,17 +98,19 @@ post-patch:
s|[(]libdir[)]/bonobo/servers|(prefix)/libdata/bonobo/servers|g'
post-install:
- @${MKDIR} ${PREFIX}/lib/AbiWord-${ABIVERSION}/plugins
-.if defined(GNOME_ENABLED)
+ @${MKDIR} ${X11BASE}/lib/AbiWord-${ABIVERSION}/plugins
+ @${MKDIR} ${X11BASE}/share/applications
@${INSTALL_DATA} ${WRKSRC}/abiword.desktop \
- ${X11BASE}/share/gnome/applications/abiword.desktop
+ ${X11BASE}/share/applications/abiword.desktop
+ @${MKDIR} ${X11BASE}/share/pixmaps
@${LN} -sf ${PREFIX}/share/AbiSuite-${ABIVERSION}/icons/abiword_48.png \
- ${X11BASE}/share/gnome/pixmaps/abiword_48.png
+ ${X11BASE}/share/pixmaps/abiword_48.png
+.if defined(GNOME_ENABLED)
@${INSTALL_DATA} ${WRKDIR}/abiword-${PORTVERSION}/abidistfiles/GNOME_AbiWord_Control_${ABIVERSION:S/./_/}.server \
${X11BASE}/libdata/bonobo/servers/
@${INSTALL_DATA} ${WRKDIR}/abiword-${PORTVERSION}/abidistfiles/abi-nautilus-view-file.xml \
${X11BASE}/share/gnome/gnome-2.0/ui/
- @-update-desktop-database
.endif
+ @-update-desktop-database
.include <bsd.port.post.mk>
diff --git a/editors/abiword/distinfo b/editors/abiword/distinfo
index 0152fc01baf7..13e2c040be74 100644
--- a/editors/abiword/distinfo
+++ b/editors/abiword/distinfo
@@ -1,2 +1,2 @@
-MD5 (AbiWord/abiword-2.2.8.tar.bz2) = f6f58e6ea4720ca635ede7b7f13cf156
-SIZE (AbiWord/abiword-2.2.8.tar.bz2) = 23918235
+MD5 (AbiWord/abiword-2.4.1.tar.bz2) = 03d47aad66c4c9f9d329e3538de97dcd
+SIZE (AbiWord/abiword-2.4.1.tar.bz2) = 24630989
diff --git a/editors/abiword/files/patch-GNUmakefile.in b/editors/abiword/files/patch-GNUmakefile.in
index e7b1b3f4059a..6385aea4d9af 100644
--- a/editors/abiword/files/patch-GNUmakefile.in
+++ b/editors/abiword/files/patch-GNUmakefile.in
@@ -1,6 +1,6 @@
---- GNUmakefile.in.orig Wed Jan 5 15:28:11 2005
-+++ GNUmakefile.in Wed Jan 5 15:30:55 2005
-@@ -315,15 +315,15 @@
+--- GNUmakefile.in.orig Wed Jul 20 22:21:46 2005
++++ GNUmakefile.in Wed Jul 20 22:23:12 2005
+@@ -337,15 +337,15 @@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
SUBDIRS = src
@@ -25,7 +25,7 @@
@BIGENDIAN_FALSE@dictionary = $(top_srcdir)/../abidistfiles/dictionary/LittleEndian32.american.hash
@BIGENDIAN_TRUE@dictionary = $(top_srcdir)/../abidistfiles/dictionary/BigEndian32.american.hash
@WITH_ISPELL_FALSE@INSTALLDICTIONARY = no
-@@ -816,7 +816,6 @@
+@@ -844,7 +844,6 @@
# Install the datafiles. This is quick-and-dirty.
install-data-local:
@@ -33,7 +33,7 @@
if test -d $(top_srcdir)/../abidistfiles ; then \
for dir in `cd $(top_srcdir)/../abidistfiles; find . -type d ! -name CVS` ; do \
$(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/$$dir ;\
-@@ -829,11 +828,7 @@
+@@ -857,11 +856,7 @@
for file in `echo $(top_srcdir)/../abidistfiles/$$dir/* | grep -v MANIFEST`; do \
if test -f $$file ; then \
sfile=`echo "$$file" | sed 's/\.[^.]*$$//'`; \
diff --git a/editors/abiword/files/patch-abiword.desktop b/editors/abiword/files/patch-abiword.desktop
index 02339d5a28ad..a8faac36b4da 100644
--- a/editors/abiword/files/patch-abiword.desktop
+++ b/editors/abiword/files/patch-abiword.desktop
@@ -1,5 +1,5 @@
---- abiword.desktop.orig Mon Apr 4 00:10:55 2005
-+++ abiword.desktop Mon Apr 4 00:12:20 2005
+--- abiword.desktop.orig Tue Oct 4 13:22:33 2005
++++ abiword.desktop Tue Oct 4 13:23:58 2005
@@ -3,11 +3,11 @@
Icon=abiword_48.png
Terminal=false
diff --git a/editors/abiword/files/patch-aq b/editors/abiword/files/patch-aq
index e00bf0585c14..98ce2809346a 100644
--- a/editors/abiword/files/patch-aq
+++ b/editors/abiword/files/patch-aq
@@ -1,6 +1,6 @@
---- src/config/abi_defs.mk.orig Thu Jun 17 14:54:58 2004
-+++ src/config/abi_defs.mk Thu Jun 17 14:55:04 2004
-@@ -217,11 +217,11 @@
+--- src/config/abi_defs.mk.orig Sun Jun 12 16:07:25 2005
++++ src/config/abi_defs.mk Sun Jun 12 16:08:49 2005
+@@ -202,11 +202,11 @@
## INSTALL program...
define MAKE_OBJDIR
@@ -10,11 +10,11 @@
define VERIFY_DIRECTORY
-if test ! -d xxxx; then rm -rf xxxx; mkdir -p xxxx; fi
-+if test ! -d xxxx; then rm -rf xxxx; $(ABIMKDIR) -p xxxx; fi
++if test ! -d xxxx; then rm -rf xxxx; $(ABIMKDIR) -p xxxx; fi
endef
ifeq ($(OS_NAME), WIN32)
-@@ -266,7 +266,9 @@
+@@ -251,7 +251,9 @@
##################################################################
##################################################################
diff --git a/editors/abiword/files/patch-ar b/editors/abiword/files/patch-ar
index 5832a8deed5c..fb71cb0b6a26 100644
--- a/editors/abiword/files/patch-ar
+++ b/editors/abiword/files/patch-ar
@@ -1,5 +1,6 @@
$FreeBSD$
+$MCom: ports/editors/abiword/files/patch-ar,v 1.2 2005/10/14 20:39:57 adamw Exp $
--- src/pkg/common/unix/scripts/install.sh.orig Sat Apr 7 10:59:52 2001
+++ src/pkg/common/unix/scripts/install.sh Wed Aug 8 13:31:57 2001
diff --git a/editors/abiword/files/patch-src_af_util_xp_ut_iconv.cpp b/editors/abiword/files/patch-src_af_util_xp_ut_iconv.cpp
index dd1f65d7282b..d892f8e3334f 100644
--- a/editors/abiword/files/patch-src_af_util_xp_ut_iconv.cpp
+++ b/editors/abiword/files/patch-src_af_util_xp_ut_iconv.cpp
@@ -1,11 +1,11 @@
---- src/af/util/xp/ut_iconv.cpp.orig Fri Jan 2 16:00:33 2004
-+++ src/af/util/xp/ut_iconv.cpp Fri Jan 2 16:08:03 2004
+--- src/af/util/xp/ut_iconv.cpp.orig Wed Jul 20 22:24:55 2005
++++ src/af/util/xp/ut_iconv.cpp Wed Jul 20 22:25:23 2005
@@ -67,7 +67,7 @@
#if defined (WIN32) || defined(__QNXNTO__) || defined(__CYGWIN__) || \
(defined (__MACH__) && defined (__APPLE__)) || \
(defined(TARGET_OS_MAC) && TARGET_OS_MAC) || \
--defined(__BEOS__) || defined (__AIX__) || \
-+defined(__BEOS__) || defined (__AIX__) || defined (__FreeBSD__) || \
+-defined (__AIX__) || \
++defined (__AIX__) || defined (__FreeBSD__) || \
(defined(__linux__) && defined(__powerpc__) && (__GLIBC__ <= 2) && (__GLIBC_MINOR__ <= 1))
#define ICONV_CONST const
diff --git a/editors/abiword/pkg-install b/editors/abiword/pkg-install
deleted file mode 100644
index a499e32b76b6..000000000000
--- a/editors/abiword/pkg-install
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-
-if [ "$2" = "POST-INSTALL" ]; then
- mkdir -p ${PKG_PREFIX}/lib/AbiWord-2.2/plugins
-fi
diff --git a/editors/abiword/pkg-plist b/editors/abiword/pkg-plist
index 105982c74268..b9f5dd8116fe 100644
--- a/editors/abiword/pkg-plist
+++ b/editors/abiword/pkg-plist
@@ -2,16 +2,18 @@ bin/AbiWord-%%ABIVERSION%%
bin/abiword
bin/ttfadmin.sh
bin/ttftool
-%%GNOME:%%libdata/bonobo/servers/GNOME_AbiWord_Control_2_2.server
+%%GNOME:%%libdata/bonobo/servers/GNOME_AbiWord_Control_2_4.server
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_Break.glade
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_Field.glade
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_FormatFootnotes.glade
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_FormatFrame.glade
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_FormatTOC.glade
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_FormatTable.glade
+share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_Goto.glade
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_HdrFtr.glade
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_InsertTable.glade
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_Insert_DateTime.glade
+share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_Latex.glade
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_MailMerge.glade
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_MetaData.glade
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_New.glade
@@ -24,6 +26,7 @@ share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_Spell.glade
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_Styles.glade
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_Stylist.glade
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_Stylist_modal.glade
+share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_Tab.glade
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_WordCount.glade
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/xap_UnixDlg_About.glade
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/xap_UnixDlg_DocComparison.glade
@@ -274,9 +277,10 @@ share/AbiSuite-%%ABIVERSION%%/templates/normal.awt-ur_PK
share/AbiSuite-%%ABIVERSION%%/templates/normal.awt-yi
share/AbiSuite-%%ABIVERSION%%/templates/normal.awt-zh_CN
share/AbiSuite-%%ABIVERSION%%/templates/normal.awt-zh_TW
-%%GNOME:%%share/gnome/applications/abiword.desktop
+share/applications/abiword.desktop
%%GNOME:%%share/gnome/gnome-2.0/ui/abi-nautilus-view-file.xml
-%%GNOME:%%share/gnome/pixmaps/abiword_48.png
+share/pixmaps/abiword_48.png
+@unexec rmdir %D/share/applications 2> /dev/null || true
@dirrm share/AbiSuite-%%ABIVERSION%%/templates
@dirrm share/AbiSuite-%%ABIVERSION%%/icons
@dirrm share/AbiSuite-%%ABIVERSION%%/dictionary
@@ -286,7 +290,8 @@ share/AbiSuite-%%ABIVERSION%%/templates/normal.awt-zh_TW
@dirrm share/AbiSuite-%%ABIVERSION%%/AbiWord/glade
@dirrm share/AbiSuite-%%ABIVERSION%%/AbiWord
@dirrm share/AbiSuite-%%ABIVERSION%%
-@dirrm lib/AbiWord-%%ABIVERSION%%/plugins
-@dirrm lib/AbiWord-%%ABIVERSION%%
-%%GNOME:%%@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
-%%GNOME:%%@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@exec /bin/mkdir -p %D/lib/AbiWord-%%ABIVERSION%%/plugins
+@unexec /bin/rmdir %D/lib/AbiWord-%%ABIVERSION%%/plugins 2>/dev/null || /usr/bin/true
+@unexec /bin/rmdir %D/lib/AbiWord-%%ABIVERSION%% 2>/dev/null || /usr/bin/true
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true