aboutsummaryrefslogtreecommitdiff
path: root/editors/apel-emacs
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>1999-01-24 03:46:05 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>1999-01-24 03:46:05 +0000
commitfa59bdaac746469fc9b7cc2871097d2297ee1d70 (patch)
tree809f1aec3ac27fc6113dc29815c64684901c81dc /editors/apel-emacs
parent7315f379b56d5c53cb24c8cbf7be8a45bd7abf93 (diff)
downloadports-fa59bdaac746469fc9b7cc2871097d2297ee1d70.tar.gz
ports-fa59bdaac746469fc9b7cc2871097d2297ee1d70.zip
o Fix for undesired error message in apel-emacs20.
o Make more simple in Makefile by moving declaration of variables. Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=16280
Diffstat (limited to 'editors/apel-emacs')
-rw-r--r--editors/apel-emacs/Makefile11
-rw-r--r--editors/apel-emacs/scripts/configure2
2 files changed, 9 insertions, 4 deletions
diff --git a/editors/apel-emacs/Makefile b/editors/apel-emacs/Makefile
index 14a151bf97a2..67dfb20d4798 100644
--- a/editors/apel-emacs/Makefile
+++ b/editors/apel-emacs/Makefile
@@ -3,7 +3,7 @@
# Date created: 23 September 1998
# Whom: Shigeyuki FUKUSHIMA <shige@kuis.kyoto-u.ac.jp>
#
-# $Id: Makefile,v 1.1.1.1 1999/01/02 13:26:51 kuriyama Exp $
+# $Id: Makefile,v 1.2 1999/01/11 10:27:46 asami Exp $
#
DISTNAME= apel-${APEL_VER}
@@ -30,15 +30,18 @@ REQUIRE_SETUPEL= YES
# target name for make build
ALL_TARGET?= elc
-.if defined(EMACS_PORT)
-PKGNAME= apel-${EMACS_PORT}-${APEL_VER}
-EMACS_CMD= ${PREFIX}/bin/${EMACS_NAME}-${EMACS_VER}
+# if RUN_DEPENDS emacs port name has the suffix `-common'
.if !defined(HAVE_COMMON_PORT)
HAVE_COMMON_PORT= NO
.endif
+# if RUN_DEPENDS emacs needs setup elisp
.if !defined(REQUIRE_SETUPEL)
REQUIRE_SETUPEL= NO
.endif
+
+.if defined(EMACS_PORT)
+PKGNAME= apel-${EMACS_PORT}-${APEL_VER}
+EMACS_CMD= ${PREFIX}/bin/${EMACS_NAME}-${EMACS_VER}
BUILD_DEPENDS= ${EMACS_CMD}:${PORTSDIR}/editors/${EMACS_PORT}
.if defined(HAVE_COMMON_PORT) && (${HAVE_COMMON_PORT} == "YES")
RUN_DEPENDS= ${EMACS_CMD}:${PORTSDIR}/editors/${EMACS_PORT}-common
diff --git a/editors/apel-emacs/scripts/configure b/editors/apel-emacs/scripts/configure
index 8c2d04dc6aa9..0abb914d60d4 100644
--- a/editors/apel-emacs/scripts/configure
+++ b/editors/apel-emacs/scripts/configure
@@ -4,9 +4,11 @@ TARGETS='apel-setup.el'
for i in ${TARGETS}
do
+ if [ -f ${WRKDIR}/${i}.in ]; then
cat ${WRKDIR}/${i}.in | /usr/bin/sed \
-e "s;@@PREFIX@@;${PREFIX};g" \
-e "s;@@EMACS_LIBDIR@@;${EMACS_LIBDIR};g" \
-e "s;@@EMACS_VER@@;${EMACS_VER};g" \
> ${WRKDIR}/${i}
+ fi
done