aboutsummaryrefslogtreecommitdiff
path: root/editors/bitmap/Makefile
diff options
context:
space:
mode:
authorJustin M. Seger <jseger@FreeBSD.org>2000-06-27 01:00:47 +0000
committerJustin M. Seger <jseger@FreeBSD.org>2000-06-27 01:00:47 +0000
commit4425d0c3f0ff927c92718eef5f2ff47923d3e810 (patch)
treeca37832834237f7740672f74ab05a6687cf611d7 /editors/bitmap/Makefile
parent768ead95980037ad0274ff63c19c35fbc43aa67e (diff)
downloadports-4425d0c3f0ff927c92718eef5f2ff47923d3e810.tar.gz
ports-4425d0c3f0ff927c92718eef5f2ff47923d3e810.zip
Use EMACS_PORTS_VERSION
Notes
Notes: svn path=/head/; revision=29898
Diffstat (limited to 'editors/bitmap/Makefile')
-rw-r--r--editors/bitmap/Makefile16
1 files changed, 6 insertions, 10 deletions
diff --git a/editors/bitmap/Makefile b/editors/bitmap/Makefile
index 8ed332826fc8..c3c97540f6ac 100644
--- a/editors/bitmap/Makefile
+++ b/editors/bitmap/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
#
-PORTNAME= bitmap-${EMACS_PORT}
+PORTNAME= bitmap-${EMACS_PORT_NAME}
PORTVERSION= ${BITMAP_VER}
CATEGORIES= editors elisp
MASTER_SITES= ftp://ftp.jpl.org/pub/elisp/bitmap/
@@ -19,19 +19,15 @@ BITMAPDOCDIR= share/doc/bitmap
BITMAP_FONT= ${X11BASE}/lib/X11/fonts/local/etl8x16-bitmap.pcf.gz
# emacs20
-EMACS_NAME= emacs
-EMACS_PORT= emacs20
-EMACS_VER= 20.6
-EMACS_LIBDIR= share/${EMACS_NAME}
-EMACS_LIBDIR_WITH_VER= ${EMACS_LIBDIR}/${EMACS_VER}
+EMACS_PORT_NAME= emacs20
# target name for make build
ALL_TARGET= elc
EMACS_CMD= ${PREFIX}/bin/${EMACS_NAME}-${EMACS_VER}
-BUILD_DEPENDS= ${EMACS_CMD}:${PORTSDIR}/editors/${EMACS_PORT} \
+BUILD_DEPENDS= ${EMACS_CMD}:${PORTSDIR}/editors/${EMACS_PORT_NAME} \
uncompface:${PORTSDIR}/mail/faces
-RUN_DEPENDS= ${EMACS_CMD}:${PORTSDIR}/editors/${EMACS_PORT} \
+RUN_DEPENDS= ${EMACS_CMD}:${PORTSDIR}/editors/${EMACS_PORT_NAME} \
${BITMAP_FONT}:${PORTSDIR}/x11-fonts/bitmap-font
SCRIPTS_ENV= EMACS_LIBDIR=${EMACS_LIBDIR} EMACS_VER=${EMACS_VER} \
EMACS_LIBDIR_WITH_VER=${EMACS_LIBDIR_WITH_VER}
@@ -41,8 +37,8 @@ PLIST_SUB= EMACS_LIBDIR=${EMACS_LIBDIR} EMACS_VER=${EMACS_VER} \
MAKE_FLAGS= EMACS=${EMACS_CMD}
# depends on apel
-BUILD_DEPENDS+= ${PREFIX}/${EMACS_LIBDIR}/${EMACS_VER}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT}
-RUN_DEPENDS+= ${PREFIX}/${EMACS_LIBDIR}/${EMACS_VER}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT}
+BUILD_DEPENDS+= ${PREFIX}/${EMACS_LIBDIR}/${EMACS_VER}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
+RUN_DEPENDS+= ${PREFIX}/${EMACS_LIBDIR}/${EMACS_VER}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel-${EMACS_PORT_NAME}
post-install:
.if !defined(NOPORTDOCS)