aboutsummaryrefslogtreecommitdiff
path: root/editors/bitmap/Makefile
diff options
context:
space:
mode:
authorHajimu UMEMOTO <ume@FreeBSD.org>2006-11-05 11:53:47 +0000
committerHajimu UMEMOTO <ume@FreeBSD.org>2006-11-05 11:53:47 +0000
commit4e3c863354fc22ec701ef0db8ecf0819807adb52 (patch)
tree2440d9a85e84b4318b2d1afc9895f8ce03484f1d /editors/bitmap/Makefile
parent052bb4cbaa60852c0eb6d3f9e1f117278f61e04f (diff)
downloadports-4e3c863354fc22ec701ef0db8ecf0819807adb52.tar.gz
ports-4e3c863354fc22ec701ef0db8ecf0819807adb52.zip
Obey user setting of EMACS_PORT_NAME to be friendry for emacs22.
Notes
Notes: svn path=/head/; revision=176473
Diffstat (limited to 'editors/bitmap/Makefile')
-rw-r--r--editors/bitmap/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/editors/bitmap/Makefile b/editors/bitmap/Makefile
index d65acf2706cf..a39243142827 100644
--- a/editors/bitmap/Makefile
+++ b/editors/bitmap/Makefile
@@ -41,8 +41,8 @@ PORTCLASS?= master
# Setup EMACS_PORT_NAME variable.
.if (${PORTCLASS} == "master")
USE_EMACS= yes
-EMACS_PORT_NAME= emacs21
-DEPPORT_SUFFIX=
+EMACS_PORT_NAME?= emacs21
+DEPPORT_SUFFIX=
.else
DEPPORT_SUFFIX= -${EMACS_PORT_NAME}
.endif
@@ -67,6 +67,10 @@ MAKE_ARGS= PREFIX="${LOCALBASE}" \
# depends on apel
BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR}/${EMACS_VER}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel${DEPPORT_SUFFIX}
RUN_DEPENDS+= ${LOCALBASE}/${EMACS_LIBDIR}/${EMACS_VER}/site-lisp/emu/emu.el:${PORTSDIR}/editors/apel${DEPPORT_SUFFIX}
+.if (${EMACS_PORT_NAME} == "emacs21") || (${EMACS_PORT_NAME} == "emacs22")
+DESCR= ${PKGDIR}/pkg-descr.emacs21
+PLIST= ${PKGDIR}/pkg-plist.emacs21
+.endif
.else
.BEGIN:
@${ECHO} "Error: Bad port."