aboutsummaryrefslogtreecommitdiff
path: root/editors/calligra/Makefile
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2012-05-31 00:09:24 +0000
committerAlberto Villa <avilla@FreeBSD.org>2012-05-31 00:09:24 +0000
commit7b4e1ec4a5950c12e703456521df41ff4b698fd2 (patch)
tree23df0789e394e66dc29f4a94ba2d01086142182d /editors/calligra/Makefile
parent77e4ccd8f07053850940fe7c052b9e91fe7c30de (diff)
downloadports-7b4e1ec4a5950c12e703456521df41ff4b698fd2.tar.gz
ports-7b4e1ec4a5950c12e703456521df41ff4b698fd2.zip
The KDE/FreeBSD team is pleased to announce Calligra Suite 2.4.2, KDE
graphic art and office suite. Information on this release can be found here: http://www.calligra.org/news/calligra-2-4-2-released Information on Calligra Project can be found in its first ever release announcement: http://www.calligra.org/news/calligra-2-4-released Consequently, KOffice 2 has been removed from the ports collection. As usual, we would like to thank all testers and contributors.
Notes
Notes: svn path=/head/; revision=297847
Diffstat (limited to 'editors/calligra/Makefile')
-rw-r--r--editors/calligra/Makefile137
1 files changed, 81 insertions, 56 deletions
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index a6378d680dad..1bb9803f4af0 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -1,76 +1,79 @@
-# New ports collection makefile for: koffice-kde4
-# Date created: 2008-07-22
-# Whom: Max Brazhnikov <makc@issp.ac.ru>
+# New ports collection makefile for: calligra
+# Date created: 28 May 2011
+# Whom: Alberto Villa <avilla@FreeBSD.org>
#
# $FreeBSD$
#
-PORTNAME= koffice
-PORTVERSION= 2.3.3
-PORTREVISION= 7
+PORTNAME= calligra
+PORTVERSION= ${CALLIGRA_VERSION}
CATEGORIES= editors kde
MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= ${KOFFICE2_BRANCH}/${PORTNAME}-${PORTVERSION}/
-PKGNAMESUFFIX= -kde4
+MASTER_SITE_SUBDIR= ${CALLIGRA_BRANCH}/${PORTNAME}-${PORTVERSION}/
DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
-COMMENT= Office suite for KDE
+COMMENT= KDE graphic art and office suite
-BUILD_DEPENDS= eigen>=2.0.b3:${PORTSDIR}/math/eigen2 \
- gmm++>=3.0.4:${PORTSDIR}/math/gmm++ \
- ${LOCALBASE}/lib/libpqxx.a:${PORTSDIR}/databases/postgresql-libpqxx30
-LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs \
- qca.2:${PORTSDIR}/devel/qca \
- GraphicsMagick++.1:${PORTSDIR}/graphics/GraphicsMagick \
+LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
+ boost_thread.4:${PORTSDIR}/devel/boost-libs \
+ qca.2:${PORTSDIR}/devel/qca \
exiv2.10:${PORTSDIR}/graphics/exiv2 \
- jpeg.11:${PORTSDIR}/graphics/jpeg \
- kdcraw.20:${PORTSDIR}/graphics/libkdcraw-kde4 \
lcms2.2:${PORTSDIR}/graphics/lcms2 \
+ fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
+ freetype.9:${PORTSDIR}/print/freetype2 \
+ wpd-0.9.9:${PORTSDIR}/textproc/libwpd \
wpg-0.2:${PORTSDIR}/graphics/libwpg \
- png.6:${PORTSDIR}/graphics/png \
poppler-qt4.3:${PORTSDIR}/graphics/poppler-qt4 \
- tiff.4:${PORTSDIR}/graphics/tiff \
- gsl.16:${PORTSDIR}/math/gsl \
- freetype.9:${PORTSDIR}/print/freetype2 \
- qimageblitz.4:${PORTSDIR}/x11/qimageblitz \
- fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
- fftw3:${PORTSDIR}/math/fftw3 \
+ openjpeg.2:${PORTSDIR}/graphics/openjpeg \
+ jpeg.11:${PORTSDIR}/graphics/jpeg \
dcmdata.3:${PORTSDIR}/devel/dcmtk \
- okularcore.1:${PORTSDIR}/graphics/okular
-RUN_DEPENDS= ${LOCALBASE}/lib/libpqxx.a:${PORTSDIR}/databases/postgresql-libpqxx30
+ fftw3.6:${PORTSDIR}/math/fftw3 \
+ tiff.4:${PORTSDIR}/graphics/tiff \
+ gsl.16:${PORTSDIR}/math/gsl
+BUILD_DEPENDS= eigen>=2.0.b3:${PORTSDIR}/math/eigen2
-CONFLICTS= calligra-[0-9]*
+CONFLICTS= koffice-kde4-2.*
+CONFLICTS_BUILD= qt-3.*
+USE_GL= glew
+USE_GNOME= glib20 libxml2 libxslt
+USE_ICONV= yes
+USE_KDE4= kdehier kdelibs kdeprefix libkdcraw okular pimlibs \
+ automoc4 sharedmime soprano
+USE_PERL5= yes
+USE_QT4= dbus designer gui opengl phonon porting_build qt3support \
+ qtestlib_build script sql svg webkit xml xmlpatterns \
+ moc_build qmake_build rcc_build uic_build uic3_build
+USE_SQLITE= 3
USE_BZIP2= yes
USE_CMAKE= yes
-USE_ICONV= yes
-USE_PGSQL= yes
+CMAKE_OUTSOURCE= yes
+CMAKE_ARGS+= -DCMAKE_INCLUDE_PATH:STRING="${QT_INCDIR} ${LOCALBASE}/include" \
+ -DBUILD_active:BOOL=FALSE \
+ -DBUILD_mobile:BOOL=FALSE \
+ -DIHAVEPATCHEDQT:BOOL=TRUE # To be removed with Qt 4.8.2.
MAKE_JOBS_SAFE= yes
-USE_KDE4= kdelibs pimlibs kdehier kdeprefix sharedmime automoc4
-USE_QT_VER= 4
-QT_COMPONENTS= corelib phonon qmake_build moc_build porting_build rcc_build uic_build \
- uic3_build
-USE_GL= glut glew
USE_LDCONFIG= yes
-CMAKE_OUTSOURCE= yes
-
-CMAKE_ARGS+= -DCMAKE_INCLUDE_PATH:STRING="${QT_INCDIR} ${LOCALBASE}/include"
-
-LDFLAGS+= "-L${LOCALBASE}/lib"
+OPTIONS= GTL "Color transformations in Krita (requires LLVM)" off \
+ MARBLE "Support for globe widget" on \
+ MYSQL "MySQL support in Kexi" on \
+ PGSQL "PostgreSQL support in Kexi" on \
+ SYBASE "SyBase support in Kexi" off
-OPTIONS+= GTL "Color transformations in Krita" off
-OPTIONS+= SYBASE "SyBase support in Kexi" off
+.if exists(${LOCALBASE}/lib/pstoedit/libp2edrvlplot.so)
+BUILD_DEPENDS+= ${LOCALBASE}/lib/pstoedit/libp2edrvlplot.so:${PORTSDIR}/graphics/pstoedit
+RUN_DEPENDS+= ${LOCALBASE}/lib/pstoedit/libp2edrvlplot.so:${PORTSDIR}/graphics/pstoedit
+PLIST_SUB+= EPS=""
+.else
+PLIST_SUB+= EPS="@comment "
+.endif
.include <bsd.port.options.mk>
-.if exists(${LOCALBASE}/include/qconfig.h)
-IGNORE= does not build with x11-toolkits/qt33 installed. Please deinstall qt-3.x first
-.endif
-
-.if !defined(WITHOUT_GTL) || exists (${LOCALBASE}/lib/libQtShiva.so)
+.if defined(WITH_GTL) || exists(${LOCALBASE}/lib/libQtShiva.so)
LIB_DEPENDS+= OpenCTL.0:${PORTSDIR}/graphics/opengtl \
QtShiva.0:${PORTSDIR}/graphics/qtgtl
PLIST_SUB+= GTL=""
@@ -78,16 +81,33 @@ PLIST_SUB+= GTL=""
PLIST_SUB+= GTL="@comment "
.endif
-.if exists(${LOCALBASE}/lib/pstoedit/libp2edrvlplot.so)
-QT_COMPONENTS+= qt3support
-BUILD_DEPENDS+= ${LOCALBASE}/lib/pstoedit/libp2edrvlplot.so:${PORTSDIR}/graphics/pstoedit
-RUN_DEPENDS+= ${LOCALBASE}/lib/pstoedit/libp2edrvlplot.so:${PORTSDIR}/graphics/pstoedit
-PLIST_SUB+= EPS=""
+.if !defined(WITHOUT_MARBLE)
+USE_KDE4+= marble
+CMAKE_ARGS+= -DWITH_Marble:BOOL=TRUE
+PLIST_SUB+= MARBLE=""
.else
-PLIST_SUB+= EPS="@comment "
+CMAKE_ARGS+= -DWITH_Marble:BOOL=FALSE
+PLIST_SUB+= MARBLE="@comment "
+.endif
+
+.if !defined(WITHOUT_MYSQL) || exists(${LOCALBASE}/lib/mysql/libmysqlclient.so)
+USE_MYSQL= yes
+PLIST_SUB+= MYSQL=""
+.else
+PLIST_SUB+= MYSQL="@comment "
+.endif
+
+.if !defined(WITHOUT_PGSQL)
+USE_PGSQL= yes
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libpqxx.a:${PORTSDIR}/databases/postgresql-libpqxx30
+RUN_DEPENDS+= ${LOCALBASE}/lib/libpqxx.a:${PORTSDIR}/databases/postgresql-libpqxx30
+PLIST_SUB+= PGSQL=""
+.else
+CMAKE_ARGS+= -DWITH_PostgreSQL:BOOL=FALSE
+PLIST_SUB+= PGSQL="@comment "
.endif
-.if defined(WITH_SYBASE) || exists (${LOCALBASE}/lib/libsybdb.so)
+.if defined(WITH_SYBASE) || exists(${LOCALBASE}/lib/libsybdb.so)
LIB_DEPENDS+= sybdb.5:${PORTSDIR}/databases/freetds
PLIST_SUB+= SYBASE=""
.else
@@ -95,15 +115,20 @@ PLIST_SUB+= SYBASE="@comment "
.endif
post-patch:
-# prevent updating mime during build/install
- ${REINPLACE_CMD} -e '/^update_xdg_mimetypes/d; /SharedMimeInfo/d' \
- ${PATCH_WRKSRC}/krita/plugins/formats/ora/CMakeLists.txt
${REINPLACE_CMD} -e 's|/usr/X11R6|${LOCALBASE}|' \
${PATCH_WRKSRC}/cmake/modules/FindGLEW.cmake
${REINPLACE_CMD} -e 's|/opt/local|${LOCALBASE}|' \
${PATCH_WRKSRC}/cmake/modules/FindImageMagick.cmake
${REINPLACE_CMD} -e 's|/usr/include|${LOCALBASE}/include|' \
${PATCH_WRKSRC}/cmake/modules/FindWPD.cmake
+ ${REINPLACE_CMD} -e 's/^# *include *< *malloc\.h *>/#include <stdlib.h>/' \
+ ${PATCH_WRKSRC}/kexi/kexidb/parser/sqlparser.cpp \
+ ${PATCH_WRKSRC}/kexi/kexidb/parser/sqlparser.y \
+ ${PATCH_WRKSRC}/plan/plugins/schedulers/rcps/libs/src/*.c
+ # Prevent updating MIME during build/install.
+ ${REINPLACE_CMD} -e '/^update_xdg_mimetypes/ d; /SharedMimeInfo/ d' \
+ ${PATCH_WRKSRC}/filters/libmsooxml/CMakeLists.txt \
+ ${PATCH_WRKSRC}/krita/plugins/formats/ora/CMakeLists.txt
post-install:
@-update-mime-database ${PREFIX}/share/mime