aboutsummaryrefslogtreecommitdiff
path: root/editors/codelite
diff options
context:
space:
mode:
authorMahdi Mokhtari <mmokhi@FreeBSD.org>2018-01-18 11:16:24 +0000
committerMahdi Mokhtari <mmokhi@FreeBSD.org>2018-01-18 11:16:24 +0000
commit42c1216a4eb99942285763811950600a7db19197 (patch)
tree415463e92c7ab0cbba4f1ae31c66d234be0050a2 /editors/codelite
parentcd883f5f56e2f00d00828ad10c721764cebec19b (diff)
downloadports-42c1216a4eb99942285763811950600a7db19197.tar.gz
ports-42c1216a4eb99942285763811950600a7db19197.zip
editors/codelite: Fix build when devel/check is installed.
Set correct include-path if devel/check is installed for check.h PR: 218297 Submitted by: w.schwarzenfeld@utanet.at Reported by: w.schwarzenfeld@utanet.at
Notes
Notes: svn path=/head/; revision=459322
Diffstat (limited to 'editors/codelite')
-rw-r--r--editors/codelite/files/patch-sdk_codelite__cppcheck_CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/editors/codelite/files/patch-sdk_codelite__cppcheck_CMakeLists.txt b/editors/codelite/files/patch-sdk_codelite__cppcheck_CMakeLists.txt
new file mode 100644
index 000000000000..33ec9aaf736d
--- /dev/null
+++ b/editors/codelite/files/patch-sdk_codelite__cppcheck_CMakeLists.txt
@@ -0,0 +1,14 @@
+--- sdk/codelite_cppcheck/CMakeLists.txt.orig 2018-01-17 21:37:24 UTC
++++ sdk/codelite_cppcheck/CMakeLists.txt
+@@ -5,8 +5,10 @@ cmake_minimum_required(VERSION 2.6.2)
+ # visual studio, and in our makefiles.
+ project(codelitegcc)
+
++set (CMAKE_INCLUDE_DIRECTORIES ON)
++
+ # Include paths
+-include_directories("${CL_SRC_ROOT}/sdk/codelite_cppcheck/lib" "${CL_SRC_ROOT}/sdk/codelite_cppcheck/cli")
++include_directories(BEFORE "${CL_SRC_ROOT}/sdk/codelite_cppcheck/lib" "${CL_SRC_ROOT}/sdk/codelite_cppcheck/cli")
+
+ set( ADDITIONAL_LIBRARIES "" )
+