aboutsummaryrefslogtreecommitdiff
path: root/editors/emacs/Makefile
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-03-21 07:39:49 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-03-21 07:39:49 +0000
commit131cd97388c78909b13a26c3ce289bbf3c007b7f (patch)
treed22f5aaa16546b9e90fc0a35df15ff1dc17c67e9 /editors/emacs/Makefile
parenta4ec4cda7de50f10ddf987112732dbd1e3e29557 (diff)
downloadports-131cd97388c78909b13a26c3ce289bbf3c007b7f.tar.gz
ports-131cd97388c78909b13a26c3ce289bbf3c007b7f.zip
Move the ancient emacs 19.x port from editors/emacs to
editors/emacs19, and update the main emacs port to 21.x by copying from editors/emacs21. Retire the editors/emacs21 port. PR: ports/24983
Notes
Notes: svn path=/head/; revision=104813
Diffstat (limited to 'editors/emacs/Makefile')
-rw-r--r--editors/emacs/Makefile97
1 files changed, 62 insertions, 35 deletions
diff --git a/editors/emacs/Makefile b/editors/emacs/Makefile
index 44214c05e8a2..74fde6802d29 100644
--- a/editors/emacs/Makefile
+++ b/editors/emacs/Makefile
@@ -1,53 +1,80 @@
# New ports collection makefile for: GNU emacs
-# Date created: 29 October 1994
-# Whom: jkh
+# Date created: 11 October 2001
+# Whom: MANTANI Nobutaka <nobutaka@nobutaka.com>
#
# $FreeBSD$
#
PORTNAME= emacs
-PORTVERSION= 19.34b
-PORTREVISION= 1
-CATEGORIES= editors
-MASTER_SITES= ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= emacs
+PORTVERSION= 21.3
+PORTREVISION= 2
+CATEGORIES= editors ipv6
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= nobutaka@FreeBSD.org
COMMENT= GNU editing macros
-EMACS_VERSION= 19.34
-CONFIGURE_TARGET= ${MACHINE_ARCH}--freebsd
-PLIST_SUB= EMACS_VERSION=${EMACS_VERSION} EMACS_ARCH=${CONFIGURE_TARGET}
-NO_LATEST_LINK= yes
-WRKSRC= ${WRKDIR}/emacs-19.34
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
.if !defined(WITHOUT_X11)
-CONFIGURE_ARGS= --with-x-toolkit --sharedstatedir=/var/run
+LIB_DEPENDS= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ tiff.4:${PORTSDIR}/graphics/tiff \
+ ungif.5:${PORTSDIR}/graphics/libungif \
+ png.5:${PORTSDIR}/graphics/png
USE_XLIB= yes
-.else
-CONFIGURE_ARGS= --with-x=no --sharedstatedir=/var/run
+USE_XPM= yes
.endif
-STRIP=
-MAN1= emacs.1 etags.1 ctags.1
+.if defined(WITH_MENUBAR_FONTSET)
+PATCH_SITES= http://www.nijino.com/ari/emacs/
+PATCHFILES= emacs-21.1-fontset.patch emacs-21.2-menu-encode.patch
+PATCH_DIST_STRIP= -p1
+.endif
-.include <bsd.port.pre.mk>
+USE_AUTOCONF_VER=213
+USE_GMAKE= yes
-.if ${ARCH} != "i386" && ${OSVERSION} >= 502102
-BROKEN= "Does not compile on !i386 5.x"
+CONFIGURE_TARGET= ${MACHINE_ARCH}--freebsd
+.if defined(WITHOUT_X11)
+CONFIGURE_ARGS= --with-x=no
+.endif
+.if defined(WITHOUT_XIM)
+CONFIGURE_ARGS+= --without-xim
.endif
+MAN1= ctags.1 emacs.1 etags.1 gfdl.1
+PLIST_SUB= EMACS_VER=${PORTVERSION} EMACS_ARCH=${CONFIGURE_TARGET}
+TEXIFILES= ada-mode autotype cc-mode cl dired-x ebrowse ediff \
+ faq emacs emacs-mime eshell eudc forms gnus idlwave \
+ info message mh-e pcl-cvs reftex sc speedbar vip \
+ viper widget woman
+
+LATEST_LINK= emacs
+
+pre-everything::
+.if !defined(WITH_MENUBAR_FONTSET)
+ @${ECHO_MSG} "====>"
+ @${ECHO_MSG} "====> To enable menubar fontset support, define WITH_MENUBAR_FONTSET"
+ @${ECHO_MSG} "====>"
+.endif
+
+post-patch:
+ @${RM} -f ${WRKSRC}/info/*
+ @(cd ${WRKSRC}/man ; \
+ for f in ${TEXIFILES} ; do \
+ ${CP} $${f}.texi $${f}.texi.orig ; \
+ ${SED} -e "s/@dircategory Emacs/@dircategory The Emacs editor and associated tools/" < $${f}.texi.orig > $${f}.texi ; \
+ ${RM} $${f}.texi.orig ; \
+ done)
+
+post-build:
+ (cd ${WRKSRC}/lisp ; \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} recompile ; \
+ ${RM} ${WRKSRC}/src/emacs ${WRKSRC}/src/emacs-${PORTVERSION}.1 ; \
+ cd ${WRKSRC}/src ; \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
+
post-install:
-.for file in emacs-19.34 emacsclient etags ctags b2m
- ${STRIP_CMD} ${PREFIX}/bin/${file}
-.endfor
-.for info in emacs vip viper forms gnus mh-e cl sc dired-x ediff ccmode message
- install-info ${PREFIX}/info/${info} ${PREFIX}/info/dir
-.endfor
-# install emacs.sh into ${PREFIX}/etc/rc.d
- ${CHMOD} 1777 /var/run/emacs/lock
- @${MKDIR} ${PREFIX}/etc/rc.d
- @${INSTALL_SCRIPT} ${FILESDIR}/emacs.sh ${PREFIX}/etc/rc.d
-
-.include <bsd.port.post.mk>
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>