aboutsummaryrefslogtreecommitdiff
path: root/editors/emacs21/Makefile
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2001-12-06 12:29:41 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2001-12-06 12:29:41 +0000
commitb0eea5e5bd47134455311cd65f6e69677e9e0517 (patch)
tree14c9396091de5f9b82da8627a42900df4f8b711c /editors/emacs21/Makefile
parenta553b7fb34874296f513a6042f6149ef6b27db15 (diff)
downloadports-b0eea5e5bd47134455311cd65f6e69677e9e0517.tar.gz
ports-b0eea5e5bd47134455311cd65f6e69677e9e0517.zip
Set ALL_TARGET=bootstrap to byte-compile patched elisp files.
Add WITHOUT_XIM and WITHOUT_MENUBAR_FONTSET switch. Make dired output in Japanese locale the same as FreeBSD ls. Submitted by: kuriyama, yoichi Reviewed by: knu
Notes
Notes: svn path=/head/; revision=51135
Diffstat (limited to 'editors/emacs21/Makefile')
-rw-r--r--editors/emacs21/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/editors/emacs21/Makefile b/editors/emacs21/Makefile
index 9c904a745dfb..bdff403dadc0 100644
--- a/editors/emacs21/Makefile
+++ b/editors/emacs21/Makefile
@@ -7,15 +7,11 @@
PORTNAME= emacs
PORTVERSION= 21.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= editors ipv6
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
-PATCH_SITES= http://www.nijino.com/ari/patches/
-PATCHFILES= emacs-21.1-fontset-20011109.patch.gz
-PATCH_DIST_STRIP= -p1
-
MAINTAINER= nobutaka@FreeBSD.org
.if !defined(WITHOUT_X11)
@@ -28,13 +24,23 @@ USE_XLIB= yes
USE_XPM= yes
.endif
+.if !defined(WITHOUT_MENUBAR_FONTSET)
+PATCH_SITES= http://www.nijino.com/ari/patches/
+PATCHFILES= emacs-21.1-fontset-20011109.patch.gz
+PATCH_DIST_STRIP= -p1
+.endif
+
USE_AUTOCONF= yes
USE_GMAKE= yes
+ALL_TARGET= bootstrap
CONFIGURE_TARGET= ${MACHINE_ARCH}--freebsd
.if defined(WITHOUT_X11)
CONFIGURE_ARGS= --with-x=no
.endif
+.if defined(WITHOUT_XIM)
+CONFIGURE_ARGS+= --without-xim
+.endif
MAN1= ctags.1 emacs.1 etags.1 gfdl.1
PLIST_SUB= EMACS_VER=${PORTVERSION} EMACS_ARCH=${CONFIGURE_TARGET}