aboutsummaryrefslogtreecommitdiff
path: root/editors/etoile-typewriter
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-12-22 12:59:07 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-12-22 12:59:07 +0000
commit9b4ddb8720b28714bf8f9d0f29fa64384cd8149f (patch)
tree69761f284b890cd7c5021da052a6af2982cddcbe /editors/etoile-typewriter
parent6e8f5a309f860ba740b667a3cc2cf44b5431e938 (diff)
downloadports-9b4ddb8720b28714bf8f9d0f29fa64384cd8149f.tar.gz
ports-9b4ddb8720b28714bf8f9d0f29fa64384cd8149f.zip
Etoile intends to be an innovative GNUstep based user environnement built
from the ground up on highly modular and light components with project and document orientation in mind, in order to allow users to create their own workflow by reshaping or recombining provided Services (aka Applications), Components etc. Flexibility and modularity on both User Interface and code level should allow us to scale from PDA to computer environment. Typewriter is a general text editor for plain and rich format text. WWW: http://www.etoile-project.org/
Notes
Notes: svn path=/head/; revision=180489
Diffstat (limited to 'editors/etoile-typewriter')
-rw-r--r--editors/etoile-typewriter/Makefile30
-rw-r--r--editors/etoile-typewriter/distinfo3
-rw-r--r--editors/etoile-typewriter/files/patch-WorkspaceController.m10
-rw-r--r--editors/etoile-typewriter/pkg-descr10
-rw-r--r--editors/etoile-typewriter/pkg-plist16
5 files changed, 69 insertions, 0 deletions
diff --git a/editors/etoile-typewriter/Makefile b/editors/etoile-typewriter/Makefile
new file mode 100644
index 000000000000..e44ce7b51cc4
--- /dev/null
+++ b/editors/etoile-typewriter/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: etoile-typewriter
+# Date created: 19 Nov 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= typewriter
+PORTVERSION= 0.1.${SNAPSHOT}
+CATEGORIES= editors
+MASTER_SITES= http://florida.ethz.ch/ports/distfiles/
+PKGNAMEPREFIX= etoile-
+DISTNAME= etoile_0+${SNAPSHOT}+dfsg.orig
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= General text editor for plain and rich format text
+
+SNAPSHOT= 20060917
+WRKSRC= ${WRKDIR}/etoile-0+${SNAPSHOT}+dfsg/Etoile/
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+USE_GNUSTEP_LOCAL_LIBS+= OgreKit:${OGREKIT_PORT}
+USE_GNUSTEP_MAKE_DIRS+= Services/User/Typewriter
+
+OGREKIT_PORT?= textproc/etoile-ogrekit
+
+.include <bsd.port.mk>
diff --git a/editors/etoile-typewriter/distinfo b/editors/etoile-typewriter/distinfo
new file mode 100644
index 000000000000..2d5c7ccf5d13
--- /dev/null
+++ b/editors/etoile-typewriter/distinfo
@@ -0,0 +1,3 @@
+MD5 (etoile_0+20060917+dfsg.orig.tar.gz) = bc96dcaba7ac66abb1320d5cfc98f05e
+SHA256 (etoile_0+20060917+dfsg.orig.tar.gz) = de7cb026ccebdbb72d115ca800a13910cd51c9df27f5578ad7059b13f88eb334
+SIZE (etoile_0+20060917+dfsg.orig.tar.gz) = 10478850
diff --git a/editors/etoile-typewriter/files/patch-WorkspaceController.m b/editors/etoile-typewriter/files/patch-WorkspaceController.m
new file mode 100644
index 000000000000..b188a17732e8
--- /dev/null
+++ b/editors/etoile-typewriter/files/patch-WorkspaceController.m
@@ -0,0 +1,10 @@
+--- Services/Private/Workspace/WorkspaceController.m.orig Sun Sep 17 21:02:12 2006
++++ Services/Private/Workspace/WorkspaceController.m Sun Nov 19 20:13:52 2006
+@@ -28,6 +28,7 @@
+
+ #import <Foundation/Foundation.h>
+ #import <AppKit/AppKit.h>
++#import <TrackerKit/TKQuery.h>
+ #import <ExtendedWorkspaceKit/ExtendedWorkspaceKit.h>
+ #import "WkContextWindowController.h"
+ #import "WorkspaceController.h"
diff --git a/editors/etoile-typewriter/pkg-descr b/editors/etoile-typewriter/pkg-descr
new file mode 100644
index 000000000000..10da750cfb18
--- /dev/null
+++ b/editors/etoile-typewriter/pkg-descr
@@ -0,0 +1,10 @@
+Etoile intends to be an innovative GNUstep based user environnement built
+from the ground up on highly modular and light components with project and
+document orientation in mind, in order to allow users to create their own
+workflow by reshaping or recombining provided Services (aka Applications),
+Components etc. Flexibility and modularity on both User Interface and code
+level should allow us to scale from PDA to computer environment.
+
+Typewriter is a general text editor for plain and rich format text.
+
+WWW: http://www.etoile-project.org/
diff --git a/editors/etoile-typewriter/pkg-plist b/editors/etoile-typewriter/pkg-plist
new file mode 100644
index 000000000000..d0fe3593d51a
--- /dev/null
+++ b/editors/etoile-typewriter/pkg-plist
@@ -0,0 +1,16 @@
+Local/Applications/Typewriter.app/Resources/English.lproj/Document.gorm/data.classes
+Local/Applications/Typewriter.app/Resources/English.lproj/Document.gorm/data.info
+Local/Applications/Typewriter.app/Resources/English.lproj/Document.gorm/objects.gorm
+Local/Applications/Typewriter.app/Resources/English.lproj/MainMenu.gorm/data.classes
+Local/Applications/Typewriter.app/Resources/English.lproj/MainMenu.gorm/data.info
+Local/Applications/Typewriter.app/Resources/English.lproj/MainMenu.gorm/objects.gorm
+Local/Applications/Typewriter.app/Resources/Info-gnustep.plist
+Local/Applications/Typewriter.app/Resources/Typewriter.desktop
+Local/Applications/Typewriter.app/Typewriter
+Local/Applications/Typewriter.app/library_paths.openapp
+Local/Applications/Typewriter.app/stamp.make
+@dirrm Local/Applications/Typewriter.app/Resources/English.lproj/MainMenu.gorm
+@dirrm Local/Applications/Typewriter.app/Resources/English.lproj/Document.gorm
+@dirrm Local/Applications/Typewriter.app/Resources/English.lproj
+@dirrm Local/Applications/Typewriter.app/Resources
+@dirrm Local/Applications/Typewriter.app