aboutsummaryrefslogtreecommitdiff
path: root/editors/kate-plugins/Makefile
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-03-09 12:56:31 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-03-09 12:56:31 +0000
commitc726e8e6f34a5a230d144029accbc96869835542 (patch)
tree4c6754347adad0ec229fb133cc4725530aa263b2 /editors/kate-plugins/Makefile
parente20877a3a93950a65b7723430c213ba23cd2eb22 (diff)
downloadports-c726e8e6f34a5a230d144029accbc96869835542.tar.gz
ports-c726e8e6f34a5a230d144029accbc96869835542.zip
Add kate-plugins, additional plugins and features for kate (part of kdebase).
Notes
Notes: svn path=/head/; revision=103391
Diffstat (limited to 'editors/kate-plugins/Makefile')
-rw-r--r--editors/kate-plugins/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/editors/kate-plugins/Makefile b/editors/kate-plugins/Makefile
new file mode 100644
index 000000000000..58818e76d56f
--- /dev/null
+++ b/editors/kate-plugins/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: kdeaddons-kate-plugins
+# Date created: 11 Feb 2004 19:51:40
+# Whom: Michael Nottebrock <lofi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ${KATEPLUGINS_PORTNAME}
+PORTVERSION= ${KATEPLUGINS_PORTVERSION}
+PORTREVISION= ${KATEPLUGINS_PORTREVISION}
+CATEGORIES= editors kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Additonal plugins and features for kate
+
+IGNORE= This port is part of KDE 3.2.1 and is not yet ready
+
+KDE_SPLIT= kate
+KDE_DOC_SPLIT= kate-plugins
+USE_KDEBASE_VER=3
+USE_KDELIBS_VER=3
+
+USE_BZIP2= yes
+PREFIX= ${KDE_PREFIX}
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+INSTALLS_SHLIB= yes
+LDCONFIG_DIRS+= %%PREFIX%%/lib/kde3
+
+.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
+.include "${.CURDIR}/../../misc/kdeaddons3/Makefile.split"
+.include <bsd.port.mk>