aboutsummaryrefslogtreecommitdiff
path: root/editors/leafpad/Makefile
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2023-02-15 16:59:47 +0000
committerJason Helfman <jgh@FreeBSD.org>2023-02-15 17:04:00 +0000
commitcab0892e2d7d4dbf6676a1bb32249f8f0dbcad8a (patch)
tree66acabf41c5b48bdd904b01bbae9d6a1696ad9b0 /editors/leafpad/Makefile
parentba49bacd39547ace5ec3dc7c4310eb126f9b30f4 (diff)
downloadports-cab0892e2d7d4dbf6676a1bb32249f8f0dbcad8a.tar.gz
ports-cab0892e2d7d4dbf6676a1bb32249f8f0dbcad8a.zip
editors/leafpad: update to v0.8.19, adjust dependencies
- options for docs/nls
Diffstat (limited to 'editors/leafpad/Makefile')
-rw-r--r--editors/leafpad/Makefile21
1 files changed, 15 insertions, 6 deletions
diff --git a/editors/leafpad/Makefile b/editors/leafpad/Makefile
index 183bfb4b2474..5ac2973fdee4 100644
--- a/editors/leafpad/Makefile
+++ b/editors/leafpad/Makefile
@@ -1,6 +1,5 @@
PORTNAME= leafpad
-PORTVERSION= 0.8.18.1
-PORTREVISION= 2
+PORTVERSION= 0.8.19
CATEGORIES= editors
MASTER_SITES= SAVANNAH
@@ -10,8 +9,12 @@ WWW= http://tarot.freeshell.org/leafpad/
LICENSE= GPLv2
-USE_GNOME= gtk20 intlhack
-USES= desktop-file-utils gettext gmake gnome pkgconfig
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libharfbuzz.so:print/harfbuzz
+
+USES= desktop-file-utils gmake gnome pkgconfig
+USE_GNOME= cairo gdkpixbuf2 gtk20 intlhack
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-chooser
CPPFLAGS+= -I${LOCALBASE}/include
@@ -19,12 +22,18 @@ LDFLAGS+= -lpthread -L${LOCALBASE}/lib
PORTDOCS= AUTHORS COPYING ChangeLog INSTALL README
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+
+.include <bsd.port.options.mk>
post-extract:
@${CHMOD} a+x ${WRKSRC}/install-sh
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}