aboutsummaryrefslogtreecommitdiff
path: root/editors/lfhex
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-10-16 20:27:06 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-10-16 20:27:06 +0000
commit09c23c8eff999c2a0038c26923e9567b0ecc5cde (patch)
tree553be5c648c2a791790eeddfa8fa52185228b451 /editors/lfhex
parent7e9c9e9a3b516119ad2093e3331a0b425825c5f0 (diff)
downloadports-09c23c8eff999c2a0038c26923e9567b0ecc5cde.tar.gz
ports-09c23c8eff999c2a0038c26923e9567b0ecc5cde.zip
- Update to version 0.3.4
- Unbreak on -current PR: 58126 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=91452
Diffstat (limited to 'editors/lfhex')
-rw-r--r--editors/lfhex/Makefile33
-rw-r--r--editors/lfhex/distinfo2
-rw-r--r--editors/lfhex/files/patch-hexEditor.cpp11
-rw-r--r--editors/lfhex/files/patch-hexGui.cpp10
-rw-r--r--editors/lfhex/files/patch-src::Makefile.in16
-rw-r--r--editors/lfhex/files/patch-src::reader.cpp16
6 files changed, 23 insertions, 65 deletions
diff --git a/editors/lfhex/Makefile b/editors/lfhex/Makefile
index a92b70fbe495..ff027bf65e57 100644
--- a/editors/lfhex/Makefile
+++ b/editors/lfhex/Makefile
@@ -7,34 +7,21 @@
#
PORTNAME= lfhex
-PORTVERSION= 0.3.2
-PORTREVISION= 2
+PORTVERSION= 0.3.4
CATEGORIES= editors
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= arved
+MASTER_SITES= http://home.earthlink.net/~eyekode/data/
-MAINTAINER= ports@freebsd.org
-COMMENT= "Large file hex editor"
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Large file hex editor
-USE_GETOPT_LONG=yes
-USE_REINPLACE= yes
USE_QT_VER= 3
+USE_GMAKE= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= QTDIR="${QT_PREFIX}"
CONFIGURE_ARGS= --with-qt-moc=${MOC}
-USE_GMAKE= yes
-CONFIGURE_ENV= CXXFLAGS="${PTHREAD_CFLAGS}"
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e "s,%%LOCALBASE%%,${LOCALBASE},g ; \
- s,%%X11BASE%%,${X11BASE},g" ${WRKSRC}/src/Makefile.in
-post-configure:
- ${REINPLACE_CMD} -e "s,LFLAGS =,LFLAGS = ${PTHREAD_LIBS} ${LDFLAGS}," ${WRKSRC}/src/Makefile
+MAKE_ARGS= EXEC_PREFIX="${PREFIX}/bin" \
+ IFLAGS="${QTCPPFLAGS} ${PTHREAD_CFLAGS}" \
+ LFLAGS="${QTCFGLIBS} -lqt-mt ${PTHREAD_LIBS}"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/editors/lfhex/distinfo b/editors/lfhex/distinfo
index 990b63c0fee3..e4c28dab4f9e 100644
--- a/editors/lfhex/distinfo
+++ b/editors/lfhex/distinfo
@@ -1 +1 @@
-MD5 (lfhex-0.3.2.tar.gz) = 28bcccd6bc77b8de92d31e9361b26531
+MD5 (lfhex-0.3.4.tar.gz) = 59aaa0ed92155106509a2cc9cb36bf1d
diff --git a/editors/lfhex/files/patch-hexEditor.cpp b/editors/lfhex/files/patch-hexEditor.cpp
deleted file mode 100644
index 37e262386879..000000000000
--- a/editors/lfhex/files/patch-hexEditor.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/hexEditor.cpp.orig Sun Feb 23 00:37:11 2003
-+++ src/hexEditor.cpp Sun Feb 23 00:38:31 2003
-@@ -22,6 +22,8 @@
- #include <qfiledialog.h>
- #include <qapplication.h>
- #include <qprogressdialog.h>
-+#include <qpainter.h>
-+#include <qpixmap.h>
-
- #include "config.h"
- #include "hexEditor.hpp"
diff --git a/editors/lfhex/files/patch-hexGui.cpp b/editors/lfhex/files/patch-hexGui.cpp
deleted file mode 100644
index 274e649e95ca..000000000000
--- a/editors/lfhex/files/patch-hexGui.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/hexGui.cpp.orig Sat Jul 7 04:16:01 2001
-+++ src/hexGui.cpp Sun Feb 23 00:40:32 2003
-@@ -24,6 +24,7 @@
- #include <qscrollbar.h>
- #include <qstring.h>
- #include <qmessagebox.h>
-+#include <qlineedit.h>
- //#include <qprogressbar.h>
- //#include <qtoolbar.h>
- //#include <qtoolbutton.h>
diff --git a/editors/lfhex/files/patch-src::Makefile.in b/editors/lfhex/files/patch-src::Makefile.in
deleted file mode 100644
index 855e2db88993..000000000000
--- a/editors/lfhex/files/patch-src::Makefile.in
+++ /dev/null
@@ -1,16 +0,0 @@
---- src/Makefile.in.orig Wed Jul 4 10:27:43 2001
-+++ src/Makefile.in Fri Jul 6 10:34:56 2001
-@@ -16,10 +16,10 @@
- endif
-
- CXXFLAGS = @CXXFLAGS@
--INCLUDE_DIRS = $(QTDIR)/include
-+INCLUDE_DIRS = %%X11BASE%%/include
- IFLAGS = $(addprefix -I,$(INCLUDE_DIRS))
--LIBRARIES = qt Xext X11 m
--LIB_DIRS = $(QTDIR)/lib /usr/X11R6/lib
-+LIBRARIES = qt-mt Xext X11 m
-+LIB_DIRS = $(QTDIR)/lib /usr/X11R6/lib
- LFLAGS = $(addprefix -L,$(LIB_DIRS)) $(addprefix -l,$(LIBRARIES))
-
- CXX_SRC = $(wildcard *.cpp)
diff --git a/editors/lfhex/files/patch-src::reader.cpp b/editors/lfhex/files/patch-src::reader.cpp
index 427ada379c0a..e487c0b5662f 100644
--- a/editors/lfhex/files/patch-src::reader.cpp
+++ b/editors/lfhex/files/patch-src::reader.cpp
@@ -1,6 +1,14 @@
---- src/reader.cpp.orig Sat Jul 7 04:16:01 2001
-+++ src/reader.cpp Sun Feb 23 00:46:53 2003
-@@ -227,7 +227,7 @@
+--- src/reader.cpp.orig Sat Jul 7 11:16:01 2001
++++ src/reader.cpp Thu Oct 16 20:54:13 2003
+@@ -13,6 +13,7 @@
+ #include <stdexcept>
+ #include <algorithm>
+ #include <new>
++#include <cassert>
+
+ // for stat:
+ #include <sys/types.h>
+@@ -227,7 +228,7 @@
// free the page which is the furthest away from the page we are loading
// this could be trouble if off_t is unsigned!
@@ -9,7 +17,7 @@
while(!freePage(_firstPage++));
else
while(!freePage(_lastPage--));
-@@ -285,7 +285,7 @@
+@@ -285,7 +286,7 @@
#ifdef LFHEX_IOS_BASE_FMTFLAGS
ostream& operator<< (ostream&out, const ReadBuffer& buff)
{