aboutsummaryrefslogtreecommitdiff
path: root/editors/libreoffice4
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2016-06-14 04:42:13 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2016-06-14 04:42:13 +0000
commit85903a014efd0162382c4f587ea845cee4806ed9 (patch)
treeb98bfba82faebcb94482018ed2503b7858395da5 /editors/libreoffice4
parent95fd56baa7e06d8ecf73bea0380a66cfff41bfc8 (diff)
downloadports-85903a014efd0162382c4f587ea845cee4806ed9.tar.gz
ports-85903a014efd0162382c4f587ea845cee4806ed9.zip
Fix build on head.
Notes
Notes: svn path=/head/; revision=416875
Diffstat (limited to 'editors/libreoffice4')
-rw-r--r--editors/libreoffice4/Makefile2
-rw-r--r--editors/libreoffice4/files/patch-configure.ac15
2 files changed, 12 insertions, 5 deletions
diff --git a/editors/libreoffice4/Makefile b/editors/libreoffice4/Makefile
index 916af3a9d2cc..8a61e8d9d6d2 100644
--- a/editors/libreoffice4/Makefile
+++ b/editors/libreoffice4/Makefile
@@ -113,8 +113,6 @@ CONFIGURE_ENV= DMAKE=${LOCALBASE}/bin/dmake \
GPERF=${LOCALBASE}/bin/gperf \
OPENCOLLADA_CFLAGS="${COLLADA_CFLAGS}" \
OPENCOLLADA_LIBS="${COLLADA_LIBS}" \
- OPENSSL_CFLAGS="-I/usr/include" \
- OPENSSL_LIBS="-lcrypto -lssl" \
PYTHON_CFLAGS="`${PYTHON_VERSION}-config --cflags`" \
PYTHON_LIBS="`${PYTHON_VERSION}-config --libs`"
diff --git a/editors/libreoffice4/files/patch-configure.ac b/editors/libreoffice4/files/patch-configure.ac
index 7e2d565076e7..d10b2fb99dec 100644
--- a/editors/libreoffice4/files/patch-configure.ac
+++ b/editors/libreoffice4/files/patch-configure.ac
@@ -1,6 +1,6 @@
---- configure.ac.orig 2015-01-28 07:00:34.000000000 -0500
-+++ configure.ac 2015-01-28 18:11:00.936172000 -0500
-@@ -7789,7 +7789,7 @@
+--- configure.ac.orig 2015-04-20 19:36:29 UTC
++++ configure.ac
+@@ -7798,7 +7798,7 @@ dnl Check for system libcmis
dnl ===================================================================
# libcmis requires curl and we can't build curl for iOS
if test $_os != iOS; then
@@ -9,3 +9,12 @@
ENABLE_CMIS=TRUE
else
ENABLE_CMIS=
+@@ -9428,7 +9428,7 @@ if test "$enable_openssl" = "yes"; then
+
+ with_system_openssl=no
+ libo_CHECK_SYSTEM_MODULE([openssl],[OPENSSL],[openssl])
+- elif test "$_os" = "NetBSD" -o "$_os" = "OpenBSD" -o "$_os" = "DragonFly" \
++ elif test "$_os" = "FreeBSD" -o "$_os" = "NetBSD" -o "$_os" = "OpenBSD" -o "$_os" = "DragonFly" \
+ && test "$with_system_openssl" != "no"; then
+ with_system_openssl=yes
+ SYSTEM_OPENSSL=TRUE