aboutsummaryrefslogtreecommitdiff
path: root/editors/mg
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-08-23 20:18:14 +0000
committerJohn Marino <marino@FreeBSD.org>2016-08-23 20:18:14 +0000
commit0dcc8837b70e8ee4751d38bda030a6e58e63f232 (patch)
treebe745c20cbfd619a0efd1d6dfc024d884a27165b /editors/mg
parent68cb68c92f2b9b59f8c0e11fa0e899e7a467b2a9 (diff)
downloadports-0dcc8837b70e8ee4751d38bda030a6e58e63f232.tar.gz
ports-0dcc8837b70e8ee4751d38bda030a6e58e63f232.zip
editors/mg: document and fix ncurses requirement
Approved by: ncurses blanket
Notes
Notes: svn path=/head/; revision=420741
Diffstat (limited to 'editors/mg')
-rw-r--r--editors/mg/Makefile2
-rw-r--r--editors/mg/files/patch-GNUmakefile22
-rw-r--r--editors/mg/files/patch-Makefile11
3 files changed, 35 insertions, 0 deletions
diff --git a/editors/mg/Makefile b/editors/mg/Makefile
index 426388f8a6a6..8860aa4b1c66 100644
--- a/editors/mg/Makefile
+++ b/editors/mg/Makefile
@@ -3,12 +3,14 @@
PORTNAME= mg
PORTVERSION= 20160421
+PORTREVISION= 1
CATEGORIES= editors
MASTER_SITES= http://homepage.boetes.org/software/mg/
MAINTAINER= darcsis@gmail.com
COMMENT= Small, fast Emacs-like editor
+USES= ncurses
PLIST_FILES= bin/mg man/man1/mg.1.gz
PORTDOCS= README tutorial
diff --git a/editors/mg/files/patch-GNUmakefile b/editors/mg/files/patch-GNUmakefile
new file mode 100644
index 000000000000..8aaf7ab71e43
--- /dev/null
+++ b/editors/mg/files/patch-GNUmakefile
@@ -0,0 +1,22 @@
+--- GNUmakefile.orig 2016-01-18 15:01:49 UTC
++++ GNUmakefile
+@@ -17,16 +17,10 @@ PKG_CONFIG= /usr/bin/pkg-config
+ INSTALL= /usr/bin/install
+ STRIP= /usr/bin/strip
+
+-UNAME:= $(shell uname)
+-ifeq ($(UNAME),FreeBSD)
+- BSD_CPPFLAGS:=
+- BSD_LIBS:= -lutil
+-else
+- BSD_CPPFLAGS:=$(shell $(PKG_CONFIG) --cflags libbsd-overlay)
+- BSD_LIBS:= $(shell $(PKG_CONFIG) --libs libbsd-overlay)
+-endif
++BSD_CPPFLAGS:=
++BSD_LIBS:= -lutil
+
+-CURSES_LIBS= -lcurses
++CURSES_LIBS= -lncurses
+
+ CC?= gcc
+ CFLAGS?= -O2 -pipe
diff --git a/editors/mg/files/patch-Makefile b/editors/mg/files/patch-Makefile
new file mode 100644
index 000000000000..fa86826ccd80
--- /dev/null
+++ b/editors/mg/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2016-01-07 18:55:54 UTC
++++ Makefile
+@@ -2,7 +2,7 @@
+
+ PROG= mg
+
+-LDADD+= -lcurses -lutil
++LDADD+= -lncurses -lutil
+ DPADD+= ${LIBCURSES} ${LIBUTIL}
+
+ # (Common) compile-time options: