aboutsummaryrefslogtreecommitdiff
path: root/editors/mg
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-20 08:11:09 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-20 08:11:09 +0000
commit863f1c2e18227a496ef958c6fdea96699035e165 (patch)
tree17fbcf972cd45266df4a24dafcd8a94f62754f80 /editors/mg
parent56862d4ebeea05e059855c7c1323d262b57a6e6e (diff)
downloadports-863f1c2e18227a496ef958c6fdea96699035e165.tar.gz
ports-863f1c2e18227a496ef958c6fdea96699035e165.zip
Support staging
Notes
Notes: svn path=/head/; revision=345179
Diffstat (limited to 'editors/mg')
-rw-r--r--editors/mg/Makefile18
1 files changed, 7 insertions, 11 deletions
diff --git a/editors/mg/Makefile b/editors/mg/Makefile
index 0644c4bd0e5e..8d1a4bba9b19 100644
--- a/editors/mg/Makefile
+++ b/editors/mg/Makefile
@@ -10,28 +10,24 @@ MASTER_SITES= ftp://ftp.SpringDaemons.com/soft/ \
MAINTAINER= darcsis@gmail.com
COMMENT= A small, fast Emacs-like editor
-MAN1= mg.1
-MANCOMPRESSED= no
-
-PLIST_FILES= bin/mg
+PLIST_FILES= bin/mg man/man1/mg.1.gz
PORTDOCS= README tutorial
HAS_CONFIGURE= yes
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
pre-configure:
@${REINPLACE_CMD} -e 's|-Wno-error=unused-but-set-variable||g' \
-e '/^CC=/d' -e 's|-g -Wall|-Wall|' -e 's|/usr/local|${PREFIX}|' \
${WRKSRC}/Makefile.in
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>