aboutsummaryrefslogtreecommitdiff
path: root/editors/mousepad/Makefile
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2013-04-23 17:43:17 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2013-04-23 17:43:17 +0000
commit1a8dedc83988ce043dc962b20d055c8fedc0e97d (patch)
tree6e22db9817d5fd0082fbb26aae461841839d8ad5 /editors/mousepad/Makefile
parent386b6ccecbe0253e45b33843649c7f2ad27c72d0 (diff)
downloadports-1a8dedc83988ce043dc962b20d055c8fedc0e97d.tar.gz
ports-1a8dedc83988ce043dc962b20d055c8fedc0e97d.zip
- Update to 0.3.0
- Trim Makefile header - Add new option DBUS - Convert to USES=desktop-file-utils gettext pathfix pkgconfig - Remove unneeded patch
Notes
Notes: svn path=/head/; revision=316383
Diffstat (limited to 'editors/mousepad/Makefile')
-rw-r--r--editors/mousepad/Makefile30
1 files changed, 18 insertions, 12 deletions
diff --git a/editors/mousepad/Makefile b/editors/mousepad/Makefile
index 4b95693db3f8..2aa8e31704f0 100644
--- a/editors/mousepad/Makefile
+++ b/editors/mousepad/Makefile
@@ -1,29 +1,35 @@
-# New ports collection makefile for: mousepad
-# Date created: 19 April 2006
-# Whom: Oliver Lehmann <oliver@FreeBSD.org>
-#
+# Created by: Oliver Lehmann <oliver@FreeBSD.org>
# $FreeBSD$
#
PORTNAME= mousepad
-PORTVERSION= 0.2.16
-PORTREVISION= 11
+PORTVERSION= 0.3.0
CATEGORIES= editors xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR=src/apps/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
-COMMENT= Simple Xfce editor
+COMMENT= Simple text editor for the Xfce Desktop
GNU_CONFIGURE= yes
USE_BZIP2= yes
-USE_GETTEXT= yes
USE_GMAKE= yes
-USE_GNOME= gtk20 intltool intlhack pkgconfig desktopfileutils
-USE_XFCE= configenv libgui
+USES= desktop-file-utils gettext pathfix pkgconfig
+USE_GNOME= glib20 gtk20 intltool intlhack gtksourceview2
+USE_XFCE= configenv
+USE_PERL5= yes
+
+OPTIONS_DEFINE= DBUS
+OPTIONS_DEFAULT= DBUS
+
+.include <bsd.port.options.mk>
-post-install:
- @-update-desktop-database
+.if ${PORT_OPTIONS:MDBUS}
+LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib
+CONFIGURE_ARGS+=--enable-dbus
+.else
+CONFIGURE_ARGS+=--disable-dbus
+.endif
.include <bsd.port.mk>