aboutsummaryrefslogtreecommitdiff
path: root/editors/nvi-devel
diff options
context:
space:
mode:
authorDima Dorfman <dd@FreeBSD.org>2001-07-07 23:45:42 +0000
committerDima Dorfman <dd@FreeBSD.org>2001-07-07 23:45:42 +0000
commit656dd7d5d23df631bfb4051a94be8d04c35a0ac2 (patch)
tree1747702aa718bb18d8de73a2dbd588a336475e52 /editors/nvi-devel
parent2d0a1eee6abbc701e09b8abc329078d7e581bdb1 (diff)
downloadports-656dd7d5d23df631bfb4051a94be8d04c35a0ac2.tar.gz
ports-656dd7d5d23df631bfb4051a94be8d04c35a0ac2.zip
Add nvi-devel, the development snapshot of nvi.
Notes
Notes: svn path=/head/; revision=44898
Diffstat (limited to 'editors/nvi-devel')
-rw-r--r--editors/nvi-devel/Makefile39
-rw-r--r--editors/nvi-devel/distinfo1
-rw-r--r--editors/nvi-devel/files/patch-configure-incl17
-rw-r--r--editors/nvi-devel/files/patch-lr-num19
-rw-r--r--editors/nvi-devel/pkg-comment1
-rw-r--r--editors/nvi-devel/pkg-descr4
-rw-r--r--editors/nvi-devel/pkg-plist5
7 files changed, 86 insertions, 0 deletions
diff --git a/editors/nvi-devel/Makefile b/editors/nvi-devel/Makefile
new file mode 100644
index 000000000000..2c14e6ebe2ed
--- /dev/null
+++ b/editors/nvi-devel/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: nvi-devel
+# Date created: 6 July 2001
+# Whom: dd
+#
+# $FreeBSD$
+#
+
+PORTNAME= nvi
+PORTVERSION= 1.81.4
+CATEGORIES= editors
+MASTER_SITES= http://www.kotnet.org/~skimo/nvi/devel/ \
+ ${MASTER_SITE_LOCAL} \
+ http://www.unixfreak.org/~dima/distfiles/
+MASTER_SITE_SUBDIR= dd
+
+MAINTAINER= dd@FreeBSD.org
+
+BUILD_DEPENDS= iconv:${PORTSDIR}/converters/iconv
+LIB_DEPENDS= db3.2:${PORTSDIR}/databases/db3
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/build.unix
+PATCH_WRKSRC= ${WRKDIR}
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ARGS+= --with-db3=${PREFIX}
+CONFIGURE_SCRIPT= ../dist/configure
+
+.include <bsd.port.pre.mk>
+
+# We need src/include/wchar.h and friends. This isn't the exact
+# version we need, but it's close enough.
+.if ${OSVERSION} < 500019
+BROKEN= "need wide character support"
+.endif
+
+post-install:
+ ${MV} ${PREFIX}/bin/vi ${PREFIX}/bin/nvi-devel
+
+.include <bsd.port.post.mk>
diff --git a/editors/nvi-devel/distinfo b/editors/nvi-devel/distinfo
new file mode 100644
index 000000000000..31e74af35959
--- /dev/null
+++ b/editors/nvi-devel/distinfo
@@ -0,0 +1 @@
+MD5 (nvi-1.81.4.tar.gz) = 5826bdceb43cb3787ee89ef57de033f6
diff --git a/editors/nvi-devel/files/patch-configure-incl b/editors/nvi-devel/files/patch-configure-incl
new file mode 100644
index 000000000000..475f48c03463
--- /dev/null
+++ b/editors/nvi-devel/files/patch-configure-incl
@@ -0,0 +1,17 @@
+# The db3 port installs its include files into ${PREFIX}/include/db3,
+# but the distfile assumes they're in ${PREFIX}/include. This seems
+# to be a FreeBSDism, so this patch has not, and probably should not,
+# be submitted to the maintainer.
+
+diff -ru nvi-1.81.4.orig/dist/configure nvi-1.81.4/dist/configure
+--- nvi-1.81.4.orig/dist/configure Mon Jun 18 14:24:37 2001
++++ nvi-1.81.4/dist/configure Fri Jul 6 03:27:53 2001
+@@ -6980,7 +6980,7 @@
+ saveLDFLAGS="$LDFLAGS"
+ if test "x$with_db3" != "x"; then
+ LDFLAGS="-L$with_db3/lib $LDFLAGS"
+- CFLAGS="-I$with_db3/include $CFLAGS"
++ CFLAGS="-I$with_db3/include -I$with_db3/include/db3 $CFLAGS"
+ fi;
+
+ echo $ac_n "checking for db_create in -ldb""... $ac_c" 1>&6
diff --git a/editors/nvi-devel/files/patch-lr-num b/editors/nvi-devel/files/patch-lr-num
new file mode 100644
index 000000000000..acad5ed93860
--- /dev/null
+++ b/editors/nvi-devel/files/patch-lr-num
@@ -0,0 +1,19 @@
+# This fixes an infinite loop in the case of:
+#
+# :set leftright
+# :set number
+#
+# See PR 28687. Patch has been submitted to maintainer.
+
+diff -ru nvi-1.81.4.orig/vi/vs_refresh.c nvi-1.81.4/vi/vs_refresh.c
+--- nvi-1.81.4.orig/vi/vs_refresh.c Wed Jul 19 10:05:20 2000
++++ nvi-1.81.4/vi/vs_refresh.c Sat Jul 7 16:11:51 2001
+@@ -573,7 +573,7 @@
+ * for the number option offset.
+ */
+ cnt = vs_columns(sp, NULL, LNO, &CNO, NULL);
+- if (O_ISSET(sp, O_NUMBER))
++ if (O_ISSET(sp, O_NUMBER) && cnt >= O_NUMBER_LENGTH)
+ cnt -= O_NUMBER_LENGTH;
+
+ /* Adjust the window towards the beginning of the line. */
diff --git a/editors/nvi-devel/pkg-comment b/editors/nvi-devel/pkg-comment
new file mode 100644
index 000000000000..82a97cb574b3
--- /dev/null
+++ b/editors/nvi-devel/pkg-comment
@@ -0,0 +1 @@
+Development snapshot of the world-renown nvi editor
diff --git a/editors/nvi-devel/pkg-descr b/editors/nvi-devel/pkg-descr
new file mode 100644
index 000000000000..870694d4fcf0
--- /dev/null
+++ b/editors/nvi-devel/pkg-descr
@@ -0,0 +1,4 @@
+This is the development snapshot of the world-renown nvi editor
+maintained by Sven Verdoolaege and Keith Bostic.
+
+WWW: http://www.kotnet.org/~skimo/nvi/
diff --git a/editors/nvi-devel/pkg-plist b/editors/nvi-devel/pkg-plist
new file mode 100644
index 000000000000..d21a1a2c276f
--- /dev/null
+++ b/editors/nvi-devel/pkg-plist
@@ -0,0 +1,5 @@
+bin/nvi-devel
+lib/libvi.a
+lib/libvi.la
+lib/libvi.so
+lib/libvi.so.0