aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice-4
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2015-10-23 23:22:24 +0000
committerDon Lewis <truckman@FreeBSD.org>2015-10-23 23:22:24 +0000
commita17bc80cb5dbdf95d7c0b2ef63c7f171c46473e5 (patch)
tree64d42f2dbe55521f0bf3c278aa64d953081a8ed3 /editors/openoffice-4
parentbf534872af32214a929b225f23ce51d8510563b4 (diff)
downloadports-a17bc80cb5dbdf95d7c0b2ef63c7f171c46473e5.tar.gz
ports-a17bc80cb5dbdf95d7c0b2ef63c7f171c46473e5.zip
Explicity set $JAVA_HOME in startup wrapper to the OpenJDK version used
for the build to avoid any potential issues with relying on javavmwrapper parsing bsd.java.mk to determine this at runtime. Fix an botch in the FreeBSD-specific $LD_LIBRARY_PATH code in the startup wrapper. Java is needed at runtime, so flag it as a runtime dependency.
Notes
Notes: svn path=/head/; revision=400064
Diffstat (limited to 'editors/openoffice-4')
-rw-r--r--editors/openoffice-4/Makefile5
-rw-r--r--editors/openoffice-4/files/patch-desktop_scripts_soffice.sh16
2 files changed, 20 insertions, 1 deletions
diff --git a/editors/openoffice-4/Makefile b/editors/openoffice-4/Makefile
index 35c87e9618ac..bbdb60c6797f 100644
--- a/editors/openoffice-4/Makefile
+++ b/editors/openoffice-4/Makefile
@@ -3,7 +3,7 @@
PORTNAME= apache-openoffice
PORTVERSION= ${AOOVERSION}
-PORTREVISION= 17
+PORTREVISION= 18
CATEGORIES= editors java
MASTER_SITES= APACHE/openoffice/${PORTVERSION}/source \
http://tools.openoffice.org/unowinreg_prebuild/680/:unoreg \
@@ -121,6 +121,7 @@ USE_GL= gl glu
USE_GNOME= gtk20 libxslt libidl glib20
USE_JAVA= yes
JAVA_BUILD= jdk
+JAVA_RUN= jdk
JAVA_VENDOR= openjdk
JAVA_VERSION= 1.6+
USE_PERL5= build
@@ -323,6 +324,8 @@ post-extract:
post-patch:
${REINPLACE_CMD} -e "/^ICONVERSION/s/=.*/= '-${AOOSUFFIX}'/" \
${WRKSRC}/sysui/desktop/productversion.mk
+ ${REINPLACE_CMD} -e "s|%%JAVA_HOME%%|${JAVA_HOME}|" \
+ ${WRKSRC}/desktop/scripts/soffice.sh
.if ${COMPILER_TYPE} == gcc
# g++49 -Os sometimes leaves inline class methods undefined,
# affects fmgridif.cxx and ColumnControl.cxx
diff --git a/editors/openoffice-4/files/patch-desktop_scripts_soffice.sh b/editors/openoffice-4/files/patch-desktop_scripts_soffice.sh
new file mode 100644
index 000000000000..708b8a63cc2b
--- /dev/null
+++ b/editors/openoffice-4/files/patch-desktop_scripts_soffice.sh
@@ -0,0 +1,16 @@
+--- desktop/scripts/soffice.sh.orig 2014-02-25 08:22:34 UTC
++++ desktop/scripts/soffice.sh
+@@ -90,11 +90,11 @@ if [ -x "$sd_prog/javaldx" ] ; then
+ case "`uname -s`" in
+ FreeBSD)
+ sd_prog1="$sd_prog"
+- LD_LIBRARY_PATH=$sd_prog1:${LD_LIBRARY_PATH}}
++ LD_LIBRARY_PATH=$sd_prog1${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}
+ export LD_LIBRARY_PATH
+ ;;
+ esac
+- my_path=`"$sd_prog/javaldx" $BOOTSTRAPVARS \
++ my_path=`JAVA_HOME="%%JAVA_HOME%%" "$sd_prog/javaldx" $BOOTSTRAPVARS \
+ "-env:INIFILENAME=vnd.sun.star.pathname:$sd_prog/redirectrc"`
+ if [ -n "$my_path" ] ; then
+ LD_LIBRARY_PATH=$my_path${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}