aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice-4
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2017-10-20 16:02:12 +0000
committerDon Lewis <truckman@FreeBSD.org>2017-10-20 16:02:12 +0000
commitdedad37c84bf0e7cb69bab38dde22870246595fd (patch)
tree4d34e2a5d199358b48b716271e741104f33d0ca4 /editors/openoffice-4
parent96f751729ac6e83deee66e41d788f462f1559e09 (diff)
downloadports-dedad37c84bf0e7cb69bab38dde22870246595fd.tar.gz
ports-dedad37c84bf0e7cb69bab38dde22870246595fd.zip
Upgrade to Apache OpenOffice 4.1.4:
* Several updates for language dictionaries * Some translation fixes in the UI * Bug fixes * Security improvements * Updated graphics/logos (new Apache feather) * Enhancements to the build tools (for developers) Clarify LICENSE entries, change MPL to MPL10 and MPL11 since code with both of these licenses is bundled. Make the java/jakarta-commons-httpclient dependency conditional on the WIKI_PUBLISHER option. The java/jakarta-commons-lang dependency should also be a RUN_DEPENDS. Add CONFLICTS_INSTALL. Move --with-ant-home and -with-jdk-home to Makefile from Makefile.knobs. Portlint fixes: USES/USE, ONLY_FOR_ARCHES ordering. MFH: 2017Q4
Notes
Notes: svn path=/head/; revision=452538
Diffstat (limited to 'editors/openoffice-4')
-rw-r--r--editors/openoffice-4/Makefile62
-rw-r--r--editors/openoffice-4/distinfo6
-rw-r--r--editors/openoffice-4/files/Makefile.knobs1
-rw-r--r--editors/openoffice-4/files/patch-sdext_prj_build.lst8
4 files changed, 40 insertions, 37 deletions
diff --git a/editors/openoffice-4/Makefile b/editors/openoffice-4/Makefile
index e1d317c99ce4..0129523a4611 100644
--- a/editors/openoffice-4/Makefile
+++ b/editors/openoffice-4/Makefile
@@ -3,9 +3,8 @@
PORTNAME= apache-openoffice
PORTVERSION= ${AOOVERSION}
-PORTREVISION= 13
CATEGORIES= editors java
-MASTER_SITES= APACHE/openoffice/${PORTVERSION}/source \
+MASTER_SITES= APACHE/openoffice/${PORTVERSION}/sources \
http://tools.openoffice.org/unowinreg_prebuild/680/:unoreg \
LOCAL/truckman/openoffice:extsrc
.if defined(LANG_PKGNAME)
@@ -23,8 +22,8 @@ MAINTAINER= office@FreeBSD.org
#Frequent Patch submitters should (optionally) sign the Apache iCLA
COMMENT= Integrated wordprocessor/dbase/spreadsheet/drawing/chart/browser
-LICENSE= APACHE20 ADOBE BSD3CLAUSE BSD4CLAUSE BSL ICU MIT MPL \
- PSFL TWAIN W3C
+LICENSE= APACHE20 ADOBE BSD3CLAUSE BSD4CLAUSE BSL ICU MIT MPL10 \
+ MPL11 PSFL TWAIN W3C
LICENSE_COMB= multi
LICENSE_NAME_ADOBE= Adobe Systems Incorporated license
LICENSE_NAME_ICU= ICU License
@@ -37,7 +36,8 @@ LICENSE_FILE_BSD4CLAUSE= ${WRKSRC}/LICENSE_BSD4CLAUSE
LICENSE_FILE_BSL= ${WRKSRC}/LICENSE_BSL
LICENSE_FILE_ICU= ${WRKSRC}/LICENSE_ICU
LICENSE_FILE_MIT= ${WRKSRC}/LICENSE_MIT
-LICENSE_FILE_MPL= ${WRKSRC}/LICENSE_MPL
+LICENSE_FILE_MPL10= ${WRKSRC}/LICENSE_MPL10
+LICENSE_FILE_MPL11= ${WRKSRC}/LICENSE_MPL11
LICENSE_FILE_PSFL= ${WRKSRC}/LICENSE_PSFL
LICENSE_FILE_TWAIN= ${WRKSRC}/LICENSE_TWAIN
LICENSE_FILE_W3C= ${WRKSRC}/LICENSE_W3C
@@ -46,6 +46,8 @@ LICENSE_PERMS_ICU= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LICENSE_PERMS_TWAIN= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LICENSE_PERMS_W3C= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+ONLY_FOR_ARCHS= amd64 i386 powerpc64
+
BUILD_DEPENDS= \
p5-Archive-Zip>=0:archivers/p5-Archive-Zip \
${LOCALBASE}/bin/unzip:archivers/unzip \
@@ -59,7 +61,6 @@ BUILD_DEPENDS= \
gpatch:devel/patch \
${LOCALBASE}/include/sane/sane.h:graphics/sane-backends \
${LOCALBASE}/bin/vigra-config:graphics/vigra \
- ${JAVALIBDIR}/commons-httpclient.jar:java/jakarta-commons-httpclient \
${JAVALIBDIR}/commons-lang.jar:java/jakarta-commons-lang \
${JAVALIBDIR}/junit.jar:java/junit \
${JAVALIBDIR}/bsh.jar:lang/bsh \
@@ -88,18 +89,20 @@ LIB_DEPENDS= \
libfontconfig.so:x11-fonts/fontconfig
RUN_DEPENDS= \
${LOCALBASE}/share/icons/hicolor/index.theme:misc/hicolor-icon-theme \
- ${JAVALIBDIR}/commons-httpclient.jar:java/jakarta-commons-httpclient \
+ ${JAVALIBDIR}/commons-lang.jar:java/jakarta-commons-lang \
${JAVALIBDIR}/bsh.jar:lang/bsh \
${LOCALBASE}/share/fonts/Caladea/Caladea-Bold.ttf:x11-fonts/crosextrafonts-caladea-ttf \
${LOCALBASE}/share/fonts/Carlito/Carlito-Bold.ttf:x11-fonts/crosextrafonts-carlito-ttf \
${LOCALBASE}/share/fonts/ChromeOS/Arimo-Bold.ttf:x11-fonts/croscorefonts-fonts-ttf
+CONFLICTS_INSTALL= apache-openoffice-devel-*
+
AOOVERSION1= 4
AOOVERSION2= 1
-AOOVERSION3= 3
+AOOVERSION3= 4
# From solenv/inc/minor.mk SOURCEREVISION LAST_MINOR BUILD
-AOOTAG= AOO413m1\(Build:9783\)
-SVNREVISION= 1761381
+AOOTAG= AOO414m5\(Build:9788\)
+SVNREVISION= 1811857
EXTSRC= ApacheOpenOffice.ext_sources.${AOOVERSION1}.x.x.20150707.tar.gz
AOOVERSION= ${AOOVERSION1}.${AOOVERSION2}.${AOOVERSION3}
@@ -115,8 +118,10 @@ XDGDIR= ${OOPATH}/share/xdg
XDGREL= ../../${INSTALLATION_BASEDIR}/openoffice${AOOVERSION1}/share/xdg
EXECBASE?= openoffice-${AOOSUFFIX}
-ONLY_FOR_ARCHS= amd64 i386 powerpc64
-
+USES= autoreconf:autoconf bison compiler:c++11-lib cpe \
+ desktop-file-utils \
+ gettext-runtime gmake iconv jpeg perl5 pkgconfig python \
+ shared-mime-info ssl tar:bzip2
USE_GL= gl glu
USE_GNOME= gtk20 libxslt libidl glib20
USE_JAVA= yes
@@ -127,10 +132,6 @@ JAVA_VERSION= 1.6+
USE_PERL5= build
USE_XORG= ice sm x11 xau xaw xcomposite xcursor xdamage xext xfixes xi \
xinerama xrandr xrender xt
-USES= autoreconf:autoconf bison compiler:c++11-lib cpe \
- desktop-file-utils \
- gettext-runtime gmake iconv jpeg perl5 pkgconfig python \
- shared-mime-info ssl tar:bzip2
INSTALLS_ICONS= yes
WITHOUT_CPU_CFLAGS= true
CPE_PRODUCT= ${PORTNAME:S|apache-||}
@@ -165,6 +166,16 @@ MMEDIA_USE= GSTREAMER=yes
SDK_CONFIGURE_ENABLE= odk
WIKI_PUBLISHER_CONFIGURE_ENABLE= wiki-publisher
+WIKI_PUBLISHER_CONFIGURE_WITH= \
+ commons-codec-jar=${JAVALIBDIR}/commons-codec.jar \
+ commons-httpclient-jar=${JAVALIBDIR}/commons-httpclient.jar \
+ commons-logging-jar=${JAVALIBDIR}/commons-logging.jar
+WIKI_PUBLISHER_JAR_DEPENDS= \
+ ${JAVALIBDIR}/commons-codec.jar:java/jakarta-commons-codec \
+ ${JAVALIBDIR}/commons-httpclient.jar:java/jakarta-commons-httpclient \
+ ${JAVALIBDIR}/commons-logging.jar:java/jakarta-commons-logging
+WIKI_PUBLISHER_BUILD_DEPENDS= ${WIKI_PUBLISHER_JAR_DEPENDS}
+WIKI_PUBLISHER_RUN_DEPENDS= ${WIKI_PUBLISHER_JAR_DEPENDS}
WIKI_PUBLISHER_VARS= BUNDLED_EXTENSIONS+=swext/wiki-publisher.oxt
# Don't run gnome-post-icons until after post-install generates the plist
@@ -218,11 +229,9 @@ SUB_LIST= EXECBASE=${EXECBASE} AOOTAG=${AOOTAG} AOOUDIR=${AOOUDIR} \
CONFIGURE_ARGS+= \
--with-unix-wrapper=${EXECBASE} \
--with-alloc=system \
+ --with-ant-home=${LOCALBASE}/share/java/apache-ant \
--with-system-apache-commons=yes \
- --with-commons-codec-jar=${JAVALIBDIR}/commons-codec.jar \
--with-commons-lang-jar=${JAVALIBDIR}/commons-lang.jar \
- --with-commons-httpclient-jar=${JAVALIBDIR}/commons-httpclient.jar \
- --with-commons-logging-jar=${JAVALIBDIR}/commons-logging.jar \
--with-system-apr \
--with-system-apr-util \
--with-system-beanshell \
@@ -246,6 +255,7 @@ CONFIGURE_ARGS+= \
--with-external-dict-dir=${LOCALBASE}/share/hunspell \
--with-system-hyphen \
--with-external-hyph-dir=${LOCALBASE}/share/hyphen \
+ --with-jdk-home=${JAVA_HOME} \
--with-system-jpeg \
--with-junit=${JAVALIBDIR}/junit.jar \
--with-system-libtextcat \
@@ -322,18 +332,20 @@ post-extract:
-e d ${WRKSRC}/LICENSE > ${LICENSE_FILE_BSL}
${SED} -e '\|^For main/i18npool/source/breakiterator|,/^__/p' \
-e d ${WRKSRC}/LICENSE > ${LICENSE_FILE_ICU}
- ${SED} -e '\|^For Multi-Dimensional Data|,/^__/p' \
+ ${SED} -e '\|^For Multi-Dimensional Data|,/^__/p' \
-e '\|^For XSLT MathML Library|,/^__/p' \
-e d ${WRKSRC}/LICENSE > ${LICENSE_FILE_MIT}
- ${SED} -e '\|^For XMLSec Library|,/^__/p' \
+ ${SED} -e '\|^For XMLSec Library|,/^__/p' \
-e d ${WRKSRC}/LICENSE_category_b >> ${LICENSE_FILE_MIT}
- ${SED} -e '\|^For Graphite|,$$d' \
- ${WRKSRC}/LICENSE_category_b > ${LICENSE_FILE_MPL}
+ ${SED} -e '\|^For Saxon|,/^__/p' \
+ -e d ${WRKSRC}/LICENSE_category_b > ${LICENSE_FILE_MPL10}
+ ${SED} -e '\|^For Saxon|,$$d' \
+ ${WRKSRC}/LICENSE_category_b > ${LICENSE_FILE_MPL11}
${SED} -e '\|^For main/filter/source/config/tools/merge/pyAltFCFGMerge|,/^__/p' \
-e d ${WRKSRC}/LICENSE > ${LICENSE_FILE_PSFL}
- ${SED} -e '\|^For main/twain|,/^__/p' \
+ ${SED} -e '\|^For main/twain|,/^__/p' \
-e d ${WRKSRC}/LICENSE > ${LICENSE_FILE_TWAIN}
- ${SED} -e '\|^For main/MathMLDTD|,/^__/p' \
+ ${SED} -e '\|^For main/MathMLDTD|,/^__/p' \
-e d ${WRKSRC}/LICENSE > ${LICENSE_FILE_W3C}
post-patch:
diff --git a/editors/openoffice-4/distinfo b/editors/openoffice-4/distinfo
index 30fe4fac9c86..2e5eccf4c2cf 100644
--- a/editors/openoffice-4/distinfo
+++ b/editors/openoffice-4/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1476083119
-SHA256 (openoffice/apache-openoffice-4.1.3-r1761381-src.tar.bz2) = 225ee39d3426389e3add68aec0921af1d22d18cada8c905c02811e873c08ebc0
-SIZE (openoffice/apache-openoffice-4.1.3-r1761381-src.tar.bz2) = 219143777
+TIMESTAMP = 1507773303
+SHA256 (openoffice/apache-openoffice-4.1.4-r1811857-src.tar.bz2) = 7fdda4e30fec6663fcef07531674056777271ae99cfe708efab55c702e3b8d64
+SIZE (openoffice/apache-openoffice-4.1.4-r1811857-src.tar.bz2) = 219097203
SHA256 (openoffice/unowinreg.dll) = f563e522922133db9340b0306711c2d8767cc3481dd9e7d9b0d059906d12653c
SIZE (openoffice/unowinreg.dll) = 6144
SHA256 (openoffice/ApacheOpenOffice.ext_sources.4.x.x.20150707.tar.gz) = 966a8333c83a18ddd84401389006d6e0b52b8175924b808b54b88211669985fa
diff --git a/editors/openoffice-4/files/Makefile.knobs b/editors/openoffice-4/files/Makefile.knobs
index d5c399470ad3..09b33b103100 100644
--- a/editors/openoffice-4/files/Makefile.knobs
+++ b/editors/openoffice-4/files/Makefile.knobs
@@ -3,7 +3,6 @@
# $FreeBSD$
# Makefile for knobs
-CONFIGURE_ARGS+= --with-jdk-home="${JAVA_HOME}" --with-ant-home="${LOCALBASE}/share/java/apache-ant"
CONFIGURE_ARGS+= --with-lang=${LOCALIZED_LANG}
pre-fetch:
diff --git a/editors/openoffice-4/files/patch-sdext_prj_build.lst b/editors/openoffice-4/files/patch-sdext_prj_build.lst
deleted file mode 100644
index e7ce00333e67..000000000000
--- a/editors/openoffice-4/files/patch-sdext_prj_build.lst
+++ /dev/null
@@ -1,8 +0,0 @@
---- sdext/prj/build.lst.orig 2014-02-25 08:27:02 UTC
-+++ sdext/prj/build.lst
-@@ -1,4 +1,4 @@
--dx sdext : L10N:l10n offuh comphelper unotools readlicense_oo cppu tools cppuhelper sal javaunohelper officecfg LIBXSLT:libxslt xmlhelp NULL
-+dx sdext : L10N:l10n offuh comphelper unotools readlicense_oo cppu tools cppuhelper sal javaunohelper officecfg LIBXSLT:libxslt xmlhelp rsc NULL
- dx sdext usr1 - all sdext_mkout NULL
- dx sdext\prj get - all sdext_prj NULL
- dx sdext\source\minimizer nmake - all sdext_minimizer sdext_inc NULL