aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice-devel
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2015-02-17 01:26:17 +0000
committerDon Lewis <truckman@FreeBSD.org>2015-02-17 01:26:17 +0000
commite2ec3380c43e7d269927ab1106c8bb4a72ae75cb (patch)
tree3f707cbbc940665055c8eb7049070220d16c848a /editors/openoffice-devel
parent6ad2f33fe108735e763c0ed87f06c0fcda93cbfb (diff)
downloadports-e2ec3380c43e7d269927ab1106c8bb4a72ae75cb.tar.gz
ports-e2ec3380c43e7d269927ab1106c8bb4a72ae75cb.zip
Switch back to USE_GCC=yes.
Work around this bug <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=65009> in g++49 -Os optimzation by using -O0 optimization if we are compiling with g++49. Differential Revision: https://reviews.freebsd.org/D1607 Reviewed by: pfg Approved by: mat (mentor)
Notes
Notes: svn path=/head/; revision=379132
Diffstat (limited to 'editors/openoffice-devel')
-rw-r--r--editors/openoffice-devel/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/editors/openoffice-devel/Makefile b/editors/openoffice-devel/Makefile
index 7cfe7d199ab4..8a8d5c5017bd 100644
--- a/editors/openoffice-devel/Makefile
+++ b/editors/openoffice-devel/Makefile
@@ -101,7 +101,7 @@ USE_XORG= x11 ice xaw xau xext xrender xrandr \
xi xt xcursor xdamage xcomposite xfixes
USE_GL= gl glu
USE_GSTREAMER= yes
-USE_GCC= 4.8
+USE_GCC= yes
USES+= bison desktop-file-utils gmake perl5 pkgconfig python tar:xz
USE_PERL5= build
WITHOUT_CPU_CFLAGS= true
@@ -262,6 +262,11 @@ post-patch:
.if defined (USE_GCC)
${REINPLACE_CMD} -e "s+%%RPATH%%+-Wl,-rpath=${_GCC_RUNTIME}+" ${WRKSRC}/solenv/inc/unxfbsd.mk
${REINPLACE_CMD} -e "s+%%RPATH%%+-Wl,-rpath=${_GCC_RUNTIME}+" ${WRKSRC}/solenv/gbuild/platform/freebsd.mk
+ # g++49 -Os sometimes leaves inline class methods undefined
+ if [ ${CXX} = g++49 ]; then \
+ ${REINPLACE_CMD} -e "s/ := -Os/ := -O0/" ${WRKSRC}/solenv/gbuild/platform/freebsd.mk; \
+ ${REINPLACE_CMD} -e "s/=-Os /=-O0 /" ${WRKSRC}/solenv/inc/unxfbsdi.mk; \
+ fi
.else
${REINPLACE_CMD} -e "s+%%RPATH%%++" ${WRKSRC}/solenv/inc/unxfbsd.mk
${REINPLACE_CMD} -e "s+%%RPATH%%++" ${WRKSRC}/solenv/gbuild/platform/freebsd.mk