aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice.org-2.0-devel/Makefile
diff options
context:
space:
mode:
authorMartin Blapp <mbr@FreeBSD.org>2003-03-12 01:04:08 +0000
committerMartin Blapp <mbr@FreeBSD.org>2003-03-12 01:04:08 +0000
commit19599e5a4a411a2d56be9c645df2a3d9eb0d4ba3 (patch)
treed09f794c6c4092a612ca9d09bf3925389764a92c /editors/openoffice.org-2.0-devel/Makefile
parent617c57ad7c79c3c4da1470d2f9b6c0b90dcaf17c (diff)
downloadports-19599e5a4a411a2d56be9c645df2a3d9eb0d4ba3.tar.gz
ports-19599e5a4a411a2d56be9c645df2a3d9eb0d4ba3.zip
Update to cws_srx644_ooo11beta. It still doesn't build but this commit will help
to track the things down. There are known problems with weak symbols and exceptions. Some c++ tools inside the port will fail if you try to compile. The cpp_uno bridge has been updated to the latest linux version available. Added 'make update' target to upgrade the source to the latest version. Approved by: kris (portmgr)
Notes
Notes: svn path=/head/; revision=77109
Diffstat (limited to 'editors/openoffice.org-2.0-devel/Makefile')
-rw-r--r--editors/openoffice.org-2.0-devel/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/editors/openoffice.org-2.0-devel/Makefile b/editors/openoffice.org-2.0-devel/Makefile
index 64c08be99f88..6f740924c399 100644
--- a/editors/openoffice.org-2.0-devel/Makefile
+++ b/editors/openoffice.org-2.0-devel/Makefile
@@ -8,7 +8,8 @@
PORTNAME= openoffice
PORTVERSION= 644
CATEGORIES+= editors
-MASTER_SITES+= http://ny1.mirror.openoffice.org/developer/%SUBDIR%/ \
+MASTER_SITES+= http://projects.imp.ch/openoffice/%SUBDIR%/ \
+ http://ny1.mirror.openoffice.org/developer/%SUBDIR%/ \
http://ftp.gwdg.de/pub/misc/openoffice/developer/%SUBDIR%/ \
${MASTER_SITE_RINGSERVER:S,developer/%SUBDIR%,misc/openoffice/&,} \
ftp://ftp.cs.man.ac.uk/pub/toby/gpc/:gpc \
@@ -567,4 +568,13 @@ package-rename:
${WRKDIR}/../OOo_${PORTVERSION}_${OPSYS}Intel_install_${LANG_PKGNAME}.tbz2
.endif
+update:
+ @${MAKE} fetch
+ @${MAKE} extract
+ @cd ${WRKSRC}/.. && for dir in *; do \
+ if [ -d $$dir ]; then \
+ cd $$dir; cvs update -d; cd ..; \
+ fi \
+ done
+
.include <bsd.port.post.mk>