aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice.org-2.0-devel/Makefile
diff options
context:
space:
mode:
authorMartin Blapp <mbr@FreeBSD.org>2002-03-13 19:19:41 +0000
committerMartin Blapp <mbr@FreeBSD.org>2002-03-13 19:19:41 +0000
commit78647a51f741416b072d15e2691caa5b53bbd6a3 (patch)
treea1c8804ebe7ac56b8487c7ecd05e80d195340a10 /editors/openoffice.org-2.0-devel/Makefile
parent4de8da50400c5b4393f6b5524f58215baff80f47 (diff)
downloadports-78647a51f741416b072d15e2691caa5b53bbd6a3.tar.gz
ports-78647a51f741416b072d15e2691caa5b53bbd6a3.zip
Make portlint happy. Add USE_XLIB
Submitted by: demon
Notes
Notes: svn path=/head/; revision=56018
Diffstat (limited to 'editors/openoffice.org-2.0-devel/Makefile')
-rw-r--r--editors/openoffice.org-2.0-devel/Makefile22
1 files changed, 12 insertions, 10 deletions
diff --git a/editors/openoffice.org-2.0-devel/Makefile b/editors/openoffice.org-2.0-devel/Makefile
index 92cda4c84e7e..0d27392347bc 100644
--- a/editors/openoffice.org-2.0-devel/Makefile
+++ b/editors/openoffice.org-2.0-devel/Makefile
@@ -7,34 +7,36 @@
PORTNAME= openoffice
PORTVERSION= 642
-CATEGORIES= editors x11
+CATEGORIES= editors
MASTER_SITES= ftp://sunsite.cnlab-switch.ch/mirror/OpenOffice/${PORTVERSION}/ \
http://sf1.mirror.openoffice.org/${PORTVERSION}/ \
ftp://ftp.cs.man.ac.uk/pub/toby/gpc/ \
http://people.freebsd.org/~mbr/distfiles/
DISTFILES= oo_${PORTVERSION}_src.tar.bz2 gpc231.tar.Z oo_moz_641.tar.gz
EXTRACT_ONLY= oo_${PORTVERSION}_src.tar.bz2
-EXTRACT_REST= gpc231.tar.Z oo_moz_641.tar.gz
MAINTAINER= mbr@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
+BUILD_DEPENDS+= ${JAVAVM}:${PORTSDIR}/java/jdk13
+LIB_DEPENDS+= pth.14:${PORTSDIR}/devel/pth
+
BROKEN= 'Work in progress -- does not build yet till the end'
-USE_BZIP2= yes
+USE_XLIB= yes
+USE_BZIP2= yes
+USE_BISON= yes
+USE_GMAKE= yes
EXTRACT_BEFORE_ARGS_R= -dc
EXTRACT_AFTER_ARGS_R= | ${TAR} -xf -
EXTRACT_CMD_R= ${GZIP_CMD}
+EXTRACT_REST= gpc231.tar.Z oo_moz_641.tar.gz
GCC_VERSION!= ${CC} --version
JDK13DIR?= ${LOCALBASE}/jdk1.3.1
JAVAVM= ${JDK13DIR}/bin/java
-BUILD_DEPENDS= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
-BUILD_DEPENDS+= bison:${PORTSDIR}/devel/bison
-BUILD_DEPENDS+= gmake:${PORTSDIR}/devel/gmake
-BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
-BUILD_DEPENDS+= ${JAVAVM}:${PORTSDIR}/java/jdk13
-BUILD_DEPENDS+= pth-config:${PORTSDIR}/devel/pth
-
GNU_CONFIGURE= yes
USE_AUTOCONF= yes
WRKSRC= ${WRKDIR}/oo_${PORTVERSION}_src/config_office