aboutsummaryrefslogtreecommitdiff
path: root/editors/py-pynvim
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2019-03-19 16:15:44 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2019-03-19 16:15:44 +0000
commit1ad97005470cf2e91ec1d2a14dffa259dde3e639 (patch)
tree067fbee67fd6fdceae71e8afd8ca37053652f432 /editors/py-pynvim
parenta3db24329ff858d3b02897ab553494c4ede3600c (diff)
downloadports-1ad97005470cf2e91ec1d2a14dffa259dde3e639.tar.gz
ports-1ad97005470cf2e91ec1d2a14dffa259dde3e639.zip
Remove neovim from TEST_DEPENDS, and original submitter becomes maintainer
My intention is to add an OPTION for pynvim to the neovim port, which means that this port cannot depend upon neovim. Change do-test to a maintainer-test target that gives some instructions. Also, per original PR and at request of 0mp, pass maintainership to Thomas Merkel, the submitter of the original py-pynvim PR. PR: 236571 Approved by: 0mp
Notes
Notes: svn path=/head/; revision=496270
Diffstat (limited to 'editors/py-pynvim')
-rw-r--r--editors/py-pynvim/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/editors/py-pynvim/Makefile b/editors/py-pynvim/Makefile
index e45b19352400..a499ab60ca9e 100644
--- a/editors/py-pynvim/Makefile
+++ b/editors/py-pynvim/Makefile
@@ -5,7 +5,7 @@ PORTVERSION= 0.3.2
CATEGORIES= editors python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= 0mp@FreeBSD.org
+MAINTAINER= tm@NetBSD.org
COMMENT= Python client and plugin host for Neovim
LICENSE= APACHE20
@@ -14,8 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}msgpack>=0.5.0:devel/py-msgpack@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}greenlet>=0:devel/py-greenlet@${PY_FLAVOR}
py27_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}trollius>=0:devel/py-trollius@${PY_FLAVOR}
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=3.4.0:devel/py-pytest@${PY_FLAVOR} \
- nvim:editors/neovim
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=3.4.0:devel/py-pytest@${PY_FLAVOR}
USES= python
USE_PYTHON= concurrent distutils flavors autoplist
@@ -29,7 +28,9 @@ SUB_FILES= pkg-message
SUB_LIST= PYTHON_CMD=${PYTHON_CMD} \
SUFFIX_FOR_PYTHON_3=${PYTHON_MAJOR_VER:M3}
-do-test:
- cd ${WRKSRC} && ${PYTHON_CMD} -m pytest
+maintainer-test:
+# Cannot depend on neovim as it could create a circular dependency
+ @${ECHO_CMD} "===> Install neovim, then run:"
+ @${ECHO_CMD} "cd ${WRKSRC} && ${PYTHON_CMD} -m pytest"
.include <bsd.port.mk>