aboutsummaryrefslogtreecommitdiff
path: root/editors/rehex
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-06-10 08:12:06 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-06-10 08:13:35 +0000
commite62f347f9cdbde90ebff1a6aa3e4e03729a52683 (patch)
tree49f7a7f2d5ef8b32515a34fe74f02d9216bd5f06 /editors/rehex
parent227ea2a4958ba72284fdcf51647ddb34cf0936e7 (diff)
downloadports-e62f347f9cdbde90ebff1a6aa3e4e03729a52683.tar.gz
ports-e62f347f9cdbde90ebff1a6aa3e4e03729a52683.zip
editors/rehex: new port had been added (+)
Cross-platform (wxWidgets-based) hexadecimal editor for reverse engineering, and everything else. WWW: https://github.com/solemnwarning/rehex
Diffstat (limited to 'editors/rehex')
-rw-r--r--editors/rehex/Makefile34
-rw-r--r--editors/rehex/distinfo3
-rw-r--r--editors/rehex/files/patch-Makefile27
-rw-r--r--editors/rehex/pkg-descr12
-rw-r--r--editors/rehex/pkg-plist19
5 files changed, 95 insertions, 0 deletions
diff --git a/editors/rehex/Makefile b/editors/rehex/Makefile
new file mode 100644
index 000000000000..a3d31681b63e
--- /dev/null
+++ b/editors/rehex/Makefile
@@ -0,0 +1,34 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+
+PORTNAME= rehex
+PORTVERSION= 0.3.91
+CATEGORIES= editors
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Hex editor for reverse engineering
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libcapstone.so:devel/capstone4 \
+ libjansson.so:devel/jansson
+
+USES= compiler:c++11-lang gmake lua:53 pkgconfig
+USE_WX= 3.0+
+MAKE_ENV= LUA_PKG="lua-${LUA_VER}" LUA="${LUA_CMD}"
+INSTALLS_ICONS= yes
+USE_GITHUB= yes
+GH_ACCOUNT= solemnwarning
+
+PORTDOCS= CHANGES.txt
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,OpenBSD,${OPSYS},' \
+ ${WRKSRC}/include/portable_endian.h
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/editors/rehex/distinfo b/editors/rehex/distinfo
new file mode 100644
index 000000000000..b898e4fa34b9
--- /dev/null
+++ b/editors/rehex/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1620046647
+SHA256 (solemnwarning-rehex-0.3.91_GH0.tar.gz) = 014a44ae5e5fc71d025fcab71392d8d2c50afc25f0d7eb6a9f87e14772b9c6ca
+SIZE (solemnwarning-rehex-0.3.91_GH0.tar.gz) = 3292919
diff --git a/editors/rehex/files/patch-Makefile b/editors/rehex/files/patch-Makefile
new file mode 100644
index 000000000000..91c4fea5fd06
--- /dev/null
+++ b/editors/rehex/files/patch-Makefile
@@ -0,0 +1,27 @@
+--- Makefile.orig 2021-05-03 12:57:27 UTC
++++ Makefile
+@@ -388,18 +388,20 @@ PLUGINS_INSTALL := \
+
+ .PHONY: install
+ install: $(EXE)
+- install -D -m 0755 $(EXE) $(DESTDIR)$(bindir)/$(EXE)
++ $(BSD_INSTALL_PROGRAM) $(EXE) $(DESTDIR)$(bindir)/$(EXE)
+
+ for s in 16 32 48 64 128 256 512; \
+ do \
+- install -D -m 0644 res/icon$${s}.png $(DESTDIR)$(datarootdir)/icons/hicolor/$${s}x$${s}/apps/rehex.png; \
++ mkdir -p $(DESTDIR)$(datarootdir)/icons/hicolor/$${s}x$${s}/apps; \
++ $(BSD_INSTALL_DATA) res/icon$${s}.png $(DESTDIR)$(datarootdir)/icons/hicolor/$${s}x$${s}/apps/rehex.png; \
+ done
+
+- install -D -m 0644 res/rehex.desktop $(DESTDIR)$(datarootdir)/applications/rehex.desktop
++ $(BSD_INSTALL_DATA) res/rehex.desktop $(DESTDIR)$(datarootdir)/applications/rehex.desktop
+
++ mkdir -p $(DESTDIR)$(libdir)/rehex/exe
+ for f in $(PLUGINS_INSTALL); \
+ do \
+- install -D -m 0644 plugins/$${f} $(DESTDIR)$(libdir)/rehex/$${f}; \
++ $(BSD_INSTALL_DATA) plugins/$${f} $(DESTDIR)$(libdir)/rehex/$${f}; \
+ done
+
+ .PHONY: uninstall
diff --git a/editors/rehex/pkg-descr b/editors/rehex/pkg-descr
new file mode 100644
index 000000000000..88733db045a5
--- /dev/null
+++ b/editors/rehex/pkg-descr
@@ -0,0 +1,12 @@
+This is cross-platform (wxWidgets-based) hexadecimal editor for reverse
+engineering, and everything else. It features:
+
+ - Large (1TB+) file support
+ - Decoding of integer/floating point value types
+ - Inline disassembly of machine code
+ - Highlighting and annotation of ranges of bytes
+ - Side by side comparison of selections
+ - Lua scripting support with documented API
+ - Virtual address mapping support
+
+WWW: https://github.com/solemnwarning/rehex
diff --git a/editors/rehex/pkg-plist b/editors/rehex/pkg-plist
new file mode 100644
index 000000000000..86e612384b8d
--- /dev/null
+++ b/editors/rehex/pkg-plist
@@ -0,0 +1,19 @@
+bin/rehex
+lib/rehex/exe/bitops52.lua
+lib/rehex/exe/class.lua
+lib/rehex/exe/document_stream.lua
+lib/rehex/exe/enum.lua
+lib/rehex/exe/kaitaistruct.lua
+lib/rehex/exe/microsoft_pe.lua
+lib/rehex/exe/plugin.lua
+lib/rehex/exe/string_decode.lua
+lib/rehex/exe/string_stream.lua
+lib/rehex/exe/utils.lua
+share/applications/rehex.desktop
+share/icons/hicolor/128x128/apps/rehex.png
+share/icons/hicolor/16x16/apps/rehex.png
+share/icons/hicolor/256x256/apps/rehex.png
+share/icons/hicolor/32x32/apps/rehex.png
+share/icons/hicolor/48x48/apps/rehex.png
+share/icons/hicolor/512x512/apps/rehex.png
+share/icons/hicolor/64x64/apps/rehex.png