aboutsummaryrefslogtreecommitdiff
path: root/editors/tamago
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2012-08-04 00:45:29 +0000
committerHiroki Sato <hrs@FreeBSD.org>2012-08-04 00:45:29 +0000
commit076c17d83e3d36e0aa205f1bf358318ca37029e0 (patch)
treea2747202d87dbfdf2b5d0b15333c21ad40ed3c6d /editors/tamago
parent5ef15963169b6fb826fa3c793f623963f14f7fae (diff)
downloadports-076c17d83e3d36e0aa205f1bf358318ca37029e0.tar.gz
ports-076c17d83e3d36e0aa205f1bf358318ca37029e0.zip
- Update to 4.0.6.0.20041122.19.
- Fix make-local-hook issue in emacs24. PR: ports/170360
Notes
Notes: svn path=/head/; revision=301979
Diffstat (limited to 'editors/tamago')
-rw-r--r--editors/tamago/Makefile5
-rw-r--r--editors/tamago/distinfo4
-rw-r--r--editors/tamago/files/post-patch-egg.el12
-rw-r--r--editors/tamago/files/post-patch-menudiag.el12
4 files changed, 28 insertions, 5 deletions
diff --git a/editors/tamago/Makefile b/editors/tamago/Makefile
index 5d351a919f5c..1c0514abe1c0 100644
--- a/editors/tamago/Makefile
+++ b/editors/tamago/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= tamago
-PORTVERSION= 4.0.6.0.20041122.18
-PORTREVISION= 7
+PORTVERSION= 4.0.6.0.20041122.19
CATEGORIES= editors elisp
MASTER_SITES= ${MASTER_SITE_DEBIAN}
MASTER_SITE_SUBDIR= pool/main/e/egg
@@ -16,7 +15,7 @@ DISTNAME= egg_4.0.6+0.20041122cvs.orig
PATCH_SITES= ${MASTER_SITE_DEBIAN:S,%SUBDIR%,pool/main/e/egg,} \
${MASTER_SITE_LOCAL:S,%SUBDIR%,nork,}
-PATCHFILES= egg_4.0.6+0.20041122cvs-18.diff.gz
+PATCHFILES= egg_4.0.6+0.20041122cvs-19.diff.gz
PATCH_DIST_STRIP= -p1
MAINTAINER= hrs@FreeBSD.org
diff --git a/editors/tamago/distinfo b/editors/tamago/distinfo
index 334659bb21fd..c4389b654df9 100644
--- a/editors/tamago/distinfo
+++ b/editors/tamago/distinfo
@@ -1,4 +1,4 @@
SHA256 (egg_4.0.6+0.20041122cvs.orig.tar.gz) = 722413515f2d60418d98250c8aed2b811e6b5363cdb69899193d454afe425115
SIZE (egg_4.0.6+0.20041122cvs.orig.tar.gz) = 287308
-SHA256 (egg_4.0.6+0.20041122cvs-18.diff.gz) = e6ff6e7e1b52b38ba87cadc0733add1651827366af766bd78719b9ab6fd57e8b
-SIZE (egg_4.0.6+0.20041122cvs-18.diff.gz) = 28267
+SHA256 (egg_4.0.6+0.20041122cvs-19.diff.gz) = bd4252d0536c1eeb526789063b822b9b9e75f2bbec9c3db97792ce0ee3b89fb0
+SIZE (egg_4.0.6+0.20041122cvs-19.diff.gz) = 28417
diff --git a/editors/tamago/files/post-patch-egg.el b/editors/tamago/files/post-patch-egg.el
new file mode 100644
index 000000000000..b22401031e04
--- /dev/null
+++ b/editors/tamago/files/post-patch-egg.el
@@ -0,0 +1,12 @@
+--- egg.el.orig 2012-08-04 09:27:19.000000000 +0900
++++ egg.el 2012-08-04 09:32:15.000000000 +0900
+@@ -169,7 +169,8 @@
+ (setq egg-modeless-mode t))
+ (setq inactivate-current-input-method-function 'egg-mode)
+ (setq describe-current-input-method-function 'egg-help)
+- (make-local-hook 'input-method-activate-hook)
++ (if (fboundp 'make-local-hook)
++ (eval '(make-local-hook 'input-method-activate-hook)))
+ (add-hook 'input-method-activate-hook 'its-set-mode-line-title nil t)
+ (if (eq (selected-window) (minibuffer-window))
+ (add-hook 'minibuffer-exit-hook 'egg-exit-from-minibuffer))
diff --git a/editors/tamago/files/post-patch-menudiag.el b/editors/tamago/files/post-patch-menudiag.el
new file mode 100644
index 000000000000..abae0c42cb3a
--- /dev/null
+++ b/editors/tamago/files/post-patch-menudiag.el
@@ -0,0 +1,12 @@
+--- menudiag.el.orig 2001-01-28 03:53:13.000000000 +0900
++++ menudiag.el 2012-08-04 09:32:34.000000000 +0900
+@@ -503,7 +503,8 @@
+ (make-local-variable 'inhibit-read-only)
+ (setq buffer-read-only t
+ inhibit-read-only nil)
+- (make-local-hook 'post-command-hook)
++ (if (fboundp 'make-local-hook)
++ (eval '(make-local-hook 'post-command-hook)))
+ (add-hook 'post-command-hook 'menudiag-selection-align-to-item nil t)
+ (use-local-map menudiag-selection-map)
+ (setq mode-name "Menudiag Selection")