aboutsummaryrefslogtreecommitdiff
path: root/editors/texmacs/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-08-28 18:20:28 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-08-28 18:20:28 +0000
commit7d97cf724a3069bfa21ba0cc24cd103b96b997a9 (patch)
treeb2f1ea996d153e254a510c0e5eda8c30438a0518 /editors/texmacs/Makefile
parent932f3c64d083d5592e126900e842db102170b5f6 (diff)
downloadports-7d97cf724a3069bfa21ba0cc24cd103b96b997a9.tar.gz
ports-7d97cf724a3069bfa21ba0cc24cd103b96b997a9.zip
- Fix build on -current
- Use OPTIONS helpers - shebangfix some perl scripts - Add missing file to plist - Don't try to remove directories installed by dependencies
Notes
Notes: svn path=/head/; revision=366444
Diffstat (limited to 'editors/texmacs/Makefile')
-rw-r--r--editors/texmacs/Makefile73
1 files changed, 26 insertions, 47 deletions
diff --git a/editors/texmacs/Makefile b/editors/texmacs/Makefile
index 401d95dd3749..0320fab42a7f 100644
--- a/editors/texmacs/Makefile
+++ b/editors/texmacs/Makefile
@@ -3,7 +3,7 @@
PORTNAME= texmacs
PORTVERSION= 1.0.7.21
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= editors print
MASTER_SITES= ftp://ftp.texmacs.org/TeXmacs/tmftp/source/ \
http://www.predatorlabs.net/dl/
@@ -16,8 +16,7 @@ LICENSE= GPLv3
LIB_DEPENDS= libguile.so:${PORTSDIR}/lang/guile
-USES= gmake shared-mime-info desktop-file-utils
-USE_PYTHON= yes
+USES= gmake shared-mime-info desktop-file-utils python shebangfix
USE_TEX= tex
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -27,54 +26,34 @@ MAKE_ARGS= CP="${CP} -R -f"
ALL_TARGET= ${PORTNAME:tu}
INSTALL_ICONS= yes
+SHEBANG_FILES= plugins/asymptote/bin/tm_asy2 \
+ plugins/feynmf/bin/bbox_add.pl \
+ plugins/asymptote/bin/perl-tm_asy
+
DATADIR= ${PREFIX}/share/TeXmacs
OPTIONS_DEFINE= FREETYPE GHOSTSCRIPT ICONV IMLIB2 PDF QT4
-OPTIONS_DEFAULT= FREETYPE GHOSTSCRIPT ICONV IMLIB2 QT4
+OPTIONS_DEFAULT=FREETYPE GHOSTSCRIPT ICONV IMLIB2 QT4
PDF_DESC= Experimental PDF renderer
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MFREETYPE}
-LIB_DEPENDS+= libfreetype.so:${PORTSDIR}/print/freetype2
-CONFIGURE_ARGS+= --with-freetype=linked
-.else
-CONFIGURE_ARGS+= --without-freetype
-.endif
-
-.if ${PORT_OPTIONS:MGHOSTSCRIPT}
-USE_GHOSTSCRIPT= yes
-CONFIGURE_ARGS+= --with-gs=yes
-.else
-CONFIGURE_ARGS+= --without-gs
-.endif
-
-.if ${PORT_OPTIONS:MICONV}
-USES+= iconv
-CONFIGURE_ARGS+= --with-iconv
-.else
-CONFIGURE_ARGS+= --without-iconv
-.endif
-
-.if ${PORT_OPTIONS:MIMLIB2}
-USE_EFL= imlib2
-CONFIGURE_ARGS+= --with-imlib2
-.else
-CONFIGURE_ARGS+= --without-imlib
-.endif
-
-.if ${PORT_OPTIONS:MPDF}
-CONFIGURE_ARGS+= --enable-pdf-renderer
-.endif
-
-.if ${PORT_OPTIONS:MQT4}
-USE_QT4= gui moc_build qmake_build rcc uic_build
-CONFIGURE_ARGS+= --with-qt --enable-qtpipes
-.else
-CONFIGURE_ARGS+= --disable-qt
-.endif
-
-.include <bsd.port.pre.mk>
+FREETYPE_LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
+FREETYPE_CONFIGURE_WITH=freetype=linked
+
+GHOSTSCRIPT_USE= GHOSTSCRIPT=yes
+GHOSTSCRIPT_CONFIGURE_WITH= gs=yes
+
+ICONV_USES= iconv
+ICONV_CONFIGURE_WITH= iconv
+
+IMLIB2_USE= EFL=imlib2
+IMLIB2_CONFIGURE_ON= --with-imlib2
+IMLIB2_CONFIGURE_OFF= --without-imlib
+
+PDF_CONFIGURE_ON= --enable-pdf-renderer
+
+QT4_USE= QT4=gui,moc_build,qmake_build,rcc,uic_build
+QT4_CONFIGURE_ON= --with-qt --enable-qtpipes
+QT4_CONFIGURE_OFF= --disable-qt
post-patch:
@${GREP} -lR "#!/bin/bash" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
@@ -87,4 +66,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|qdrawutil.h|qt4/Qt/qdrawutil.h|' \
${WRKSRC}/src/Plugins/Qt/QTMStyle.cpp
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>