aboutsummaryrefslogtreecommitdiff
path: root/editors/texmacs/Makefile
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2011-03-07 13:40:14 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2011-03-07 13:40:14 +0000
commit935808b1000358c1035c4888a02e7fcb15687ac1 (patch)
tree8527ab01548b1ff29d953f2fbcecfd389a950b34 /editors/texmacs/Makefile
parent78b693b7118121f92601bdb1d151f2c6c7d133e0 (diff)
downloadports-935808b1000358c1035c4888a02e7fcb15687ac1.tar.gz
ports-935808b1000358c1035c4888a02e7fcb15687ac1.zip
- Update to 1.0.7.9
- Add OPTIONS PR: ports/155343 Submitted by: Rob Farmer <rfarmer@predatorlabs.net> (maintainer)
Notes
Notes: svn path=/head/; revision=270439
Diffstat (limited to 'editors/texmacs/Makefile')
-rw-r--r--editors/texmacs/Makefile29
1 files changed, 25 insertions, 4 deletions
diff --git a/editors/texmacs/Makefile b/editors/texmacs/Makefile
index 003675fb3ed8..f698225b689a 100644
--- a/editors/texmacs/Makefile
+++ b/editors/texmacs/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= texmacs
-PORTVERSION= 1.0.7.8
+PORTVERSION= 1.0.7.9
CATEGORIES= editors print
MASTER_SITES= ftp://ftp.texmacs.org/pub/TeXmacs/%SUBDIR%/ \
http://www.predatorlabs.net/dl/
@@ -26,6 +26,7 @@ MAKE_JOBS_SAFE= yes
USE_PYTHON= yes
USE_ICONV= yes
USE_GMAKE= yes
+USE_GHOSTSCRIPT= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -35,14 +36,36 @@ CONFIGURE_ARGS= --enable-optimize="${CXXFLAGS}" \
MAKE_ARGS= CP="${CP} -R -f"
ALL_TARGET= ${PORTNAME:U}
+DATADIR= ${PREFIX}/share/TeXmacs
+
MAN1= texmacs.1 fig2ps.1
MANCOMPRESSED= yes
+OPTIONS= IMLIB2 "Use imlib2" ON \
+ PDF "Experimental PDF renderer" OFF \
+ QT4 "Experimental QT4 GUI" OFF
+
+DESKTOP_ENTRIES= "TeXmacs" "${COMMENT}" \
+ "${DATADIR}/misc/pixmaps/TeXmacs.xpm" "texmacs" \
+ "Application;Education;Science;" false
+
+.include <bsd.port.options.mk>
+
.if !defined(WITHOUT_IMLIB2)
USE_EFL= imlib2
CONFIGURE_ARGS+= --with-imlib2
.endif
+.if !defined(WITHOUT_PDF)
+CONFIGURE_ARGS+= --enable-pdf-renderer
+.endif
+
+.if !defined(WITHOUT_QT4)
+CONFIGURE_ARGS+= --enable-qt
+USE_QT_VER= 4
+QT_COMPONENTS= gui moc_build qmake_build uic_build
+.endif
+
.include <bsd.port.pre.mk>
post-patch:
@@ -53,9 +76,7 @@ post-patch:
${WRKSRC}/configure
post-install:
- ${MKDIR} ${DESKTOPDIR}
- ${INSTALL_DATA} ${WRKSRC}/TeXmacs/misc/mime/texmacs.desktop ${DESKTOPDIR}/
${CHOWN} -R ${LIBOWN}:${LIBGRP} ${PREFIX}/libexec/TeXmacs
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/share/TeXmacs
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DATADIR}
.include <bsd.port.post.mk>