aboutsummaryrefslogtreecommitdiff
path: root/editors/texmacs
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2016-08-23 20:31:07 +0000
committerPawel Pekala <pawel@FreeBSD.org>2016-08-23 20:31:07 +0000
commit29f7b3d8283c0a942db00c5712c751a60115c96f (patch)
treeaa42afd95ce63e3ff01ecb198df50e5f1cd04b6d /editors/texmacs
parentd3c4d47567ea8e31887fbcbf07972425df1a71dc (diff)
downloadports-29f7b3d8283c0a942db00c5712c751a60115c96f.tar.gz
ports-29f7b3d8283c0a942db00c5712c751a60115c96f.zip
- Fix build after databases/sqlite update
- Convert to USES=localbase - Register proxy dependencies found by stage-qa
Notes
Notes: svn path=/head/; revision=420744
Diffstat (limited to 'editors/texmacs')
-rw-r--r--editors/texmacs/Makefile10
-rw-r--r--editors/texmacs/files/patch-src_Plugins_Sqlite3_sqlite3.hpp13
2 files changed, 18 insertions, 5 deletions
diff --git a/editors/texmacs/Makefile b/editors/texmacs/Makefile
index d3a3cb4feff9..a504da44fefd 100644
--- a/editors/texmacs/Makefile
+++ b/editors/texmacs/Makefile
@@ -14,15 +14,15 @@ COMMENT= WYSIWYG scientific text editor
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libguile.so:lang/guile
+LIB_DEPENDS= libltdl.so:devel/libltdl \
+ libguile.so:lang/guile \
+ libgmp.so:math/gmp
RUN_DEPENDS= fig2dev:print/transfig
-USES= cpe desktop-file-utils gmake iconv pkgconfig python \
+USES= cpe desktop-file-utils gmake iconv localbase pkgconfig python \
shared-mime-info shebangfix
USE_TEX= tex:run dvipsk:run
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --enable-optimize="${CXXFLAGS}"
MAKE_ARGS= CP="${CP} -R -f"
ALL_TARGET= ${PORTNAME:tu}
@@ -51,7 +51,7 @@ IMLIB2_CONFIGURE_WITH= imlib2
PDF_CONFIGURE_ENABLE= pdf-renderer
PDF_LDFLAGS= -lz
PDF_IMPLIES= FREETYPE GHOSTSCRIPT
-QT4_USE= qt4=accessible,gui,imageformats \
+QT4_USE= qt4=accessible,corelib,gui,imageformats \
qt4=moc_build,qmake_build,rcc_build,uic_build
QT4_USE_OFF= xorg=xext
QT4_CONFIGURE_ON= --with-qt=${QT_PREFIX} --enable-qtpipes
diff --git a/editors/texmacs/files/patch-src_Plugins_Sqlite3_sqlite3.hpp b/editors/texmacs/files/patch-src_Plugins_Sqlite3_sqlite3.hpp
new file mode 100644
index 000000000000..cd1fa8e06c8e
--- /dev/null
+++ b/editors/texmacs/files/patch-src_Plugins_Sqlite3_sqlite3.hpp
@@ -0,0 +1,13 @@
+--- src/Plugins/Sqlite3/sqlite3.hpp.orig 2016-08-22 16:04:07 UTC
++++ src/Plugins/Sqlite3/sqlite3.hpp
+@@ -9,8 +9,8 @@
+ * in the root directory or <http://www.gnu.org/licenses/gpl-3.0.html>.
+ ******************************************************************************/
+
+-#ifndef SQLITE3_H
+-#define SQLITE3_H
++#ifndef TM_SQLITE3_H
++#define TM_SQLITE3_H
+ #include "url.hpp"
+
+ bool sqlite3_present ();