aboutsummaryrefslogtreecommitdiff
path: root/editors/tpad
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-04-07 14:02:39 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-04-07 14:02:39 +0000
commitcaad18deae982bb54f69bbd966b38fa196026178 (patch)
treea4959b33ff8b859fc9328a8054d67a3bb0529b39 /editors/tpad
parent87c176b118ef3216576fc66bc2c9bca31e8b6069 (diff)
downloadports-caad18deae982bb54f69bbd966b38fa196026178.tar.gz
ports-caad18deae982bb54f69bbd966b38fa196026178.zip
- Add staging support
- Define DOCS option
Notes
Notes: svn path=/head/; revision=350481
Diffstat (limited to 'editors/tpad')
-rw-r--r--editors/tpad/Makefile50
-rw-r--r--editors/tpad/pkg-plist2
2 files changed, 20 insertions, 32 deletions
diff --git a/editors/tpad/Makefile b/editors/tpad/Makefile
index d7fa2344586b..8b2f917adb9d 100644
--- a/editors/tpad/Makefile
+++ b/editors/tpad/Makefile
@@ -19,41 +19,27 @@ NO_BUILD= yes
PORTDOCS= ChangeLog bug.html conf.html embed.html index.html intro.html \
keys.html log.html mouse.html tidy.html tidy.png todo tpad.html
-MAN1= tpad.1
-MLINKS= tpad.1 tview.1
PLIST_SUB= LIBDIR=lib/tpad${PORTVERSION}
SUB_FILES= pkg-message
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/bin/tpad ${PREFIX}/bin/tpad
- @${MKDIR} ${PREFIX}/lib/tpad${PORTVERSION}/msgs
- cd ${WRKDIR}/lib/tpad${PORTVERSION}; \
- for libfile in *.tcl; do \
- ${INSTALL_DATA} $$libfile ${PREFIX}/lib/tpad${PORTVERSION}; \
- done
- cd ${WRKDIR}/lib/tpad${PORTVERSION}/msgs; \
- for msgfile in *.msg; do \
- ${INSTALL_DATA} $$msgfile ${PREFIX}/lib/tpad${PORTVERSION}/msgs; \
- done
- @${MKDIR} ${DATADIR}
- cd ${WRKDIR}/share/tpad/; \
- for datafile in *; do \
- ${INSTALL_DATA} $$datafile ${DATADIR}; \
- done
-
-post-install:
- ${TEST} -e ${PREFIX}/bin/tview || (cd ${PREFIX}/bin ; ${LN} -s tpad tview)
-.if !defined(NO_INSTALL_MANPAGES)
- ${INSTALL_MAN} ${WRKDIR}/man/man1/tpad.1 ${MANPREFIX}/man/man1
-.endif
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for docfile in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKDIR}/share/doc/tpad/${docfile} ${DOCSDIR}
-.endfor
-.endif
- ${INSTALL_DATA} ${WRKDIR}/etc/tpad.conf ${PREFIX}/etc/tpad.conf.sample
- @${CAT} ${PKGMESSAGE}
+ ${INSTALL_SCRIPT} ${WRKDIR}/bin/tpad ${STAGEDIR}${PREFIX}/bin/tpad
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/tpad${PORTVERSION}/msgs
+ (cd ${WRKDIR}/lib/tpad${PORTVERSION} && ${INSTALL_DATA} *.tcl \
+ ${STAGEDIR}${PREFIX}/lib/tpad${PORTVERSION})
+ (cd ${WRKDIR}/lib/tpad${PORTVERSION}/msgs && ${INSTALL_DATA} *.msg \
+ ${STAGEDIR}${PREFIX}/lib/tpad${PORTVERSION}/msgs)
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${WRKDIR}/share/tpad && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
+ (cd ${STAGEDIR}${PREFIX}/bin && ${LN} -s tpad tview)
+ ${INSTALL_MAN} ${WRKDIR}/man/man1/tpad.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ (cd ${STAGEDIR}${MANPREFIX}/man/man1 && ${LN} -s tpad.1.gz tview.1.gz)
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKDIR}/share/doc/tpad && ${INSTALL_DATA} ${PORTDOCS} \
+ ${STAGEDIR}${DOCSDIR})
+ ${INSTALL_DATA} ${WRKDIR}/etc/tpad.conf \
+ ${STAGEDIR}${PREFIX}/etc/tpad.conf.sample
.include <bsd.port.mk>
diff --git a/editors/tpad/pkg-plist b/editors/tpad/pkg-plist
index 080a5701d452..15833bbdd220 100644
--- a/editors/tpad/pkg-plist
+++ b/editors/tpad/pkg-plist
@@ -1,6 +1,8 @@
bin/tpad
bin/tview
etc/tpad.conf.sample
+man/man1/tpad.1.gz
+man/man1/tview.1.gz
%%DATADIR%%/Makefile
%%DATADIR%%/tpad-tips
%%DATADIR%%/tpad-tips.dat