aboutsummaryrefslogtreecommitdiff
path: root/editors/wxhexeditor/Makefile
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-05-06 08:40:45 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-05-06 08:40:45 +0000
commit61f54fee4596e07fec0d1123961a6e1532b01911 (patch)
tree1983f15cc453ded999e6f699b19ed394ec483911 /editors/wxhexeditor/Makefile
parent8db9e11bfe0f234925e43a421390e5b5e24d4288 (diff)
downloadports-61f54fee4596e07fec0d1123961a6e1532b01911.tar.gz
ports-61f54fee4596e07fec0d1123961a6e1532b01911.zip
editors/wxhexeditor: fix build with GCC-based architectures
Add USES=compiler:c++11-lang to fix: /usr/local/include/wx-3.0/wx/strvararg.h:350: error: ISO C++ forbids declaration of 'is_enum' with no typeIn file included from /usr/local/include/wx-3.0/wx/string.h:46, Approved by: mentors (implicit approval)
Notes
Notes: svn path=/head/; revision=500900
Diffstat (limited to 'editors/wxhexeditor/Makefile')
-rw-r--r--editors/wxhexeditor/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/editors/wxhexeditor/Makefile b/editors/wxhexeditor/Makefile
index 43274a7901fd..0aae74ff4ec5 100644
--- a/editors/wxhexeditor/Makefile
+++ b/editors/wxhexeditor/Makefile
@@ -16,7 +16,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libudis86.so:devel/udis86 \
libmhash.so:security/mhash
-USES= gettext-tools gmake tar:xz
+USES= compiler:c++11-lang gettext-tools gmake tar:xz
USE_WX= 3.0+
MAKE_ARGS= WXCONFIG="${WX_CONFIG}"