aboutsummaryrefslogtreecommitdiff
path: root/editors/xcoral
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2003-04-08 23:16:28 +0000
committerMikhail Teterin <mi@FreeBSD.org>2003-04-08 23:16:28 +0000
commit2975b9e2af397fa82be470753e39fe544fd2398b (patch)
tree796047d483c0ad2c9f5778cdf8bbb569d4d462b3 /editors/xcoral
parent8c8f742a75eded6db2478f7e22d8699f128fd01f (diff)
downloadports-2975b9e2af397fa82be470753e39fe544fd2398b.tar.gz
ports-2975b9e2af397fa82be470753e39fe544fd2398b.zip
Upgrade from 3.40 to 3.42. Make it use our -lgnuregex instead of compiling
its own (same version). May be, the upgrade will fix the intermittent crashes one of my users was experiencing...
Notes
Notes: svn path=/head/; revision=78632
Diffstat (limited to 'editors/xcoral')
-rw-r--r--editors/xcoral/Makefile3
-rw-r--r--editors/xcoral/distinfo2
-rw-r--r--editors/xcoral/files/patch-regex38
-rw-r--r--editors/xcoral/pkg-plist2
4 files changed, 42 insertions, 3 deletions
diff --git a/editors/xcoral/Makefile b/editors/xcoral/Makefile
index eb7ee2865444..38a548d56135 100644
--- a/editors/xcoral/Makefile
+++ b/editors/xcoral/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xcoral
-PORTVERSION= 3.40
+PORTVERSION= 3.42
CATEGORIES= editors
MASTER_SITES= http://xcoral.free.fr/
@@ -17,6 +17,7 @@ USE_X_PREFIX= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --libdir=${PREFIX}/share
+PLIST_SUB+= PORTVERSION=${PORTVERSION}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xcoral ${PREFIX}/bin
diff --git a/editors/xcoral/distinfo b/editors/xcoral/distinfo
index 3a5eab8abece..0b08d849162b 100644
--- a/editors/xcoral/distinfo
+++ b/editors/xcoral/distinfo
@@ -1 +1 @@
-MD5 (xcoral-3.40.tar.gz) = eb13e9cc63f61662ff06c964e195ba32
+MD5 (xcoral-3.42.tar.gz) = a6169cbaf5b23ff049e9f0848aee7506
diff --git a/editors/xcoral/files/patch-regex b/editors/xcoral/files/patch-regex
new file mode 100644
index 000000000000..61632f1e5393
--- /dev/null
+++ b/editors/xcoral/files/patch-regex
@@ -0,0 +1,38 @@
+This patch makes xcoral use the standard GNU regular expression library,
+installed on FreeBSD as -lgnuregex, instead of compiling its own (of the
+same version).
+
+ -mi
+
+--- Makefile.in Thu Nov 15 16:29:49 2001
++++ Makefile.in Tue Apr 8 19:06:20 2003
+@@ -15,5 +15,5 @@
+ @SET_MAKE@
+
+-LDOPTIONS = @LDFLAGS@
++LDOPTIONS = @LDFLAGS@ -lgnuregex
+
+ XCORALLIBDIR = \"$(XC_LIBDIR)\"
+@@ -32,5 +32,5 @@
+ file_dict.c proc_dict.c gen.tab.c lex.yy.c ie_func.c mode.c \
+ input_str.c process.c warn_box.c dial_box.c fs_box.c list_box.c \
+- man_box.c justify.c macros.c ctr_version.c color_area.c regex.c \
++ man_box.c justify.c macros.c ctr_version.c color_area.c \
+ selection.c tool_bar.c buttons_bits.c tbox.c
+
+@@ -44,5 +44,5 @@
+ global_dict.o file_dict.o proc_dict.o ie_func.o mode.o \
+ input_str.o process.o warn_box.o dial_box.o fs_box.o list_box.o \
+- man_box.o justify.o macros.o ctr_version.o color_area.o regex.o \
++ man_box.o justify.o macros.o ctr_version.o color_area.o \
+ selection.o tool_bar.o buttons_bits.o tbox.o @ALLOCA@
+
+--- bm_search.c Sun Sep 20 12:49:08 1998
++++ bm_search.c Tue Apr 8 19:04:23 2003
+@@ -58,5 +58,5 @@
+ #include <sys/types.h>
+ #define const
+-#include "regex.h"
++#include <gnuregex.h>
+
+ #include "main_text.h"
diff --git a/editors/xcoral/pkg-plist b/editors/xcoral/pkg-plist
index ed00e5371865..92ebdd97768a 100644
--- a/editors/xcoral/pkg-plist
+++ b/editors/xcoral/pkg-plist
@@ -1,5 +1,5 @@
bin/xcoral
-%%PORTDOCS%%share/doc/xcoral/xcoral-3.40.ps
+%%PORTDOCS%%share/doc/xcoral/xcoral-%%PORTVERSION%%.ps
%%PORTDOCS%%share/doc/xcoral/xcoral-card.ps
share/xcoral/DEPEND
share/xcoral/README