aboutsummaryrefslogtreecommitdiff
path: root/editors/xed/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2020-01-31 13:58:43 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2020-01-31 13:58:43 +0000
commitaf8b56bb00cb1067f6db169c2dc942d92e3fc7dd (patch)
tree900cf0609ca3af5d36fe34a0cbfe648292582b30 /editors/xed/Makefile
parentf0b20f01594d7d65e95f9affb271edff74e09c1b (diff)
downloadports-af8b56bb00cb1067f6db169c2dc942d92e3fc7dd.tar.gz
ports-af8b56bb00cb1067f6db169c2dc942d92e3fc7dd.zip
xed is a small and lightweight text editor, which supports most standard
editing features, plus several not typically found in one's average text editor (plugins being the most notable of these). WWW: https://github.com/linuxmint/xed This is not a resurrection of the previous `editors/xed' that was removed in r506581 as abandonware.
Notes
Notes: svn path=/head/; revision=524706
Diffstat (limited to 'editors/xed/Makefile')
-rw-r--r--editors/xed/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/editors/xed/Makefile b/editors/xed/Makefile
new file mode 100644
index 000000000000..42864ead633e
--- /dev/null
+++ b/editors/xed/Makefile
@@ -0,0 +1,33 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= xed
+PORTVERSION= 2.4.2
+CATEGORIES= editors
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Small and lightweight graphical text editor
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= intltool-merge:textproc/intltool \
+ itstool:textproc/itstool
+LIB_DEPENDS= libpeas-1.0.so:devel/libpeas \
+ libxapp.so:x11/xapps
+RUN_DEPENDS= ${LOCALBASE}/share/glib-2.0/schemas/org.gnome.desktop.interface.gschema.xml:devel/gsettings-desktop-schemas
+
+USES= desktop-file-utils gettext-tools gnome meson pkgconfig xorg
+USE_GITHUB= yes
+GH_ACCOUNT= linuxmint
+USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk30 gtksourceview3 \
+ introspection pango
+USE_XORG= x11
+GLIB_SCHEMAS= org.x.editor.gschema.xml \
+ org.x.editor.plugins.filebrowser.gschema.xml \
+ org.x.editor.plugins.time.gschema.xml \
+ org.x.editor.plugins.wordcompletion.gschema.xml
+
+# XXX: should become OPTIONs
+MESON_ARGS= -Denable_spell=false
+
+.include <bsd.port.mk>