aboutsummaryrefslogtreecommitdiff
path: root/editors/zile/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-05-09 09:19:01 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-05-09 09:19:01 +0000
commit9a367b48deb395a7356f696bb7ac35a6323cb752 (patch)
tree35689461c68f9c1e72b0a179624e908a85b1651f /editors/zile/Makefile
parentd8ff394b3488f2c43d9a35154088414827fe636e (diff)
downloadports-9a367b48deb395a7356f696bb7ac35a6323cb752.tar.gz
ports-9a367b48deb395a7356f696bb7ac35a6323cb752.zip
- Update to 2.3.7
PR: 134281 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=233508
Diffstat (limited to 'editors/zile/Makefile')
-rw-r--r--editors/zile/Makefile22
1 files changed, 6 insertions, 16 deletions
diff --git a/editors/zile/Makefile b/editors/zile/Makefile
index f87620c8ea66..906a91a755b5 100644
--- a/editors/zile/Makefile
+++ b/editors/zile/Makefile
@@ -6,39 +6,29 @@
#
PORTNAME= zile
-PORTVERSION= 2.3.4
+PORTVERSION= 2.3.7
CATEGORIES= editors
MASTER_SITES= GNU
MAINTAINER= ports@FreeBSD.org
COMMENT= Small emacs-like text editor
-BUILD_DEPENDS= help2man:${PORTSDIR}/misc/help2man
-
-USE_LUA= 5.0+
-LUA_COMPS= lua:build
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-lgnuregex" \
- ac_cv_path_LUA="${LUA_CMD}"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --without-included-regex
MAN1= zile.1
PLIST_FILES= bin/zile %%DATADIR%%/FAQ %%DATADIR%%/dotzile.sample
PLIST_DIRS= %%DATADIR%%
+CPPFLAGS= -isystem /usr/include/gnu
+LDFLAGS= -lgnuregex
+
post-patch:
@${REINPLACE_CMD} -e \
- 's|<regex\.h>|<gnu/regex.h>|g ; \
- s|-pedantic||g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e \
- 's|"regex\.h"|<gnu/regex.h>|g' ${WRKSRC}/src/search.c
+ 's|-pedantic||g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e \
's|: install-exec-local|:|g' ${WRKSRC}/lib/Makefile.in
-pre-build:
- @${RM} -f ${WRKSRC}/src/tbl_funcs.h
- @(cd ${BUILD_WRKSRC}/src; ${SETENV} ${MAKE_ENV} ${GMAKE} \
- ${MAKE_FLAGS} ${MAKEFILE} tbl_funcs.h)
-
.include <bsd.port.mk>