aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2007-05-03 14:47:05 +0000
committerMaho Nakata <maho@FreeBSD.org>2007-05-03 14:47:05 +0000
commit0968ea948183479e7fd437cb9d493fc3278f36c9 (patch)
treee215431b679867dcfa60e91d892061ed522f7a8f /editors
parentaf3dbfe39e0f7f6e9495d74666685b6735e3f64c (diff)
downloadports-0968ea948183479e7fd437cb9d493fc3278f36c9.tar.gz
ports-0968ea948183479e7fd437cb9d493fc3278f36c9.zip
Fix build after objformat removal.
Notes
Notes: svn path=/head/; revision=191482
Diffstat (limited to 'editors')
-rw-r--r--editors/openoffice.org-1.1/files/moz-patch189
-rw-r--r--editors/openoffice.org-1.1/files/patch-objformat230
2 files changed, 405 insertions, 14 deletions
diff --git a/editors/openoffice.org-1.1/files/moz-patch b/editors/openoffice.org-1.1/files/moz-patch
index 0d4947d1c5a0..b37c1cbc1b37 100644
--- a/editors/openoffice.org-1.1/files/moz-patch
+++ b/editors/openoffice.org-1.1/files/moz-patch
@@ -7,6 +7,8 @@ http://qa.openoffice.org/issues/show_bug.cgi?id=11424
disable freetype2 support since build broken and
this functionality is not used at all.
+fix build after /usr/bin/objformat removal
+
--- moz/extractfiles.mk.org Sat Oct 30 22:01:49 2004
+++ moz/extractfiles.mk Sat Oct 30 22:00:21 2004
@@ -269,8 +269,8 @@
@@ -21,14 +23,11 @@ this functionality is not used at all.
.IF "$(GUI)"=="UNX"
---- moz/mozilla-source-1.0.patch.org Tue Feb 10 19:44:34 2004
-+++ moz/mozilla-source-1.0.patch Sat Mar 19 12:51:35 2005
-@@ -4471,14 +4471,17 @@
- return NS_OK;
- }
+--- moz/mozilla-source-1.0.patch Thu May 3 09:11:47 2007
++++ moz/mozilla-source-1.0.patch Thu May 3 09:10:12 2007
+@@ -4473,12 +4473,15 @@
----- miss/build/mozilla/.mozconfig Tue Jul 22 21:52:27 2003
-+--- misc/build/mozilla/.mozconfig Tue Jul 22 21:52:27 2003
+ --- misc/build/mozilla/.mozconfig Tue Jul 22 21:52:27 2003
+++ misc/build/mozilla/.mozconfig Mon Jul 28 15:07:20 2003
-@@ -0,0 +1,8 @@
+@@ -0,0 +1,11 @@
@@ -43,7 +42,7 @@ this functionality is not used at all.
+ac_add_options --enable-optimize
+ac_add_options --enable-crypto
+ac_add_options --enable-strip
-@@ -4497,3 +4500,19 @@
+@@ -4497,3 +4500,233 @@
endif
# Windows equivalents
@@ -63,15 +62,26 @@ this functionality is not used at all.
+ #endif
+
+ /*
---- moz/mozilla-source-1.0.patch~ Sun Sep 10 09:28:29 2006
-+++ moz/mozilla-source-1.0.patch Sun Sep 10 12:01:05 2006
-@@ -4516,3 +4516,49 @@
- #endif
-
- /*
+*** misc/mozilla/configure Tue May 28 04:29:00 2002
+--- misc/build/mozilla/configure Sun Sep 10 11:56:33 2006
+***************
++*** 4565,4571 ****
++ ;;
++
++ *-freebsd*)
++! if test `test -x /usr/bin/objformat && /usr/bin/objformat || echo aout` != "elf"; then
++ DLL_SUFFIX=".so.1.0"
++ DSO_LDOPTS="-shared"
++ fi
++--- 4565,4571 ----
++ ;;
++
++ *-freebsd*)
++! if test `test -x /usr/bin/objformat && /usr/bin/objformat || echo elf` != "elf"; then
++ DLL_SUFFIX=".so.1.0"
++ DSO_LDOPTS="-shared"
++ fi
++***************
+*** 6589,6594 ****
+--- 6589,6596 ----
+ case $target in
@@ -85,6 +95,23 @@ this functionality is not used at all.
+*** misc/mozilla/configure.in Tue May 28 04:29:12 2002
+--- misc/build/mozilla/configure.in Sun Sep 10 11:56:18 2006
+***************
++*** 787,793 ****
++ ;;
++
++ *-freebsd*)
++! if test `test -x /usr/bin/objformat && /usr/bin/objformat || echo aout` != "elf"; then
++ DLL_SUFFIX=".so.1.0"
++ DSO_LDOPTS="-shared"
++ fi
++--- 787,793 ----
++ ;;
++
++ *-freebsd*)
++! if test `test -x /usr/bin/objformat && /usr/bin/objformat || echo elf` != "elf"; then
++ DLL_SUFFIX=".so.1.0"
++ DSO_LDOPTS="-shared"
++ fi
++***************
+*** 1606,1611 ****
+--- 1606,1613 ----
+ case $target in
@@ -95,6 +122,140 @@ this functionality is not used at all.
+ *)
+ AC_CHECK_LIB(c_r, gethostbyname_r)
+ ;;
++*** misc/mozilla/directory/c-sdk/config/FreeBSD.mk Wed Apr 10 11:31:55 2002
++--- misc/build/mozilla/directory/c-sdk/config/FreeBSD.mk Thu May 3 07:55:57 2007
++***************
++*** 66,72 ****
++
++ ARCH = freebsd
++
++! MOZ_OBJFORMAT := $(shell test -x /usr/bin/objformat && /usr/bin/objformat || echo aout)
++
++ ifeq ($(MOZ_OBJFORMAT),elf)
++ DLL_SUFFIX = so
++--- 66,72 ----
++
++ ARCH = freebsd
++
++! MOZ_OBJFORMAT := $(shell test -x /usr/bin/objformat && /usr/bin/objformat || echo elf)
++
++ ifeq ($(MOZ_OBJFORMAT),elf)
++ DLL_SUFFIX = so
++*** misc/mozilla/directory/c-sdk/configure Wed Apr 10 11:31:53 2002
++--- misc/build/mozilla/directory/c-sdk/configure Thu May 3 07:58:33 2007
++***************
++*** 3410,3416 ****
++ EOF
++
++ CFLAGS="$CFLAGS $(DSO_CFLAGS) -ansi -Wall"
++! MOZ_OBJFORMAT=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
++ if test "$MOZ_OBJFORMAT" = "elf"; then
++ DLL_SUFFIX=so
++ else
++--- 3410,3416 ----
++ EOF
++
++ CFLAGS="$CFLAGS $(DSO_CFLAGS) -ansi -Wall"
++! MOZ_OBJFORMAT=`test -x /usr/bin/objformat && /usr/bin/objformat || echo elf`
++ if test "$MOZ_OBJFORMAT" = "elf"; then
++ DLL_SUFFIX=so
++ else
++*** misc/mozilla/directory/c-sdk/configure.in Wed Apr 10 11:31:54 2002
++--- misc/build/mozilla/directory/c-sdk/configure.in Thu May 3 07:58:48 2007
++***************
++*** 900,906 ****
++ AC_DEFINE(FREEBSD)
++ AC_DEFINE(HAVE_BSD_FLOCK)
++ CFLAGS="$CFLAGS $(DSO_CFLAGS) -ansi -Wall"
++! MOZ_OBJFORMAT=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
++ if test "$MOZ_OBJFORMAT" = "elf"; then
++ DLL_SUFFIX=so
++ else
++--- 900,906 ----
++ AC_DEFINE(FREEBSD)
++ AC_DEFINE(HAVE_BSD_FLOCK)
++ CFLAGS="$CFLAGS $(DSO_CFLAGS) -ansi -Wall"
++! MOZ_OBJFORMAT=`test -x /usr/bin/objformat && /usr/bin/objformat || echo elf`
++ if test "$MOZ_OBJFORMAT" = "elf"; then
++ DLL_SUFFIX=so
++ else
++*** misc/mozilla/nsprpub/configure Tue Sep 14 17:14:38 2004
++--- misc/build/mozilla/nsprpub/configure Wed Apr 4 20:56:33 2007
++***************
++*** 3407,3413 ****
++ EOF
++
++ CFLAGS="$CFLAGS $(DSO_CFLAGS) -ansi -Wall"
++! MOZ_OBJFORMAT=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
++ if test "$MOZ_OBJFORMAT" = "elf"; then
++ DLL_SUFFIX=so
++ else
++--- 3407,3413 ----
++ EOF
++
++ CFLAGS="$CFLAGS $(DSO_CFLAGS) -ansi -Wall"
++! MOZ_OBJFORMAT=`test -x /usr/bin/objformat && /usr/bin/objformat || echo elf`
++ if test "$MOZ_OBJFORMAT" = "elf"; then
++ DLL_SUFFIX=so
++ else
++*** misc/mozilla/nsprpub/configure.in Tue Sep 14 17:14:38 2004
++--- misc/build/mozilla/nsprpub/configure.in Wed Apr 4 20:56:40 2007
++***************
++*** 922,928 ****
++ AC_DEFINE(HAVE_BSD_FLOCK)
++ AC_DEFINE(HAVE_SOCKLEN_T)
++ CFLAGS="$CFLAGS $(DSO_CFLAGS) -ansi -Wall"
++! MOZ_OBJFORMAT=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
++ if test "$MOZ_OBJFORMAT" = "elf"; then
++ DLL_SUFFIX=so
++ else
++--- 922,928 ----
++ AC_DEFINE(HAVE_BSD_FLOCK)
++ AC_DEFINE(HAVE_SOCKLEN_T)
++ CFLAGS="$CFLAGS $(DSO_CFLAGS) -ansi -Wall"
++! MOZ_OBJFORMAT=`test -x /usr/bin/objformat && /usr/bin/objformat || echo elf`
++ if test "$MOZ_OBJFORMAT" = "elf"; then
++ DLL_SUFFIX=so
++ else
++
++*** misc/mozilla/security/coreconf/FreeBSD.mk Wed Mar 26 20:17:25 2003
++--- misc/build/mozilla/security/coreconf/FreeBSD.mk Wed Apr 4 20:56:48 2007
++***************
++*** 63,69 ****
++
++ ARCH = freebsd
++
++! MOZ_OBJFORMAT := $(shell test -x /usr/bin/objformat && /usr/bin/objformat || echo aout)
++
++ ifeq ($(MOZ_OBJFORMAT),elf)
++ DLL_SUFFIX = so
++--- 63,69 ----
++
++ ARCH = freebsd
++
++! MOZ_OBJFORMAT := $(shell test -x /usr/bin/objformat && /usr/bin/objformat || echo elf)
++
++ ifeq ($(MOZ_OBJFORMAT),elf)
++ DLL_SUFFIX = so
++*** misc/mozilla/nsprpub/config/FreeBSD.mk Wed Apr 10 12:16:03 2002
++--- misc/build/mozilla/nsprpub/config/FreeBSD.mk Thu May 3 08:07:27 2007
++***************
++*** 66,72 ****
++
++ ARCH = freebsd
++
++! MOZ_OBJFORMAT := $(shell test -x /usr/bin/objformat && /usr/bin/objformat || echo aout)
++
++ ifeq ($(MOZ_OBJFORMAT),elf)
++ DLL_SUFFIX = so
++--- 66,72 ----
++
++ ARCH = freebsd
++
++! MOZ_OBJFORMAT := $(shell test -x /usr/bin/objformat && /usr/bin/objformat || echo elf)
++
++ ifeq ($(MOZ_OBJFORMAT),elf)
++ DLL_SUFFIX = so
+*** misc/mozilla/nsprpub/pr/src/misc/prnetdb.c Wed Apr 10 12:17:35 2002
+--- misc/build/mozilla/nsprpub/pr/src/misc/prnetdb.c Sun Sep 10 11:55:27 2006
+***************
diff --git a/editors/openoffice.org-1.1/files/patch-objformat b/editors/openoffice.org-1.1/files/patch-objformat
new file mode 100644
index 000000000000..53587fc236d8
--- /dev/null
+++ b/editors/openoffice.org-1.1/files/patch-objformat
@@ -0,0 +1,230 @@
+--- /dev/null Thu May 3 10:02:14 2007
++++ berkeleydb/db-4.2.52.patch Thu May 3 09:52:51 2007
+@@ -0,0 +1,70 @@
++*** misc/db-4.2.52.NC/dist/configure 2003-12-03 22:10:02.000000000 +0100
++--- misc/build/db-4.2.52.NC/dist/configure 2007-02-19 16:12:12.000000000 +0100
++***************
++*** 9328,9334 ****
++ ;;
++
++ freebsd*)
++! objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
++ version_type=freebsd-$objformat
++ case $version_type in
++ freebsd-elf*)
++--- 9328,9334 ----
++ ;;
++
++ freebsd*)
++! objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo elf`
++ version_type=freebsd-$objformat
++ case $version_type in
++ freebsd-elf*)
++***************
++*** 12872,12878 ****
++ ;;
++
++ freebsd*)
++! objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
++ version_type=freebsd-$objformat
++ case $version_type in
++ freebsd-elf*)
++--- 12872,12878 ----
++ ;;
++
++ freebsd*)
++! objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo elf`
++ version_type=freebsd-$objformat
++ case $version_type in
++ freebsd-elf*)
++***************
++*** 15849,15855 ****
++ ;;
++
++ freebsd*)
++! objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
++ version_type=freebsd-$objformat
++ case $version_type in
++ freebsd-elf*)
++--- 15849,15855 ----
++ ;;
++
++ freebsd*)
++! objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo elf`
++ version_type=freebsd-$objformat
++ case $version_type in
++ freebsd-elf*)
++***************
++*** 18114,18120 ****
++ ;;
++
++ freebsd*)
++! objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
++ version_type=freebsd-$objformat
++ case $version_type in
++ freebsd-elf*)
++--- 18114,18120 ----
++ ;;
++
++ freebsd*)
++! objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo elf`
++ version_type=freebsd-$objformat
++ case $version_type in
++ freebsd-elf*)
+Index: berkeleydb/makefile.mk
+===================================================================
+RCS file: /cvs/external/berkeleydb/makefile.mk,v
+retrieving revision 1.13.12.2
+diff -u -r1.13.12.2 makefile.mk
+--- berkeleydb/makefile.mk 28 Oct 2004 11:54:48 -0000 1.13.12.2
++++ berkeleydb/makefile.mk 3 May 2007 01:04:40 -0000
+@@ -73,6 +73,8 @@
+
+ TARFILE_NAME=db-4.2.52.NC
+
++PATCH_FILE_NAME=db-4.2.52.patch
++
+ # not needed for win32. comment out when causing problems...
+
+ .IF "$(GUI)"=="UNX"
+
+Index: curl/unx1-curl-7.9.8.patch
+===================================================================
+RCS file: /cvs/external/curl/Attic/unx1-curl-7.9.8.patch,v
+retrieving revision 1.2.18.1
+diff -u -r1.2.18.1 unx1-curl-7.9.8.patch
+--- curl/unx1-curl-7.9.8.patch 3 May 2004 16:32:05 -0000 1.2.18.1
++++ curl/unx1-curl-7.9.8.patch 3 May 2007 01:13:15 -0000
+@@ -251,3 +251,22 @@
+ /*************************************************************
+ * No protocol part in URL was used, add it!
+ *************************************************************/
++*** misc/curl-7.9.8/configure Wed Jun 12 00:16:54 2002
++--- misc/build/curl-7.9.8/configure Thu May 3 10:10:42 2007
++***************
++*** 6292,6298 ****
++ ;;
++
++ freebsd*)
++! objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
++ version_type=freebsd-$objformat
++ case $version_type in
++ freebsd-elf*)
++--- 6292,6298 ----
++ ;;
++
++ freebsd*)
++! objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo elf`
++ version_type=freebsd-$objformat
++ case $version_type in
++ freebsd-elf*)
+Index: freetype/freetype-2.1.4.patch
+===================================================================
+RCS file: /cvs/external/freetype/Attic/freetype-2.1.4.patch,v
+retrieving revision 1.2
+diff -u -r1.2 freetype-2.1.4.patch
+--- freetype/freetype-2.1.4.patch 17 Apr 2003 15:11:01 -0000 1.2
++++ freetype/freetype-2.1.4.patch 3 May 2007 01:15:56 -0000
+@@ -131,3 +131,22 @@
+
+ /* XXX If some new encodings to represent UCS-4 are added, */
+ /* they should be added here. */
++*** misc/freetype-2.1.4/builds/unix/configure Sun Jan 19 01:39:18 2003
++--- misc/build/freetype-2.1.4/builds/unix/configure Thu May 3 10:14:26 2007
++***************
++*** 7203,7209 ****
++ ;;
++
++ freebsd*)
++! objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
++ version_type=freebsd-$objformat
++ case $version_type in
++ freebsd-elf*)
++--- 7203,7209 ----
++ ;;
++
++ freebsd*)
++! objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo elf`
++ version_type=freebsd-$objformat
++ case $version_type in
++ freebsd-elf*)
+
+Index: sndfile/libsndfile-1.0.9.patch
+===================================================================
+RCS file: /cvs/external/sndfile/libsndfile-1.0.9.patch,v
+retrieving revision 1.2
+diff -u -r1.2 libsndfile-1.0.9.patch
+--- sndfile/libsndfile-1.0.9.patch 31 May 2005 16:31:31 -0000 1.2
++++ sndfile/libsndfile-1.0.9.patch 3 May 2007 01:21:01 -0000
+@@ -83,6 +83,23 @@
+ shlibpath_var=DYLD_LIBRARY_PATH
+ shrext='$(test .$module = .yes && echo .so || echo .dylib)'
+ ***************
++*** 7871,7877 ****
++ ;;
++
++ freebsd*)
++! objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
++ version_type=freebsd-$objformat
++ case $version_type in
++ freebsd-elf*)
++--- 7878,7884 ----
++ ;;
++
++ freebsd*)
++! objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo elf`
++ version_type=freebsd-$objformat
++ case $version_type in
++ freebsd-elf*)
++***************
+ *** 9111,9120 ****
+ ;;
+ esac
+@@ -143,6 +160,23 @@
+ module_expsym_cmds_CXX='sed -e "s,#.*,," -e "s,^[ ]*,," -e "s,^\(..*\),_&," < $export_symbols > $output_objdir/${libname}-symbols.expsym~$CC $allow_undefined_flag -o $lib -bundle $libobjs $deplibs$compiler_flags~nmedit -s $output_objdir/${libname}-symbols.expsym ${lib}'
+ hardcode_direct_CXX=no
+ ***************
++*** 11560,11566 ****
++ ;;
++
++ freebsd*)
++! objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
++ version_type=freebsd-$objformat
++ case $version_type in
++ freebsd-elf*)
++--- 11567,11573 ----
++ ;;
++
++ freebsd*)
++! objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo elf`
++ version_type=freebsd-$objformat
++ case $version_type in
++ freebsd-elf*)
++***************
+ *** 14069,14084 ****
+ lt_int_apple_cc_single_mod=yes
+ fi
+@@ -178,6 +212,23 @@
+ module_expsym_cmds_F77='sed -e "s,#.*,," -e "s,^[ ]*,," -e "s,^\(..*\),_&," < $export_symbols > $output_objdir/${libname}-symbols.expsym~$CC $allow_undefined_flag -o $lib -bundle $libobjs $deplibs$compiler_flags~nmedit -s $output_objdir/${libname}-symbols.expsym ${lib}'
+ hardcode_direct_F77=no
+ ***************
++*** 14700,14706 ****
++ ;;
++
++ freebsd*)
++! objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
++ version_type=freebsd-$objformat
++ case $version_type in
++ freebsd-elf*)
++--- 14707,14713 ----
++ ;;
++
++ freebsd*)
++! objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo elf`
++ version_type=freebsd-$objformat
++ case $version_type in
++ freebsd-elf*)
++***************
+ *** 16414,16429 ****
+ lt_int_apple_cc_single_mod=yes
+ fi