aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2004-03-14 06:17:56 +0000
committerAde Lovett <ade@FreeBSD.org>2004-03-14 06:17:56 +0000
commit3f651573ad3b90cf8e6539c52b4b34a1df543fa6 (patch)
tree14261786c359f03d9574a1c204f76ddc8ec4db8a /editors
parent003520276a84300843c37e85ff39f416dec0bd8e (diff)
downloadports-3f651573ad3b90cf8e6539c52b4b34a1df543fa6.tar.gz
ports-3f651573ad3b90cf8e6539c52b4b34a1df543fa6.zip
Whoa there, boy, that's a mighty big commit y'all have there...
Begin autotools sanitization sequence by requiring ports to explicitly specify which version of {libtool,autoconf,automake} they need, erasing the concept of a "system default". For ports-in-waiting: USE_LIBTOOL=YES -> USE_LIBTOOL_VER=13 USE_AUTOCONF=YES -> USE_AUTOCONF_VER=213 USE_AUTOMAKE=YES -> USE_AUTOMAKE_VER=14 Ports attempting to use the old style system after June 1st 2004 will be sorely disappointed.
Notes
Notes: svn path=/head/; revision=103963
Diffstat (limited to 'editors')
-rw-r--r--editors/AbiWord2/Makefile1
-rw-r--r--editors/abiword-devel/Makefile1
-rw-r--r--editors/abiword/Makefile1
-rw-r--r--editors/conglomerate/Makefile2
-rw-r--r--editors/emacs20-dl/Makefile2
-rw-r--r--editors/emacs20-mule-devel/Makefile2
-rw-r--r--editors/gedit-plugins/Makefile2
-rw-r--r--editors/gedit2/Makefile2
-rw-r--r--editors/ghex2/Makefile2
-rw-r--r--editors/gnotepad+/Makefile2
-rw-r--r--editors/lpe/Makefile2
-rw-r--r--editors/mlview/Makefile2
-rw-r--r--editors/xemacs21-mule/Makefile2
-rw-r--r--editors/xmleditor/Makefile2
14 files changed, 11 insertions, 14 deletions
diff --git a/editors/AbiWord2/Makefile b/editors/AbiWord2/Makefile
index 0281ac7083f2..be9c70a03eda 100644
--- a/editors/AbiWord2/Makefile
+++ b/editors/AbiWord2/Makefile
@@ -28,7 +28,6 @@ WRKSRC= ${WRKDIR}/abiword-${PORTVERSION}/abi
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_AUTOMAKE= yes
USE_AUTOMAKE_VER=14
USE_AUTOCONF_VER=213
USE_GMAKE= yes
diff --git a/editors/abiword-devel/Makefile b/editors/abiword-devel/Makefile
index 0281ac7083f2..be9c70a03eda 100644
--- a/editors/abiword-devel/Makefile
+++ b/editors/abiword-devel/Makefile
@@ -28,7 +28,6 @@ WRKSRC= ${WRKDIR}/abiword-${PORTVERSION}/abi
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_AUTOMAKE= yes
USE_AUTOMAKE_VER=14
USE_AUTOCONF_VER=213
USE_GMAKE= yes
diff --git a/editors/abiword/Makefile b/editors/abiword/Makefile
index 0281ac7083f2..be9c70a03eda 100644
--- a/editors/abiword/Makefile
+++ b/editors/abiword/Makefile
@@ -28,7 +28,6 @@ WRKSRC= ${WRKDIR}/abiword-${PORTVERSION}/abi
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_AUTOMAKE= yes
USE_AUTOMAKE_VER=14
USE_AUTOCONF_VER=213
USE_GMAKE= yes
diff --git a/editors/conglomerate/Makefile b/editors/conglomerate/Makefile
index 1bb0b88632e5..fd1e1281ddeb 100644
--- a/editors/conglomerate/Makefile
+++ b/editors/conglomerate/Makefile
@@ -16,7 +16,7 @@ COMMENT= GNOME2 visual XML editor with emphasis on DocBook editing
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= libgnomeui gtksourceview gnomeprefix gnomehack intlhack lthack
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER= 13
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/editors/emacs20-dl/Makefile b/editors/emacs20-dl/Makefile
index 5170a7a21f4f..9c77f2677f54 100644
--- a/editors/emacs20-dl/Makefile
+++ b/editors/emacs20-dl/Makefile
@@ -30,7 +30,7 @@ RUN_DEPENDS= emacs-${EMACS_VER}:${PORTSDIR}/editors/emacs20
WRKSRC= ${WRKDIR}/emacs-${EMACS_VER}
-USE_AUTOCONF= yes
+USE_AUTOCONF_VER= 213
USE_GMAKE= yes
MAKE_ENV= INSTALL_SCRIPT="${INSTALL_SCRIPT}"
EMACS_VER= 20.7
diff --git a/editors/emacs20-mule-devel/Makefile b/editors/emacs20-mule-devel/Makefile
index dd1b0ef02f8c..7f5f7684efa4 100644
--- a/editors/emacs20-mule-devel/Makefile
+++ b/editors/emacs20-mule-devel/Makefile
@@ -31,7 +31,7 @@ RUN_DEPENDS= emacs-${EMACS_VER}:${PORTSDIR}/editors/emacs20
WRKSRC= ${WRKDIR}/emacs-${EMACS_VER}
-USE_AUTOCONF= yes
+USE_AUTOCONF_VER= 213
USE_GMAKE= yes
MAKE_ENV= INSTALL_SCRIPT="${INSTALL_SCRIPT}"
EMACS_VER= 20.7
diff --git a/editors/gedit-plugins/Makefile b/editors/gedit-plugins/Makefile
index ecef2fdc0f08..736ac527c6a4 100644
--- a/editors/gedit-plugins/Makefile
+++ b/editors/gedit-plugins/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
USE_BZIP2= yes
USE_PERL5= yes
USE_X_PREFIX= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER= 13
INSTALLS_SHLIB= yes
USE_GNOME= gnomehack gnomeprefix gnometarget lthack
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/editors/gedit2/Makefile b/editors/gedit2/Makefile
index 8093989166ba..d9331404264b 100644
--- a/editors/gedit2/Makefile
+++ b/editors/gedit2/Makefile
@@ -23,7 +23,7 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
INSTALLS_SHLIB= yes
USE_GMAKE= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
USE_GNOME= gnomeprefix gnomehack gnomehier libgnomeprintui libgnomeui \
eel2 gtksourceview
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/editors/ghex2/Makefile b/editors/ghex2/Makefile
index c1e441059a75..2c4520c651ea 100644
--- a/editors/ghex2/Makefile
+++ b/editors/ghex2/Makefile
@@ -21,7 +21,7 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gail libgnomeprintui libgnomeui
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/editors/gnotepad+/Makefile b/editors/gnotepad+/Makefile
index 5ca866b3851e..681c80b7ca43 100644
--- a/editors/gnotepad+/Makefile
+++ b/editors/gnotepad+/Makefile
@@ -26,7 +26,7 @@ USE_REINPLACE= yes
USE_XPM= yes
WANT_GNOME= yes
USE_GNOME= gtk12
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/editors/lpe/Makefile b/editors/lpe/Makefile
index b8b19a3bdbfb..e2a5ab696972 100644
--- a/editors/lpe/Makefile
+++ b/editors/lpe/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= slang.1:${PORTSDIR}/devel/libslang
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
CONFIGURE_ENV= LDFLAGS="-L${PREFIX}/lib -L${LOCALBASE}/lib" \
CPPFLAGS="-I${PREFIX}/include -I${LOCALBASE}/include" \
LIBS="-ltermcap"
diff --git a/editors/mlview/Makefile b/editors/mlview/Makefile
index e818c9aa7e0d..36e379e6c525 100644
--- a/editors/mlview/Makefile
+++ b/editors/mlview/Makefile
@@ -21,7 +21,7 @@ USE_X_PREFIX= yes
USE_AUTOCONF_VER= 253
USE_GNOME= gnomeprefix gnomehack libgnomeui
USE_GMAKE= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
diff --git a/editors/xemacs21-mule/Makefile b/editors/xemacs21-mule/Makefile
index 54864abd6f5b..ece32c189874 100644
--- a/editors/xemacs21-mule/Makefile
+++ b/editors/xemacs21-mule/Makefile
@@ -43,7 +43,7 @@ XEMACS_ARCH= ${CONFIGURE_TARGET}
USE_GETTEXT= yes
USE_XLIB= yes
STRIP=
-USE_AUTOCONF= yes
+USE_AUTOCONF_VER= 213
CONFIGURE_TARGET=${MACHINE_ARCH}--freebsd
CONFIGURE_ARGS= --with-x11 \
diff --git a/editors/xmleditor/Makefile b/editors/xmleditor/Makefile
index 90e8967dbdc5..e3fe0e58f51e 100644
--- a/editors/xmleditor/Makefile
+++ b/editors/xmleditor/Makefile
@@ -21,7 +21,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_BISON= yes
USE_GNOME= gnomehack libglade
USE_GMAKE= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \