aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2007-01-19 17:17:56 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2007-01-19 17:17:56 +0000
commit4bf154add70057460e4b5ed5274dd0377dd6846d (patch)
treeb6c339831dbb69fb7a0d778c0ac86ccb2e53c567 /editors
parent0d451e059805e7c78dc584040e6fd15f4415b53a (diff)
downloadports-4bf154add70057460e4b5ed5274dd0377dd6846d.tar.gz
ports-4bf154add70057460e4b5ed5274dd0377dd6846d.zip
Update to rospell-2007.00:
- multiwindow editing - LaTeX support - table of contents support for C/C++/Javascript - kloc functionality - new ctags engine - code beautifier - help menu - context help support for POSIX standard header files - context help support for LaTeX - proxy traversing support for webload feature - several FreeBSD fixes
Notes
Notes: svn path=/head/; revision=182806
Diffstat (limited to 'editors')
-rw-r--r--editors/rospell/Makefile4
-rw-r--r--editors/rospell/distinfo6
-rw-r--r--editors/rospell/files/patch-BSDmakefile58
-rw-r--r--editors/rospell/pkg-plist38
4 files changed, 101 insertions, 5 deletions
diff --git a/editors/rospell/Makefile b/editors/rospell/Makefile
index ca8dea6259c7..9c6db0d00825 100644
--- a/editors/rospell/Makefile
+++ b/editors/rospell/Makefile
@@ -6,8 +6,8 @@
# $FreeBSD$
PORTNAME= rospell
-PORTVERSION= 2006.01
-PORTREVISION= 1
+PORTVERSION= 2007.00
+PORTREVISION= 0
CATEGORIES= editors textproc # this should/will be romanian ;)
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/editors/rospell/distinfo b/editors/rospell/distinfo
index 40d4dc93f810..0d7c2f435c91 100644
--- a/editors/rospell/distinfo
+++ b/editors/rospell/distinfo
@@ -1,3 +1,3 @@
-MD5 (rospell-2006.01.tar.gz) = b9530fad4994508d0f0596c23bc9064c
-SHA256 (rospell-2006.01.tar.gz) = 360b1931016317459d5204e93e6f125f8175b4f77e414032c21e231bd7537268
-SIZE (rospell-2006.01.tar.gz) = 1124939
+MD5 (rospell-2007.00.tar.gz) = d34dcba5d5e685366cd98709362c9c16
+SHA256 (rospell-2007.00.tar.gz) = 01f7aa347307e7d82a96483af1e7b91ee10687661ec9f90a97b6ce362be4ff04
+SIZE (rospell-2007.00.tar.gz) = 1417746
diff --git a/editors/rospell/files/patch-BSDmakefile b/editors/rospell/files/patch-BSDmakefile
new file mode 100644
index 000000000000..b8888fad9298
--- /dev/null
+++ b/editors/rospell/files/patch-BSDmakefile
@@ -0,0 +1,58 @@
+--- ./BSDmakefile.orig Fri Jan 19 16:17:31 2007
++++ ./BSDmakefile Fri Jan 19 18:36:12 2007
+@@ -1,9 +1,13 @@
+ ###############################################################################
++# $Tecnik: people/itetcu/ports/myports/rospell/BSDmakefile,v 1.4 2007/01/19 16:36:08 itetcu Exp $
+ # Based on $Id: BSDmakefile,v 1.18 2005/11/20 18:09:54 itetcu Rel $
+ # Modified for release 2007.00 by rospell team
++# Modified again to be more close to current FreeBSD standards by itetcu
+ #
+ # FreeBSD makefile for rospell (http://rospell.sourceforge.net)
+-# Written by Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com>
++# Written by Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com>
++# FreeBSD committer address: <itetcu@FreeBSD.org>
++#
+ # Distributed under BSD or GNU licence (your choice).
+ #
+
+@@ -15,6 +19,7 @@
+ PREFIX?= /usr/local
+ BINDIR?= ${PREFIX}/bin
+ DATADIR?= ${PREFIX}/share/rospell
++DOCSDIR?= ${PREFIX}/share/doc/rospell
+ X11BASE?= /usr/X11R6
+ QT_PREFIX?= ${X11BASE}
+
+@@ -22,7 +27,7 @@
+ CXX?= g++
+ PTHREAD_CFLAGS?=
+ PTHREAD_LIBS?= -pthread
+-CXXFLAGS?= -O
++CXXFLAGS?= -O2
+
+ QTCPPFLAGS?= -I${LOCALBASE}/include -I${PREFIX}/include \
+ -I${QT_PREFIX}/include -D_GETOPT_H
+@@ -81,7 +86,7 @@
+ @${ECHO_CMD} "#define DF6 \"${DATADIR}/usenix.sty\"" >> dictfiles.h
+ @${ECHO_CMD} "#define DF7 \"${DATADIR}/usenix.tex\"" >> dictfiles.h
+ @${ECHO_CMD} "#define DF8 \"${DATADIR}/posixh.tags\"" >> dictfiles.h
+- @${ECHO_CMD} "#define DF9 \"${DATADIR}/authors.html\"" >> dictfiles.h
++ @${ECHO_CMD} "#define DF9 \"${DOCSDIR}/authors.html\"" >> dictfiles.h
+ @${ECHO_CMD} "#define ROSPELL_FREEBSD" >> dictfiles.h
+ @${ECHO_CMD} "---> Done dictfiles.h."
+
+@@ -330,9 +335,13 @@
+ @${BSD_INSTALL_DATA} posixh10.info ${DATADIR}
+ @${BSD_INSTALL_DATA} posixh11.info ${DATADIR}
+ @${BSD_INSTALL_DATA} posixh.tags ${DATADIR}
+- @${BSD_INSTALL_DATA} authors.html ${DATADIR}
++ @${ECHO_CMD} "----> Done."
++ @${ECHO_CMD} "----> Installing docs in ${DOCSDIR} ... "
++ @${MKDIR} ${DOCSDIR}
++ @${BSD_INSTALL_DATA} authors.html ${DOCSDIR}
+ @${ECHO_CMD} "----> Done."
+ @${ECHO_CMD} "----> Installing man page ... "
++ @${MKDIR} ${DOCSDIR}
+ @${BSD_INSTALL_MAN} src/man/rospell.lx ${MANPREFIX}/man/man1/rospell.1
+ @${ECHO_CMD} "----> Done."
+ @${ECHO_CMD} "---> Done installing."
diff --git a/editors/rospell/pkg-plist b/editors/rospell/pkg-plist
index 7de4ff2e2884..16a6b2c78def 100644
--- a/editors/rospell/pkg-plist
+++ b/editors/rospell/pkg-plist
@@ -1,5 +1,43 @@
+bin/robcpp
+bin/rokloc
bin/rospell
+
+%%DATADIR%%/ctype.info
%%DATADIR%%/dictionary.en
%%DATADIR%%/dictionary.fixed
%%DATADIR%%/dictionary.ro
+%%DATADIR%%/largefile.info
+%%DATADIR%%/latexhelp.tags
+%%DATADIR%%/latexhelp1.info
+%%DATADIR%%/latexhelp2.info
+%%DATADIR%%/latexhelp3.info
+%%DATADIR%%/libc.tags
+%%DATADIR%%/libm.info
+%%DATADIR%%/locale.info
+%%DATADIR%%/misc.info
+%%DATADIR%%/posixh.tags
+%%DATADIR%%/posixh1.info
+%%DATADIR%%/posixh2.info
+%%DATADIR%%/posixh3.info
+%%DATADIR%%/posixh4.info
+%%DATADIR%%/posixh5.info
+%%DATADIR%%/posixh6.info
+%%DATADIR%%/posixh7.info
+%%DATADIR%%/posixh8.info
+%%DATADIR%%/posixh9.info
+%%DATADIR%%/posixh10.info
+%%DATADIR%%/posixh11.info
+%%DATADIR%%/signal.info
+%%DATADIR%%/stdlib1.info
+%%DATADIR%%/stdlib2.info
+%%DATADIR%%/stdio1.info
+%%DATADIR%%/stdio2.info
+%%DATADIR%%/stdio3.info
+%%DATADIR%%/string.info
+%%DATADIR%%/time.info
+%%DATADIR%%/usenix.sty
+%%DATADIR%%/usenix.tex
+%%DATADIR%%/wchar.info
+%%DOCSDIR%%/authors.html
@dirrm %%DATADIR%%
+@dirrm %%DOCSDIR%%