aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2010-04-01 00:48:45 +0000
committerMaho Nakata <maho@FreeBSD.org>2010-04-01 00:48:45 +0000
commit947b41afd95be7e8a3f272b443a66a41797ea215 (patch)
treea902586069b6f359ba7466527ba7189fd056b648 /editors
parent796d26c5517bb4343ed2751067585edd75404633 (diff)
downloadports-947b41afd95be7e8a3f272b443a66a41797ea215.tar.gz
ports-947b41afd95be7e8a3f272b443a66a41797ea215.zip
Fix build on 9.0-Current.
PR: 142843 Submitted by: Andrey Kosachenko <Andrey.Kosachenko@gmail.com> Feature safe: yes
Notes
Notes: svn path=/head/; revision=251916
Diffstat (limited to 'editors')
-rw-r--r--editors/openoffice-3-devel/Makefile3
-rw-r--r--editors/openoffice-3/Makefile3
-rw-r--r--editors/openoffice.org-2/Makefile8
-rw-r--r--editors/openoffice.org-3-RC/Makefile3
-rw-r--r--editors/openoffice.org-3-devel/Makefile3
-rw-r--r--editors/openoffice.org-3/Makefile3
-rw-r--r--editors/openoffice.org-vcltesttool/Makefile3
7 files changed, 19 insertions, 7 deletions
diff --git a/editors/openoffice-3-devel/Makefile b/editors/openoffice-3-devel/Makefile
index 32d7babf3ff8..b459f6b411aa 100644
--- a/editors/openoffice-3-devel/Makefile
+++ b/editors/openoffice-3-devel/Makefile
@@ -124,7 +124,7 @@ CONFIGURE_ENV+= CC="${OOOCC}" CXX="${OOOCXX}" \
PATH=${WRKSRC}/solenv/bin:$$PATH
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
- unzip:${PORTSDIR}/archivers/unzip \
+ ${LOCALBASE}/bin/unzip:${PORTSDIR}/archivers/unzip \
gcp:${PORTSDIR}/sysutils/coreutils \
gpatch:${PORTSDIR}/devel/patch \
${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
@@ -208,6 +208,7 @@ post-extract:
pre-configure:
#Workaround for gperf. #i85469#
@${LN} -sf ${LOCALBASE}/bin/gperf ${WRKSRC}/solenv/bin/gperf
+ @${LN} -sf ${LOCALBASE}/bin/unzip ${WRKSRC}/solenv/bin/unzip
.if defined(WITH_KDE4)
@${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/solenv/bin/moc
.endif
diff --git a/editors/openoffice-3/Makefile b/editors/openoffice-3/Makefile
index d8b06b28948b..e98ab6b37a6e 100644
--- a/editors/openoffice-3/Makefile
+++ b/editors/openoffice-3/Makefile
@@ -116,7 +116,7 @@ CONFIGURE_ENV+= CC="${OOOCC}" CXX="${OOOCXX}" \
PATH=${WRKSRC}/solenv/bin:$$PATH
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
- unzip:${PORTSDIR}/archivers/unzip \
+ ${LOCALBASE}/bin/unzip:${PORTSDIR}/archivers/unzip \
gcp:${PORTSDIR}/sysutils/coreutils \
gpatch:${PORTSDIR}/devel/patch \
${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
@@ -198,6 +198,7 @@ post-extract:
pre-configure:
#Workaround for gperf. #i85469#
@${LN} -sf ${LOCALBASE}/bin/gperf ${WRKSRC}/solenv/bin/gperf
+ @${LN} -sf ${LOCALBASE}/bin/unzip ${WRKSRC}/solenv/bin/unzip
.if defined(WITH_KDE4)
@${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/solenv/bin/moc
.endif
diff --git a/editors/openoffice.org-2/Makefile b/editors/openoffice.org-2/Makefile
index 4170cdc6ffa5..412f3748cb4a 100644
--- a/editors/openoffice.org-2/Makefile
+++ b/editors/openoffice.org-2/Makefile
@@ -107,12 +107,13 @@ CONFIGURE_ENV+= CC="${OOOCC}" CXX="${OOOCXX}" \
LDFLAGS="-L${LOCALBASE}/lib"
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
- unzip:${PORTSDIR}/archivers/unzip \
+ ${LOCALBASE}/bin/unzip:${PORTSDIR}/archivers/unzip \
gcp:${PORTSDIR}/sysutils/coreutils \
gpatch:${PORTSDIR}/devel/patch \
${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
bash:${PORTSDIR}/shells/bash \
imake:${PORTSDIR}/devel/imake \
+ ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf \
ant:${PORTSDIR}/devel/apache-ant
.if !defined(WITH_GPC)
@@ -177,6 +178,11 @@ post-extract:
@${CP} ${DISTDIR}/${DIST_SUBDIR}/${MOZILLA_SOURCE} ${WRKSRC}/moz/download
.endif
+pre-configure:
+#Workaround for gperf. #i85469#
+ @${LN} -sf ${LOCALBASE}/bin/gperf ${WRKSRC}/solenv/bin/gperf
+ @${LN} -sf ${LOCALBASE}/bin/unzip ${WRKSRC}/solenv/bin/unzip
+
do-build:
@cd ${WRKSRC} ; ./bootstrap
# PR:84786 #i53289#
diff --git a/editors/openoffice.org-3-RC/Makefile b/editors/openoffice.org-3-RC/Makefile
index e08d45f43fff..ee07bc61e0de 100644
--- a/editors/openoffice.org-3-RC/Makefile
+++ b/editors/openoffice.org-3-RC/Makefile
@@ -116,7 +116,7 @@ CONFIGURE_ENV+= CC="${OOOCC}" CXX="${OOOCXX}" \
PATH=${WRKSRC}/solenv/bin:$$PATH
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
- unzip:${PORTSDIR}/archivers/unzip \
+ ${LOCALBASE}/bin/unzip:${PORTSDIR}/archivers/unzip \
gcp:${PORTSDIR}/sysutils/coreutils \
gpatch:${PORTSDIR}/devel/patch \
${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
@@ -198,6 +198,7 @@ post-extract:
pre-configure:
#Workaround for gperf. #i85469#
@${LN} -sf ${LOCALBASE}/bin/gperf ${WRKSRC}/solenv/bin/gperf
+ @${LN} -sf ${LOCALBASE}/bin/unzip ${WRKSRC}/solenv/bin/unzip
.if defined(WITH_KDE4)
@${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/solenv/bin/moc
.endif
diff --git a/editors/openoffice.org-3-devel/Makefile b/editors/openoffice.org-3-devel/Makefile
index 32d7babf3ff8..b459f6b411aa 100644
--- a/editors/openoffice.org-3-devel/Makefile
+++ b/editors/openoffice.org-3-devel/Makefile
@@ -124,7 +124,7 @@ CONFIGURE_ENV+= CC="${OOOCC}" CXX="${OOOCXX}" \
PATH=${WRKSRC}/solenv/bin:$$PATH
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
- unzip:${PORTSDIR}/archivers/unzip \
+ ${LOCALBASE}/bin/unzip:${PORTSDIR}/archivers/unzip \
gcp:${PORTSDIR}/sysutils/coreutils \
gpatch:${PORTSDIR}/devel/patch \
${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
@@ -208,6 +208,7 @@ post-extract:
pre-configure:
#Workaround for gperf. #i85469#
@${LN} -sf ${LOCALBASE}/bin/gperf ${WRKSRC}/solenv/bin/gperf
+ @${LN} -sf ${LOCALBASE}/bin/unzip ${WRKSRC}/solenv/bin/unzip
.if defined(WITH_KDE4)
@${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/solenv/bin/moc
.endif
diff --git a/editors/openoffice.org-3/Makefile b/editors/openoffice.org-3/Makefile
index d8b06b28948b..e98ab6b37a6e 100644
--- a/editors/openoffice.org-3/Makefile
+++ b/editors/openoffice.org-3/Makefile
@@ -116,7 +116,7 @@ CONFIGURE_ENV+= CC="${OOOCC}" CXX="${OOOCXX}" \
PATH=${WRKSRC}/solenv/bin:$$PATH
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
- unzip:${PORTSDIR}/archivers/unzip \
+ ${LOCALBASE}/bin/unzip:${PORTSDIR}/archivers/unzip \
gcp:${PORTSDIR}/sysutils/coreutils \
gpatch:${PORTSDIR}/devel/patch \
${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
@@ -198,6 +198,7 @@ post-extract:
pre-configure:
#Workaround for gperf. #i85469#
@${LN} -sf ${LOCALBASE}/bin/gperf ${WRKSRC}/solenv/bin/gperf
+ @${LN} -sf ${LOCALBASE}/bin/unzip ${WRKSRC}/solenv/bin/unzip
.if defined(WITH_KDE4)
@${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/solenv/bin/moc
.endif
diff --git a/editors/openoffice.org-vcltesttool/Makefile b/editors/openoffice.org-vcltesttool/Makefile
index fa58db267105..ec19e9641cb3 100644
--- a/editors/openoffice.org-vcltesttool/Makefile
+++ b/editors/openoffice.org-vcltesttool/Makefile
@@ -79,7 +79,7 @@ CONFIGURE_ENV+= CC="${OOOCC}" CXX="${OOOCXX}" \
PATH=${WRKSRC}/solenv/bin:$$PATH
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
- unzip:${PORTSDIR}/archivers/unzip \
+ ${LOCALBASE}/bin/unzip:${PORTSDIR}/archivers/unzip \
gcp:${PORTSDIR}/sysutils/coreutils \
gpatch:${PORTSDIR}/devel/patch \
${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
@@ -124,6 +124,7 @@ post-extract:
pre-configure:
#Workaround for gperf. #i85469#
@${LN} -sf ${LOCALBASE}/bin/gperf ${WRKSRC}/solenv/bin/gperf
+ @${LN} -sf ${LOCALBASE}/bin/unzip ${WRKSRC}/solenv/bin/unzip
do-build:
@cd ${WRKSRC} ; ./bootstrap