aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2012-05-04 20:02:25 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2012-05-04 20:02:25 +0000
commite68eaea5f12217864cd469ac1cffc1f8cd9bd3fc (patch)
tree1c518e47cb6bca96acf5d9c3d66616bb47f50c24 /editors
parenta4c811e8863280f72eea4a3c4f932e793ccc5ba8 (diff)
downloadports-e68eaea5f12217864cd469ac1cffc1f8cd9bd3fc.tar.gz
ports-e68eaea5f12217864cd469ac1cffc1f8cd9bd3fc.zip
- Work around build issues with Clang by lowering C++ standard level. Note
this is temporary because both Clang and LibreOffice fixed all the issues. - Shut up annoying "argument unused during compilation" warnings for Clang. With hat: office@
Notes
Notes: svn path=/head/; revision=296020
Diffstat (limited to 'editors')
-rw-r--r--editors/libreoffice/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index e2b5e40d7086..b561a6782735 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -229,6 +229,8 @@ USE_BINUTILS= yes
CXXCPP= clang++ -E
CPP= clang -E
.endif
+# XXX Work around C++11 problems with Clang.
+CXXFLAGS= -std=gnu++98 -Qunused-arguments
BUILD_DEPENDS+= ${LOCALBASE}/lib/libcppunit.so:${PORTSDIR}/devel/cppunit
.endif