aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-02-28 17:12:07 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-02-28 17:12:07 +0000
commite71c4eb4b4c483c764aa24f45eec20de248d6d8a (patch)
tree89cb31600d920042f2c715b0d6ca97a53d39dd84 /editors
parent3e3e934c157f569dcf3a8e693ba57a2a05ddbc83 (diff)
downloadports-e71c4eb4b4c483c764aa24f45eec20de248d6d8a.tar.gz
ports-e71c4eb4b4c483c764aa24f45eec20de248d6d8a.zip
- Add missing Qt4 components to fix build [1]
- Respect CC, etc by passing QMAKEFLAGS to qmake - Tweak desktop entry Approved by: gahr (maintainer) Reported by: miwi [1]
Notes
Notes: svn path=/head/; revision=313116
Diffstat (limited to 'editors')
-rw-r--r--editors/texworks/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/editors/texworks/Makefile b/editors/texworks/Makefile
index d22b4a3f0c99..f0d0b476cee3 100644
--- a/editors/texworks/Makefile
+++ b/editors/texworks/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= poppler-qt4:${PORTSDIR}/graphics/poppler-qt4
USE_PKGCONFIG= build
USE_QT4= qmake_build gui corelib rcc_build moc_build uic_build \
- dbus xml
+ dbus xml scripttools designer_build
QMAKE_ARGS= INSTALL_PREFIX=${PREFIX} \
DATA_DIR=${DATADIR} \
DOCS_DIR=${DOCSDIR} \
@@ -36,8 +36,8 @@ DESKTOP_ENTRIES="TexWorks" \
"Lowering the entry barrier to the TeX world" \
"TeXworks" \
"${PORTNAME}" \
- "Utility;" \
- false
+ "Utility;Qt;" \
+ true
MAN1= texworks.1
PLIST_FILES= bin/texworks \
@@ -59,6 +59,6 @@ post-patch:
do-configure:
@cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${QMAKE} ${QMAKE_ARGS} TeXworks.pro
+ ${QMAKE} ${QMAKEFLAGS} ${QMAKE_ARGS} TeXworks.pro
.include <bsd.port.mk>