aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-05-20 19:32:39 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-05-20 19:32:39 +0000
commitf191d6b8872215d88c30b5942a9319854b9e98ba (patch)
tree2ae9e1593b29ed28637a9cbae361c9e3af678802 /editors
parent47e51189262149884b0a6e3a5653e397d7635d35 (diff)
downloadports-f191d6b8872215d88c30b5942a9319854b9e98ba.tar.gz
ports-f191d6b8872215d88c30b5942a9319854b9e98ba.zip
Quote ${CC} and similar variables in MAKE_ARGS.
Reported by: Dominic Fandrey <kamikaze@bsdforen.de>
Notes
Notes: svn path=/head/; revision=354670
Diffstat (limited to 'editors')
-rw-r--r--editors/mined/Makefile2
-rw-r--r--editors/vim/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/editors/mined/Makefile b/editors/mined/Makefile
index ce0b47a59f53..80dbd0f13278 100644
--- a/editors/mined/Makefile
+++ b/editors/mined/Makefile
@@ -18,7 +18,7 @@ PORTDOCS= *
USES= gmake
MAKEFILE= makefile
REINPLACE_ARGS= -i ""
-MAKE_ARGS= GMAKE=${MAKE_CMD} CC=${CC:T} OPT="${CFLAGS}"
+MAKE_ARGS= GMAKE="${MAKE_CMD}" CC="${CC}" OPT="${CFLAGS}"
INSTALL_TARGET= localinstall
MAKE_JOBS_UNSAFE= yes
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 2742584cd97a..c98cae50216a 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -32,7 +32,7 @@ UI_DESC= User interface
XTERM_SAVE_DESC= Restore xterm screen after exit
ALL_TARGET= # empty
-MAKE_ARGS+= CC=${CC} CONF_ARGS="--prefix=${PREFIX} ${CSCOPE_ARG}" STRIP=${STRIP_CMD} CONF_OPT_MULTIBYTE=--enable-multibyte CONF_TERM_LIB=--with-tlib=termlib
+MAKE_ARGS+= CC="${CC}" CONF_ARGS="--prefix=${PREFIX} ${CSCOPE_ARG}" STRIP="${STRIP_CMD}" CONF_OPT_MULTIBYTE=--enable-multibyte CONF_TERM_LIB=--with-tlib=termlib
PATCH= ${LOCALBASE}/bin/gpatch
PATCH_DIST_ARGS=--batch --directory ${WRKSRC} --forward --quiet --remove-empty-files ${PATCH_DIST_STRIP}
REINPLACE_ARGS= -i ''