aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorPiotr Pawel Stefaniak <pstef@FreeBSD.org>2021-04-07 16:47:04 +0000
committerPiotr Pawel Stefaniak <pstef@FreeBSD.org>2021-04-07 16:49:18 +0000
commitfba3dac6cdd8f201a3b0e6d1f33d7727ca31c7cd (patch)
treeef9e97843a33511bb02f1302229f66463a354baf /editors
parentc5b605ecf1093dce00afa38ea9d6d314a7667711 (diff)
downloadports-fba3dac6cdd8f201a3b0e6d1f33d7727ca31c7cd.tar.gz
ports-fba3dac6cdd8f201a3b0e6d1f33d7727ca31c7cd.zip
editors/libreoffice: add an option to build with or without MariaDB driver
PR: 254273 Approved by: lwhsu
Diffstat (limited to 'editors')
-rw-r--r--editors/libreoffice/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index c7eb4fadfeb7..0ef3f674cd74 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -108,15 +108,15 @@ SHEBANG_GLOB= *.py
GNU_CONFIGURE= yes
USES= autoreconf:build bison compiler:c++17-lang cpe desktop-file-utils \
- gettext-runtime gl gmake gnome jpeg mysql:client perl5 pkgconfig \
- pkgconfig python:3.6+ shebangfix shared-mime-info ssl tar:xz xorg
+ gettext-runtime gl gmake gnome jpeg perl5 pkgconfig python:3.6+ \
+ shebangfix shared-mime-info ssl tar:xz xorg
USE_GL= gl glew glu
USE_GNOME= cairo glib20 libxml2 libxslt
USE_OPENLDAP= yes
USE_PERL5= build
USE_XORG= ice sm x11 xaw xcb xext xinerama xrandr xrender
-OPTIONS_DEFINE= COINMP CUPS DOCS GNOME GTK3 JAVA KF5 LTO MMEDIA PGSQL QT5 SDK TEST WEBDAV
+OPTIONS_DEFINE= COINMP CUPS DOCS GNOME GTK3 JAVA KF5 LTO MMEDIA PGSQL MARIADB QT5 SDK TEST WEBDAV
OPTIONS_DEFAULT= CUPS MMEDIA QT5
.if !defined(DEFAULT_VERSIONS) || ! ${DEFAULT_VERSIONS:Mssl=*}
@@ -130,6 +130,7 @@ JAVA_DESC= Add Java support (XML filters, macros, DB connections)
KF5_DESC= KF5/Qt5 GUI toolkit support (implies QT5)
MMEDIA_DESC= Enable multimedia backend for Impress
PGSQL_DESC= Build with PostgreSQL-SDBC driver
+MARIADB_DESC= Build with MariaDB-SDBC driver
QT5_DESC= Qt5 GUI toolkit support (default visual style)
SDK_DESC= Build with SDK
TEST_DESC= Run all regression tests
@@ -208,6 +209,9 @@ PGSQL_CONFIGURE_ENABLE= postgresql-sdbc
PGSQL_CONFIGURE_WITH= gssapi krb5
PGSQL_USES= pgsql
+MARIADB_CONFIGURE_ENABLE= mariadb-sdbc
+MARIADB_USES= mysql:client
+
QT5_CONFIGURE_ENABLE= qt5
QT5_USE= qt=buildtools_build,core,gui,network,qmake_build,widgets,x11extras
QT5_USES= qt:5