aboutsummaryrefslogtreecommitdiff
path: root/emulators/atari800/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-10-07 14:54:11 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-10-07 14:54:11 +0000
commit4da7def3bf29f019e35a18472a365712b64afdb3 (patch)
tree1b9844554e343ea6f1dae2afc399d3e98382ed3e /emulators/atari800/Makefile
parent2530ea84c58780defb9eadbf3b8aec3bc3cf98de (diff)
downloadports-4da7def3bf29f019e35a18472a365712b64afdb3.tar.gz
ports-4da7def3bf29f019e35a18472a365712b64afdb3.zip
- Update to version 1.3.1
PR: 57702 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=90521
Diffstat (limited to 'emulators/atari800/Makefile')
-rw-r--r--emulators/atari800/Makefile73
1 files changed, 68 insertions, 5 deletions
diff --git a/emulators/atari800/Makefile b/emulators/atari800/Makefile
index 4437d496042f..858788e874fe 100644
--- a/emulators/atari800/Makefile
+++ b/emulators/atari800/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= atari800
-PORTVERSION= 1.3.0
+PORTVERSION= 1.3.1
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -23,19 +23,77 @@ RESTRICTED= "xf25 contains copyright ROMs and cannot be distributed."
WRKSRC= ${WRKDIR}/${DISTNAME}/src
-USE_XLIB= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --target=x11
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= atari800.1
ATARI_XF= ataribas.rom atariosb.rom atarixl.rom demos1.xfd \
demos2.xfd dos25.xfd mydos45d.atr
-post-extract:
- @unzip -q -L -o ${DISTDIR}/${DIST_SUBDIR}/xf25.zip ${ATARI_XF} -d ${WRKSRC}
+.if defined(WITH_SDL)
+PKGNAMESUFFIX= -sdl
+USE_SDL= yes
+CONFIGURE_ARGS+= --target=sdl
+.else
+USE_XLIB= yes
+.if defined(WITHOUT_SHM)
+CONFIGURE_ARGS+= --target=x11
+.else
+CONFIGURE_ARGS+= --target=shm
+.endif
+.endif
+
+.if defined(WITH_SERIOSOUND)
+CONFIGURE_ARGS+= --enable-seriosound
+.endif
+
+.if defined(WITH_CLIPSOUND)
+CONFIGURE_ARGS+= --enable-cripsound
+.endif
+
+.if defined(WITH_SNAILMETER)
+CONFIGURE_ARGS+= --enable-snailmeter
+.endif
+
+.if defined(WITH_PAGEDATTRIB)
+CONFIGURE_ARGS+= --enable-pagedattrib
+.endif
+
+.if defined(WITH_BUFFERDLOG)
+CONFIGURE_ARGS+= --enable-bufferdlog
+.endif
+
+.if defined(WITH_DISKLED)
+CONFIGURE_ARGS+= --enable-diskled
+.endif
+
+.if defined(WITH_VERYSLOW)
+CONFIGURE_ARGS+= --enable-veryslow
+.endif
+
+.if defined(WITH_CURSORBLOCK)
+CONFIGURE_ARGS+= --enable-cursorblock
+.endif
+
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Atari800 has the following tunable option(s):"
+ @${ECHO_MSG} " WITHOUT_SHM=yes Use X11 frontend without shared memory extensions"
+ @${ECHO_MSG} " WITH_SDL=yes Use SDL frontend"
+ @${ECHO_MSG} " WITH_SERIOSOUND=yes Use serial in/out sound"
+ @${ECHO_MSG} " WITH_CLIPSOUND=yes Use bufferd debug output"
+ @${ECHO_MSG} " WITH_SNAILMETER=yes Show how much the emulator is slower than the original"
+ @${ECHO_MSG} " WITH_PAGEDATTRIB=yes Use page-based attribute array"
+ @${ECHO_MSG} " WITH_BUFFERDLOG=yes Use buffered debug output"
+ @${ECHO_MSG} " (until the graphics mode switches back to text mode)"
+ @${ECHO_MSG} " WITH_DISKLED=yes Show disk LED emulation on screen display"
+ @${ECHO_MSG} " WITH_VERYSLOW=yes Use very slow computer support"
+ @${ECHO_MSG} " (disables generating screen completely)"
+ @${ECHO_MSG} " WITH_CURSORBLOCK=yes Using cursor/ctrl keys for keyboard joystick"
+ @${ECHO_MSG} ""
post-patch:
@${CP} ${FILESDIR}/atari800.cfg ${WRKSRC}
@@ -43,6 +101,11 @@ post-patch:
@${REINPLACE_CMD} -e 's|/etc|${DATADIR}|g' ${WRKSRC}/rt-config.c
@${REINPLACE_CMD} -e 's|tmpnam|mkstemp|g' ${WRKSRC}/devices.c \
${WRKSRC}/compfile.c
+ @${REINPLACE_CMD} -e 's|sdl-config|$$SDL_CONFIG|g' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+
+pre-configure:
+ @unzip -q -L -o ${DISTDIR}/${DIST_SUBDIR}/xf25.zip ${ATARI_XF} -d ${WRKSRC}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/atari800 ${PREFIX}/bin/atari800