aboutsummaryrefslogtreecommitdiff
path: root/emulators/cannonball
diff options
context:
space:
mode:
authorSanthosh Raju <fox@FreeBSD.org>2019-09-03 02:49:46 +0000
committerSanthosh Raju <fox@FreeBSD.org>2019-09-03 02:49:46 +0000
commit343944887377d5542289fe31f344823bc9b01b0b (patch)
tree8f1930ba8c51ad52fb486359becab99114e113d1 /emulators/cannonball
parent11b7c1628cd8b6142f7abe8d1db3f482bddb5792 (diff)
downloadports-343944887377d5542289fe31f344823bc9b01b0b.tar.gz
ports-343944887377d5542289fe31f344823bc9b01b0b.zip
emulators/cannonball: Update to g20190819
- Updates MAINTAINER email Changes since cannonball-g20171201: 1. Removes files/patch-cmake_bsd.cmake and files/patch-cmake_CMakeLists.txt since these are now merged with upstream. 2. Removes files/cannonball.6.in since the man page is now available upstream. PR: 239960 Approved by: philip (mentor)
Notes
Notes: svn path=/head/; revision=510915
Diffstat (limited to 'emulators/cannonball')
-rw-r--r--emulators/cannonball/Makefile11
-rw-r--r--emulators/cannonball/distinfo6
-rw-r--r--emulators/cannonball/files/patch-cmake_CMakeLists.txt16
-rw-r--r--emulators/cannonball/files/patch-cmake_bsd.cmake25
-rw-r--r--emulators/cannonball/pkg-plist1
5 files changed, 10 insertions, 49 deletions
diff --git a/emulators/cannonball/Makefile b/emulators/cannonball/Makefile
index 6ab4cb69290b..ae782952b8d2 100644
--- a/emulators/cannonball/Makefile
+++ b/emulators/cannonball/Makefile
@@ -1,11 +1,10 @@
# $FreeBSD$
PORTNAME= cannonball
-DISTVERSION= g20171201
-PORTREVISION= 1
+DISTVERSION= g20190819
CATEGORIES= emulators games
-MAINTAINER= santhosh.raju@gmail.com
+MAINTAINER= fox@FreeBSD.org
COMMENT= Enhanced OutRun Engine
LICENSE= MAME-LICENSE
@@ -18,12 +17,13 @@ LIB_DEPENDS= libboost_program_options.so:devel/boost-libs
USES= cmake:insource pkgconfig sdl
USE_SDL= sdl
-CMAKE_ARGS= ${WRKSRC}/cmake \
+CMAKE_ARGS+= ${WRKSRC}/cmake \
+ -DBSD_PREFIX_PATH=${LOCALBASE} \
-DTARGET=bsd
USE_GITHUB= yes
GH_ACCOUNT= djyt
-GH_TAGNAME= 0c0814d
+GH_TAGNAME= 48d2c62
BUILD_WRKSRC= ${WRKSRC}/cmake
CONFIGURE_WRKSRC= ${WRKSRC}/cmake
@@ -36,6 +36,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/cmake/res/tilemap.bin ${STAGEDIR}${DATADIR}/res/tilemap.bin
${INSTALL_DATA} ${WRKSRC}/cmake/res/tilepatch.bin ${STAGEDIR}${DATADIR}/res/tilepatch.bin
${INSTALL_DATA} ${WRKSRC}/cmake/config.xml ${STAGEDIR}${DATADIR}/conf/config.xml
+ ${INSTALL_MAN} ${WRKSRC}/docs/cannonball.6 ${STAGEDIR}${MAN1PREFIX}/man/man6
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
${INSTALL_PROGRAM} ${WRKSRC}/cmake/cannonball ${STAGEDIR}${PREFIX}/libexec
diff --git a/emulators/cannonball/distinfo b/emulators/cannonball/distinfo
index 63dbddc9d48a..20df9154aa2d 100644
--- a/emulators/cannonball/distinfo
+++ b/emulators/cannonball/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1560212844
-SHA256 (djyt-cannonball-g20171201-0c0814d_GH0.tar.gz) = 9f79a26df838ad64b96137ddf5e843f3e76e639c2112f5bfaae39296698019d5
-SIZE (djyt-cannonball-g20171201-0c0814d_GH0.tar.gz) = 277297
+TIMESTAMP = 1566223011
+SHA256 (djyt-cannonball-g20190819-48d2c62_GH0.tar.gz) = 08c37ee43d2417446af9095ae845db3ff1f747b62fb328120d27e6ff21575b2a
+SIZE (djyt-cannonball-g20190819-48d2c62_GH0.tar.gz) = 278238
diff --git a/emulators/cannonball/files/patch-cmake_CMakeLists.txt b/emulators/cannonball/files/patch-cmake_CMakeLists.txt
deleted file mode 100644
index e7ff77c3d5b0..000000000000
--- a/emulators/cannonball/files/patch-cmake_CMakeLists.txt
+++ /dev/null
@@ -1,16 +0,0 @@
-Remove the boost directory reference.
-
-Not required in ports, since boost libraries are directly installed
-in ${LOCALBASE}/include
-
---- cmake/CMakeLists.txt.orig 2019-06-10 03:25:18 UTC
-+++ cmake/CMakeLists.txt
-@@ -25,7 +25,7 @@ else()
- include(${DCMAKE})
- endif(TARGET)
-
--set(BOOST_INCLUDEDIR ${lib_base}/boost_1_54_0)
-+set(BOOST_INCLUDEDIR ${lib_base})
- find_package(Boost REQUIRED)
-
- # Include
diff --git a/emulators/cannonball/files/patch-cmake_bsd.cmake b/emulators/cannonball/files/patch-cmake_bsd.cmake
deleted file mode 100644
index fe000b61fba6..000000000000
--- a/emulators/cannonball/files/patch-cmake_bsd.cmake
+++ /dev/null
@@ -1,25 +0,0 @@
-Create a cmake file for FreeBSD build.
-
---- cmake/bsd.cmake.orig 2019-06-10 03:23:23 UTC
-+++ cmake/bsd.cmake
-@@ -0,0 +1,20 @@
-+# Default CMake Setup. Used for FreeBSD Builds.
-+
-+set(lib_base /usr/local/include)
-+set(sdl_root ${lib_base}/SDL)
-+
-+include_directories("${sdl_root}")
-+
-+link_libraries(cannonball
-+ SDL
-+)
-+
-+# Linking
-+link_directories(
-+ "/usr/local/lib"
-+)
-+
-+# Location for Cannonball to create save files
-+# Used to auto-generate setup.hpp with various file paths
-+set(xml_directory ./)
-+set(sdl_flags "SDL_DOUBLEBUF | SDL_SWSURFACE")
diff --git a/emulators/cannonball/pkg-plist b/emulators/cannonball/pkg-plist
index b8fcb4bdc425..a7a5194dc70a 100644
--- a/emulators/cannonball/pkg-plist
+++ b/emulators/cannonball/pkg-plist
@@ -1,5 +1,6 @@
bin/cannonball
libexec/cannonball
+man/man6/cannonball.6.gz
%%DATADIR%%/conf/config.xml
%%DATADIR%%/res/tilemap.bin
%%DATADIR%%/res/tilepatch.bin