aboutsummaryrefslogtreecommitdiff
path: root/emulators/cannonball
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-07-06 18:55:17 +0000
committerSteve Wills <swills@FreeBSD.org>2019-07-06 18:55:17 +0000
commit9aba7ed3209a73ffe7c87606c9c54f397d393af9 (patch)
treed8d0d2e10598e1e30dea0486af562167c344c264 /emulators/cannonball
parent6bc519d256e48b6e4815539dc8df2bd87cf63ec8 (diff)
downloadports-9aba7ed3209a73ffe7c87606c9c54f397d393af9.tar.gz
ports-9aba7ed3209a73ffe7c87606c9c54f397d393af9.zip
emulators/cannonball: create port
Cannonball is a program which allows you to play an enhanced version of Yu Suzuki's seminal arcade racer, OutRun, on a variety of systems. WWW: https://github.com/djyt/cannonball/wiki PR: 238495 Submitted by: Santhosh Raju <santhosh.raju@gmail.com>
Notes
Notes: svn path=/head/; revision=506026
Diffstat (limited to 'emulators/cannonball')
-rw-r--r--emulators/cannonball/Makefile41
-rw-r--r--emulators/cannonball/distinfo3
-rw-r--r--emulators/cannonball/files/cannonball.sh.in27
-rw-r--r--emulators/cannonball/files/patch-cmake_CMakeLists.txt16
-rw-r--r--emulators/cannonball/files/patch-cmake_bsd.cmake25
-rw-r--r--emulators/cannonball/pkg-descr4
-rw-r--r--emulators/cannonball/pkg-message16
-rw-r--r--emulators/cannonball/pkg-plist5
8 files changed, 137 insertions, 0 deletions
diff --git a/emulators/cannonball/Makefile b/emulators/cannonball/Makefile
new file mode 100644
index 000000000000..41579188c51e
--- /dev/null
+++ b/emulators/cannonball/Makefile
@@ -0,0 +1,41 @@
+# $FreeBSD$
+
+PORTNAME= cannonball
+DISTVERSION= g20171201
+CATEGORIES= emulators games
+
+MAINTAINER= santhosh.raju@gmail.com
+COMMENT= Enhanced OutRun Engine
+
+LICENSE= MAME-LICENSE
+LICENSE_NAME= MAME license
+LICENSE_FILE= ${WRKSRC}/docs/license.txt
+LICENSE_PERMS= dist-mirror no-dist-sell pkg-mirror no-pkg-sell auto-accept
+
+LIB_DEPENDS= libboost_program_options.so:devel/boost-libs
+
+USES= cmake:insource pkgconfig sdl
+USE_SDL= sdl
+
+CMAKE_ARGS= ${WRKSRC}/cmake \
+ -DTARGET=bsd
+
+USE_GITHUB= yes
+GH_ACCOUNT= djyt
+GH_TAGNAME= 0c0814d
+
+BUILD_WRKSRC= ${WRKSRC}/cmake
+CONFIGURE_WRKSRC= ${WRKSRC}/cmake
+
+SUB_FILES= ${PORTNAME}.sh
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}/res
+ ${MKDIR} ${STAGEDIR}${DATADIR}/conf
+ ${INSTALL_DATA} ${WRKSRC}/cmake/res/tilemap.bin ${STAGEDIR}${DATADIR}/res/tilemap.bin
+ ${INSTALL_DATA} ${WRKSRC}/cmake/res/tilepatch.bin ${STAGEDIR}${DATADIR}/res/tilepatch.bin
+ ${INSTALL_DATA} ${WRKSRC}/cmake/config.xml ${STAGEDIR}${DATADIR}/conf/config.xml
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/cmake/cannonball ${STAGEDIR}${PREFIX}/libexec
+
+.include <bsd.port.mk>
diff --git a/emulators/cannonball/distinfo b/emulators/cannonball/distinfo
new file mode 100644
index 000000000000..63dbddc9d48a
--- /dev/null
+++ b/emulators/cannonball/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1560212844
+SHA256 (djyt-cannonball-g20171201-0c0814d_GH0.tar.gz) = 9f79a26df838ad64b96137ddf5e843f3e76e639c2112f5bfaae39296698019d5
+SIZE (djyt-cannonball-g20171201-0c0814d_GH0.tar.gz) = 277297
diff --git a/emulators/cannonball/files/cannonball.sh.in b/emulators/cannonball/files/cannonball.sh.in
new file mode 100644
index 000000000000..7cba41b2ab6c
--- /dev/null
+++ b/emulators/cannonball/files/cannonball.sh.in
@@ -0,0 +1,27 @@
+#!/bin/sh
+
+if [ -n "${XDG_DATA_HOME}" ]; then
+ CANNONBALL_DIR=${XDG_DATA_HOME}/cannonball
+else
+ CANNONBALL_DIR=${HOME}/.local/share/cannonball
+fi
+
+RESOURCE_DIR=${CANNONBALL_DIR}/res
+ROMS_DIR=${CANNONBALL_DIR}/roms
+
+mkdir -p "${CANNONBALL_DIR}" "${ROMS_DIR}"
+
+if [ ! -f "${CANNONBALL_DIR}/config.xml" ]; then
+ cp %%PREFIX%%/share/cannonball/conf/config.xml \
+ "${CANNONBALL_DIR}"
+fi
+
+if [ ! -d "${RESOURCE_DIR}" ]; then
+ mkdir -p "${RESOURCE_DIR}"
+ cp %%PREFIX%%/share/cannonball/res/tilemap.bin \
+ "${RESOURCE_DIR}"
+ cp %%PREFIX%%/share/cannonball/res/tilepatch.bin \
+ "${RESOURCE_DIR}"
+fi
+
+cd "${CANNONBALL_DIR}" && exec "%%PREFIX%%/libexec/cannonball" "$@"
diff --git a/emulators/cannonball/files/patch-cmake_CMakeLists.txt b/emulators/cannonball/files/patch-cmake_CMakeLists.txt
new file mode 100644
index 000000000000..e7ff77c3d5b0
--- /dev/null
+++ b/emulators/cannonball/files/patch-cmake_CMakeLists.txt
@@ -0,0 +1,16 @@
+Remove the boost directory reference.
+
+Not required in ports, since boost libraries are directly installed
+in ${LOCALBASE}/include
+
+--- cmake/CMakeLists.txt.orig 2019-06-10 03:25:18 UTC
++++ cmake/CMakeLists.txt
+@@ -25,7 +25,7 @@ else()
+ include(${DCMAKE})
+ endif(TARGET)
+
+-set(BOOST_INCLUDEDIR ${lib_base}/boost_1_54_0)
++set(BOOST_INCLUDEDIR ${lib_base})
+ find_package(Boost REQUIRED)
+
+ # Include
diff --git a/emulators/cannonball/files/patch-cmake_bsd.cmake b/emulators/cannonball/files/patch-cmake_bsd.cmake
new file mode 100644
index 000000000000..fe000b61fba6
--- /dev/null
+++ b/emulators/cannonball/files/patch-cmake_bsd.cmake
@@ -0,0 +1,25 @@
+Create a cmake file for FreeBSD build.
+
+--- cmake/bsd.cmake.orig 2019-06-10 03:23:23 UTC
++++ cmake/bsd.cmake
+@@ -0,0 +1,20 @@
++# Default CMake Setup. Used for FreeBSD Builds.
++
++set(lib_base /usr/local/include)
++set(sdl_root ${lib_base}/SDL)
++
++include_directories("${sdl_root}")
++
++link_libraries(cannonball
++ SDL
++)
++
++# Linking
++link_directories(
++ "/usr/local/lib"
++)
++
++# Location for Cannonball to create save files
++# Used to auto-generate setup.hpp with various file paths
++set(xml_directory ./)
++set(sdl_flags "SDL_DOUBLEBUF | SDL_SWSURFACE")
diff --git a/emulators/cannonball/pkg-descr b/emulators/cannonball/pkg-descr
new file mode 100644
index 000000000000..d98ba1173083
--- /dev/null
+++ b/emulators/cannonball/pkg-descr
@@ -0,0 +1,4 @@
+Cannonball is a program which allows you to play an enhanced version
+of Yu Suzuki's seminal arcade racer, OutRun, on a variety of systems.
+
+WWW: https://github.com/djyt/cannonball/wiki
diff --git a/emulators/cannonball/pkg-message b/emulators/cannonball/pkg-message
new file mode 100644
index 000000000000..863357f96cf1
--- /dev/null
+++ b/emulators/cannonball/pkg-message
@@ -0,0 +1,16 @@
+===========================================================================
+$FreeBSD$
+
+In order for Cannonball to work you need to provide a copy of the
+OutRun revision B romset to the roms subdirectory. Rename the files if
+necessary.
+
+The roms subdirectory can be found at $XDG_DATA_HOME/cannonball/roms
+which defaults to $HOME/.local/share/cannonball/roms
+
+Configuration can be found at $XDG_DATA_HOME/cannonball/config.xml
+which defaults to $HOME/.local/share/cannonball/config.xml
+
+NOTE: The directories will be created on the first run of Cannonball
+if they do not exist.
+===========================================================================
diff --git a/emulators/cannonball/pkg-plist b/emulators/cannonball/pkg-plist
new file mode 100644
index 000000000000..b8fcb4bdc425
--- /dev/null
+++ b/emulators/cannonball/pkg-plist
@@ -0,0 +1,5 @@
+bin/cannonball
+libexec/cannonball
+%%DATADIR%%/conf/config.xml
+%%DATADIR%%/res/tilemap.bin
+%%DATADIR%%/res/tilepatch.bin