aboutsummaryrefslogtreecommitdiff
path: root/emulators/cannonball
diff options
context:
space:
mode:
authorSanthosh Raju <fox@FreeBSD.org>2021-04-27 14:44:39 +0000
committerSanthosh Raju <fox@FreeBSD.org>2021-04-27 14:44:39 +0000
commitc391ce3a1c6ab181804f5dac3c67595fab0d093e (patch)
tree3e95c1eed3dea5d8957f870f376b145f379f80bf /emulators/cannonball
parent8ea13f9d5915cc145c2ac0ba43dcc987eb10c7ad (diff)
downloadports-c391ce3a1c6ab181804f5dac3c67595fab0d093e.tar.gz
ports-c391ce3a1c6ab181804f5dac3c67595fab0d093e.zip
emulators/cannonball: Updates to 0.34
Changes since 0.32: v0.34 Car Handling Options, Colours & More! * Car Setup Options (selectable in Settings -> Engine -> Car Setup) * [Car Handling] Top Speed of 352kph option. * [Car Handling] Grippy Tyres option. * [Car Handling] Drive offroad without losing speed option. * [Car Handling] Strong Bumper option. Hit other cars without sliding/losing as much speed. * [Car Colours] Eventually these will be hooked up to something interesting, but for now you simply toggle them in the menu. * [Controls] Possible to invert analog pedal axis in config.xml * [Bug] Fixed issue present on original hardware, where 1 horizontal line of road bleeds onto music selection and map screen fixed, when fix_bugs enabled in config.xml * [Bug] Fixed issue present in the original game, where the passengers palettes would be incorrect on passing the finish line for 3/5 destinations. * [Bug] Fixed a visual glitch that persisted for 1/60th of a second when passing the finish line in 60fps mode * [High Score Entry] Possible to delete last initial (not present in original game, but enabled by default in config.xml) * [High Score Entry] Possible to change default timeout value in config.xml * [Music Selection] Possible to change default timeout value in config.xml * [Shadows] Darkness increased to match hardware, as opposed to MAME. Can be toggled in config.xml * [Menus] Reorganised menu structure. Added Freeplay and Timing Fixes to menu. * [Roms] Support for both versions of fixed sample rom * New Icon on Windows build v0.33 Switch & 3DS Audio Support Overview Good news: This release focuses on enabling the new music from the Nintendo 3DS and Nintendo Switch version to be used. This audio is in native format, rather than streamed. Yey. Bad news: It is incredibly complex to extract the audio. And I cannot provide it for legal reasons. Boo. I have provided a wiki page which provides a rough overview of what's involved. I'll add instructions for the 3DS release at a later date. Please replace your old config.xml file when upgrading to this release. What's New * [Audio] Nintendo Switch and Nintendo 3DS Audio File Support. * [Audio] Sample Rate can now be set in config.xml. Default frequency increased to 48Khz, which makes a difference for FM generated audio. * [Audio] Music Test menu now supports additional audio files * [Audio] Extra music tracks no longer replace existing audio. * [Audio] Music selection screen auto-adjusts when new audio added with new scrolling format. * [Bug] Fixed long-standing bug where there was a 50% chance of a blank screen when switching from 60fps to 30fps mode. * [Techy] MML format better documented in osound.cpp source code. Additional command added to support Step On Beat.
Diffstat (limited to 'emulators/cannonball')
-rw-r--r--emulators/cannonball/Makefile3
-rw-r--r--emulators/cannonball/distinfo6
-rw-r--r--emulators/cannonball/files/patch-src_main_sdl2_renderbase.cpp11
3 files changed, 16 insertions, 4 deletions
diff --git a/emulators/cannonball/Makefile b/emulators/cannonball/Makefile
index 2626fdfcd825..3078725872fc 100644
--- a/emulators/cannonball/Makefile
+++ b/emulators/cannonball/Makefile
@@ -1,5 +1,6 @@
PORTNAME= cannonball
-DISTVERSION= 0.32
+DISTVERSION= 0.34
+DISTVERSIONPREFIX=v
CATEGORIES= emulators games
MAINTAINER= fox@FreeBSD.org
diff --git a/emulators/cannonball/distinfo b/emulators/cannonball/distinfo
index d40e78998ca0..6cf664b13330 100644
--- a/emulators/cannonball/distinfo
+++ b/emulators/cannonball/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1616733810
-SHA256 (djyt-cannonball-0.32_GH0.tar.gz) = 50a4316159f5651a18edc7aa1a8961f944ec4bf8170e8afd6cb231cbc182a7c2
-SIZE (djyt-cannonball-0.32_GH0.tar.gz) = 292602
+TIMESTAMP = 1619529584
+SHA256 (djyt-cannonball-v0.34_GH0.tar.gz) = e2cf8e21619b183a9fd835ae34ce65fb3d014c2fea37723fc8ba05681ed317ce
+SIZE (djyt-cannonball-v0.34_GH0.tar.gz) = 326020
diff --git a/emulators/cannonball/files/patch-src_main_sdl2_renderbase.cpp b/emulators/cannonball/files/patch-src_main_sdl2_renderbase.cpp
new file mode 100644
index 000000000000..9d2f244e2102
--- /dev/null
+++ b/emulators/cannonball/files/patch-src_main_sdl2_renderbase.cpp
@@ -0,0 +1,11 @@
+Fixes the error: no member named 'round' in namespace 'std'
+
+--- src/main/sdl2/renderbase.cpp.orig 2021-04-27 14:23:03 UTC
++++ src/main/sdl2/renderbase.cpp
+@@ -1,5 +1,6 @@
+ #include "renderbase.hpp"
+ #include <iostream>
++#include <cmath>
+
+ RenderBase::RenderBase()
+ {