aboutsummaryrefslogtreecommitdiff
path: root/emulators/catapult
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2013-12-28 05:15:57 +0000
committerJohn Marino <marino@FreeBSD.org>2013-12-28 05:15:57 +0000
commit461bb8b81c1ffeb739d1ac28124fdc7b040716c0 (patch)
tree7b3715828a4ee74f089fb2a9ca755da73a955b50 /emulators/catapult
parent5fd9c17f34ae8a184861b4c4aa281c0b75a4533c (diff)
downloadports-461bb8b81c1ffeb739d1ac28124fdc7b040716c0.tar.gz
ports-461bb8b81c1ffeb739d1ac28124fdc7b040716c0.zip
emulators/catapult: Fix installation in /root, add DragonFly support
After DragonFly support was added, it was discovered that this port was writing in /root/.local, which is not permissible. Settng CATAPULT_NO_DESKTOP_HOOKS stops that, but requires that catapult.xpm be manually installed, which was added to post-install target.
Notes
Notes: svn path=/head/; revision=337834
Diffstat (limited to 'emulators/catapult')
-rw-r--r--emulators/catapult/Makefile8
-rw-r--r--emulators/catapult/files/patch-build_detectsys.py11
2 files changed, 19 insertions, 0 deletions
diff --git a/emulators/catapult/Makefile b/emulators/catapult/Makefile
index 2e19b805efae..38f451d080cf 100644
--- a/emulators/catapult/Makefile
+++ b/emulators/catapult/Makefile
@@ -29,6 +29,7 @@ MAKE_ARGS= INSTALL_BASE="${STAGEDIR}${PREFIX}" \
CATAPULT_FLAVOUR="portbld" \
CATAPULT_OPENMSX_BINARY="${LOCALBASE}/bin/openmsx" \
CATAPULT_OPENMSX_SHARE="${LOCALBASE}/share/openmsx" \
+ CATAPULT_NO_DESKTOP_HOOKS="true" \
SYMLINK_FOR_BINARY="false" \
PYTHON="${PYTHON_CMD}"
@@ -42,6 +43,10 @@ CFLAGS+= -DNDEBUG
CATAPULT_STRIP= true
.endif
+post-extract:
+ ${CP} ${WRKSRC}/build/platform-freebsd.mk \
+ ${WRKSRC}/build/platform-dragonfly.mk
+
post-patch:
@${REINPLACE_CMD} 's|$$(INSTALL_BASE)|${DATADIR}|' \
${WRKSRC}/build/info2code.mk
@@ -62,6 +67,9 @@ post-patch:
>> ${WRKSRC}/build/flavour-portbld.mk
post-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}/resources/icons
+ ${INSTALL_DATA} ${WRKSRC}/src/catapult.xpm \
+ ${STAGEDIR}${DATADIR}/resources/icons
(cd ${WRKSRC}/desktop && ${INSTALL_DATA} openMSX-Catapult.desktop \
${STAGEDIR}${DESKTOPDIR})
diff --git a/emulators/catapult/files/patch-build_detectsys.py b/emulators/catapult/files/patch-build_detectsys.py
new file mode 100644
index 000000000000..229e111e97e6
--- /dev/null
+++ b/emulators/catapult/files/patch-build_detectsys.py
@@ -0,0 +1,11 @@
+--- build/detectsys.py.orig 2009-12-05 18:55:51.000000000 +0000
++++ build/detectsys.py
+@@ -57,7 +57,7 @@ def detectOS():
+ Raises ValueError if no known OS is detected.
+ '''
+ os = system().lower()
+- if os in ('linux', 'darwin', 'freebsd', 'netbsd', 'openbsd', 'gnu'):
++ if os in ('linux', 'darwin', 'dragonfly', 'freebsd', 'netbsd', 'openbsd', 'gnu'):
+ return os
+ elif os.startswith('gnu/'):
+ # GNU userland on non-Hurd kernel, for example Debian GNU/kFreeBSD.