aboutsummaryrefslogtreecommitdiff
path: root/emulators/darcnes/files
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2017-07-16 18:06:45 +0000
committerPawel Pekala <pawel@FreeBSD.org>2017-07-16 18:06:45 +0000
commit2a9f1991aaa5408712e24be5c0d7f683b71a4ea0 (patch)
treea12b48f95b82c62d112a23045f358487bcf60466 /emulators/darcnes/files
parent54f6d08f7eb7d1c9303b59702b4872d002b798c2 (diff)
downloadports-2a9f1991aaa5408712e24be5c0d7f683b71a4ea0.tar.gz
ports-2a9f1991aaa5408712e24be5c0d7f683b71a4ea0.zip
- COMMENT should start wit capital letter
- Remove deprecated WANT_GNOME - Turn pkg-plist to PLIST_FILES, PORTDOCS - only 2 plist items - Convert to options helpers, add missing dependencies when GTK1=on - Fix build when SVGALIB=on => patch-video__svga.c - Regenerate patches with make makepatch
Notes
Notes: svn path=/head/; revision=446041
Diffstat (limited to 'emulators/darcnes/files')
-rw-r--r--emulators/darcnes/files/patch-Makefile10
-rw-r--r--emulators/darcnes/files/patch-cd__unix.c (renamed from emulators/darcnes/files/patch-cd_unix.c)8
-rw-r--r--emulators/darcnes/files/patch-mtypes.h10
-rw-r--r--emulators/darcnes/files/patch-snd__unix.c (renamed from emulators/darcnes/files/patch-snd_unix.c)4
-rw-r--r--emulators/darcnes/files/patch-tool.c4
-rw-r--r--emulators/darcnes/files/patch-types.h4
-rw-r--r--emulators/darcnes/files/patch-ui__gtk.c (renamed from emulators/darcnes/files/patch-ui_gtk.c)6
-rw-r--r--emulators/darcnes/files/patch-ui__x.c (renamed from emulators/darcnes/files/patch-ui_x.c)2
-rw-r--r--emulators/darcnes/files/patch-video__svga.c10
-rw-r--r--emulators/darcnes/files/patch-video__x.c6
10 files changed, 39 insertions, 25 deletions
diff --git a/emulators/darcnes/files/patch-Makefile b/emulators/darcnes/files/patch-Makefile
index 7d046d199615..f2d819fce3cd 100644
--- a/emulators/darcnes/files/patch-Makefile
+++ b/emulators/darcnes/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2001-03-28 02:51:41.000000000 +0200
-+++ Makefile 2008-04-01 16:53:11.000000000 +0200
-@@ -11,16 +11,16 @@
+--- Makefile.orig 2001-03-28 00:51:41 UTC
++++ Makefile
+@@ -11,16 +11,16 @@ TARGET?=Linux_X
#C_ONLY=-DC_ONLY
@@ -22,7 +22,7 @@
BASE_SFLAGS=-Wall $(DEBUG) $(OPTFLAGS)
BASE_LDFLAGS=
-@@ -33,8 +33,12 @@
+@@ -33,8 +33,12 @@ endif
#
ifeq ($(TARGET),Linux_svgalib)
CONFFLAGS=-DPCE_CD_SUPPORT -DSOUND
@@ -36,7 +36,7 @@
LIBS=-lvgagl -lvga
endif
-@@ -43,9 +47,9 @@
+@@ -43,9 +47,9 @@ endif
#
ifeq ($(TARGET),Linux_X)
CONFFLAGS=-DPCE_CD_SUPPORT -DSOUND
diff --git a/emulators/darcnes/files/patch-cd_unix.c b/emulators/darcnes/files/patch-cd__unix.c
index ced852c1b10c..693472a4b9fd 100644
--- a/emulators/darcnes/files/patch-cd_unix.c
+++ b/emulators/darcnes/files/patch-cd__unix.c
@@ -1,6 +1,6 @@
---- cd_unix.c.orig Sun Aug 20 03:25:53 2000
+--- cd_unix.c.orig 2000-10-30 22:18:23 UTC
+++ cd_unix.c
-@@ -62,7 +62,6 @@
+@@ -62,7 +62,6 @@ void cd_read_next_sector(u8 *buf)
void cd_play_track(u8 track)
{
@@ -8,7 +8,7 @@
struct ioc_play_track playtrack;
/* FIXME: CD keeps playing after program quits */
-@@ -74,12 +73,10 @@
+@@ -74,12 +73,10 @@ void cd_play_track(u8 track)
playtrack.end_index = 1;
ioctl(cd_drive, CDIOCPLAYTRACKS, &playtrack);
@@ -21,7 +21,7 @@
struct ioc_play_blocks playblocks;
/* FIXME: ignores the repeat flag */
-@@ -94,7 +91,6 @@
+@@ -94,7 +91,6 @@ void cd_play_lba(u32 from, u32 to, int repeat)
playblocks.len = to - from;
ioctl(cd_drive, CDIOCPLAYBLOCKS, &playblocks);
diff --git a/emulators/darcnes/files/patch-mtypes.h b/emulators/darcnes/files/patch-mtypes.h
index 30dc8dfe346c..b9a7099b5b93 100644
--- a/emulators/darcnes/files/patch-mtypes.h
+++ b/emulators/darcnes/files/patch-mtypes.h
@@ -1,7 +1,11 @@
---- mtypes.h.orig Sat Aug 7 18:19:37 1999
-+++ mtypes.h Thu Jun 1 02:43:05 2000
-@@ -11,2 +11,4 @@
+--- mtypes.h.orig 1999-08-07 16:19:37 UTC
++++ mtypes.h
+@@ -9,6 +9,8 @@
+
+ /* $Id: mtypes.h,v 1.2 1999/08/07 16:19:37 nyef Exp $ */
+#include "endian.h"
+
typedef unsigned char byte;
+ typedef unsigned short word;
+ typedef signed char offset;
diff --git a/emulators/darcnes/files/patch-snd_unix.c b/emulators/darcnes/files/patch-snd__unix.c
index 18290f5fc77c..fb5b167728c2 100644
--- a/emulators/darcnes/files/patch-snd_unix.c
+++ b/emulators/darcnes/files/patch-snd__unix.c
@@ -1,5 +1,5 @@
---- snd_unix.c.orig Wed Oct 23 20:11:53 2002
-+++ snd_unix.c Wed Oct 23 20:12:07 2002
+--- snd_unix.c.orig 2000-10-30 22:18:27 UTC
++++ snd_unix.c
@@ -23,7 +23,7 @@
#endif
diff --git a/emulators/darcnes/files/patch-tool.c b/emulators/darcnes/files/patch-tool.c
index b4d59628fef4..8e98cd568f4f 100644
--- a/emulators/darcnes/files/patch-tool.c
+++ b/emulators/darcnes/files/patch-tool.c
@@ -1,5 +1,5 @@
---- tool.c.orig Sat May 6 23:50:17 2000
-+++ tool.c Thu Jun 1 02:43:09 2000
+--- tool.c.orig 2001-03-25 21:53:42 UTC
++++ tool.c
@@ -19,6 +19,7 @@
#include "video.h"
#include "tool.h"
diff --git a/emulators/darcnes/files/patch-types.h b/emulators/darcnes/files/patch-types.h
index 77564830253e..fe22d5ca9f49 100644
--- a/emulators/darcnes/files/patch-types.h
+++ b/emulators/darcnes/files/patch-types.h
@@ -1,5 +1,5 @@
---- types.h.orig Tue Dec 7 03:01:23 1999
-+++ types.h Thu Jun 1 02:43:11 2000
+--- types.h.orig 2000-08-04 20:19:23 UTC
++++ types.h
@@ -13,6 +13,8 @@
#include MACH_TYPES
#endif
diff --git a/emulators/darcnes/files/patch-ui_gtk.c b/emulators/darcnes/files/patch-ui__gtk.c
index 44de790f1058..457a2e753d06 100644
--- a/emulators/darcnes/files/patch-ui_gtk.c
+++ b/emulators/darcnes/files/patch-ui__gtk.c
@@ -1,6 +1,6 @@
---- ui_gtk.c.orig Tue Aug 22 11:06:48 2000
-+++ ui_gtk.c Mon Feb 2 20:12:54 2004
-@@ -63,6 +63,7 @@
+--- ui_gtk.c.orig 2000-08-22 02:06:48 UTC
++++ ui_gtk.c
+@@ -63,6 +63,7 @@ int main( int argc, char* argv[] )
video_buffer_1 = video_buffer_2 = NULL;
/* Get Gtk up and running. */
diff --git a/emulators/darcnes/files/patch-ui_x.c b/emulators/darcnes/files/patch-ui__x.c
index 0ec269aadeec..ac874c61fcff 100644
--- a/emulators/darcnes/files/patch-ui_x.c
+++ b/emulators/darcnes/files/patch-ui__x.c
@@ -1,4 +1,4 @@
---- ui_x.c.orig Mon Oct 30 23:15:31 2000
+--- ui_x.c.orig 2000-10-30 22:15:31 UTC
+++ ui_x.c
@@ -177,6 +177,12 @@ int main(int argc, char *argv[])
return 1;
diff --git a/emulators/darcnes/files/patch-video__svga.c b/emulators/darcnes/files/patch-video__svga.c
new file mode 100644
index 000000000000..66c002ca9fc3
--- /dev/null
+++ b/emulators/darcnes/files/patch-video__svga.c
@@ -0,0 +1,10 @@
+--- video_svga.c.orig 2000-09-16 23:45:10 UTC
++++ video_svga.c
+@@ -52,7 +52,6 @@ unsigned char *vbpfunc8(int line);
+
+ void video_events(void);
+
+-__inline__
+ void input_update()
+ {
+ keyboard_update();
diff --git a/emulators/darcnes/files/patch-video__x.c b/emulators/darcnes/files/patch-video__x.c
index 4cdc50417c9a..3566d6ce80d6 100644
--- a/emulators/darcnes/files/patch-video__x.c
+++ b/emulators/darcnes/files/patch-video__x.c
@@ -1,6 +1,6 @@
---- video_x.c.orig Tue Aug 24 10:46:40 2004
-+++ video_x.c Tue Aug 24 10:46:55 2004
-@@ -365,7 +365,7 @@
+--- video_x.c.orig 2000-10-30 22:15:34 UTC
++++ video_x.c
+@@ -365,7 +365,7 @@ void handle_joypad_key(int type, KeySym keysym)
ui_joypad->data &= ~ui_joypad->button_template->buttons[0];
}