aboutsummaryrefslogtreecommitdiff
path: root/emulators/e-uae
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-06-04 08:22:22 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-06-04 08:22:22 +0000
commit189f7f398482f23b4e9eedf199328cdab2eaf0ca (patch)
tree776f18a12f2e7b0668aa2971e4c6bc469c2090f8 /emulators/e-uae
parentef883f0a44f8b0404682ecb10b558433a84936b0 (diff)
downloadports-189f7f398482f23b4e9eedf199328cdab2eaf0ca.tar.gz
ports-189f7f398482f23b4e9eedf199328cdab2eaf0ca.zip
- Fix build with clang
- Add LICENSE PR: 179210 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=319830
Diffstat (limited to 'emulators/e-uae')
-rw-r--r--emulators/e-uae/Makefile25
-rw-r--r--emulators/e-uae/files/patch-src__dms__cdata.h11
2 files changed, 27 insertions, 9 deletions
diff --git a/emulators/e-uae/Makefile b/emulators/e-uae/Makefile
index d4e093200cf1..0b7d053a957d 100644
--- a/emulators/e-uae/Makefile
+++ b/emulators/e-uae/Makefile
@@ -11,25 +11,36 @@ DISTNAME= e-uae-0.8.29-WIP4
MAINTAINER= ports@FreeBSD.org
COMMENT= Enhanced version of UAE, the Amiga emulator
+LICENSE= GPLv2
+
+OPTIONS_DEFINE= DOCS
+
CONFLICTS= uae-[0-9]*
-USE_GMAKE= yes
+
USE_BZIP2= yes
-GNU_CONFIGURE= yes
USE_GNOME= gtk20
USE_SDL= sdl
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-sdl --with-sdl-gfx
MAKE_JOBS_UNSAFE= yes
-PLIST_FILES= bin/uae bin/readdisk
PORTDOCS= ChangeLog README bsdsocket.txt cmd-line.txt \
compiling.txt configuration.txt floppies.txt \
joystick.txt keyboard.txt scsi.txt
+PLIST_FILES= bin/readdisk bin/uae
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ '/X11\/xkb\/rules/s|/usr/X11R6/lib|${LOCALBASE}/share|' \
+ ${WRKSRC}/configure
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/uae ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/src/readdisk ${PREFIX}/bin
-
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
@@ -43,8 +54,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/docs/scsi.txt ${DOCSDIR}
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|/usr/X11R6/lib/X11/xkb/rules|${LOCALBASE}/share/X11/xkb/rules|' \
- ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/emulators/e-uae/files/patch-src__dms__cdata.h b/emulators/e-uae/files/patch-src__dms__cdata.h
new file mode 100644
index 000000000000..fea834c31c33
--- /dev/null
+++ b/emulators/e-uae/files/patch-src__dms__cdata.h
@@ -0,0 +1,11 @@
+--- src/dms/cdata.h.orig
++++ src/dms/cdata.h
+@@ -31,7 +31,7 @@
+ #define INLINE inline
+ #else
+ #ifdef __GNUC__
+- #define INLINE inline
++ #define INLINE static inline
+ #else
+ #ifdef __SASC
+ #define INLINE __inline