aboutsummaryrefslogtreecommitdiff
path: root/emulators/fmsx
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1997-02-27 09:27:59 +0000
committerThomas Gellekum <tg@FreeBSD.org>1997-02-27 09:27:59 +0000
commitc324db5e481e90eeebe3faf3f7f70e2663018e0a (patch)
tree890ae9685556995f3cc03a5e3750271d0079bd05 /emulators/fmsx
parentd9050aab2bd80317740a5ce88dc5f8ac172026bd (diff)
downloadports-c324db5e481e90eeebe3faf3f7f70e2663018e0a.tar.gz
ports-c324db5e481e90eeebe3faf3f7f70e2663018e0a.zip
Import of fmsx port. fMSX is an emulator for MSX computers,
which seem to have been popular in Russia some years ago. Closes PR #2434. Submitted by: Dmitry Kohmanyuk <dk@farm.org>
Notes
Notes: svn path=/head/; revision=5767
Diffstat (limited to 'emulators/fmsx')
-rw-r--r--emulators/fmsx/Makefile33
-rw-r--r--emulators/fmsx/distinfo1
-rw-r--r--emulators/fmsx/files/fmsx4
-rw-r--r--emulators/fmsx/files/patch-aa13
-rw-r--r--emulators/fmsx/pkg-comment1
-rw-r--r--emulators/fmsx/pkg-descr24
-rw-r--r--emulators/fmsx/pkg-plist15
7 files changed, 91 insertions, 0 deletions
diff --git a/emulators/fmsx/Makefile b/emulators/fmsx/Makefile
new file mode 100644
index 000000000000..22a82fe3a208
--- /dev/null
+++ b/emulators/fmsx/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: fMSX
+# Version required: 1.5
+# Date created: 15 Oct 1996
+# Whom: dk
+#
+
+DISTNAME= fMSX-1.5
+PKGNAME= fmsx-1.5
+CATEGORIES= emulators
+MASTER_SITES= ftp://cam031313.student.utwente.nl/pub/MSX/fMSX/ \
+ ftp://ftp.saitama-u.ac.jp/pub/msx/cam031313.student.utwente.nl/fMSX/
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= dk@farm.org
+
+NO_PACKAGE= ${RESTRICTED}
+RESTRICTED= Legal status of distributed ROM images unclear
+WRKSRC= ${WRKDIR}/MSX
+
+do-install:
+ ${INSTALL_SCRIPT} files/fmsx ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/fmsx ${PREFIX}/bin/fmsx.bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/dasm ${PREFIX}/bin/fmsx-dasm
+ ${INSTALL_PROGRAM} ${WRKSRC}/rddsk ${PREFIX}/bin/fmsx-rddsk
+ ${INSTALL_PROGRAM} ${WRKSRC}/wrdsk ${PREFIX}/bin/fmsx-wrdsk
+ ${MKDIR} -p ${PREFIX}/share/fmsx
+ ${INSTALL_DATA} ${WRKSRC}/*.ROM ${WRKSRC}/*.FNT ${PREFIX}/share/fmsx
+.if !defined(NOPORTDOCS)
+ ${MKDIR} -p ${PREFIX}/share/doc/fmsx
+ ${INSTALL_DATA} ${WRKSRC}/*.doc ${PREFIX}/share/doc/fmsx
+.endif
+
+.include <bsd.port.mk>
diff --git a/emulators/fmsx/distinfo b/emulators/fmsx/distinfo
new file mode 100644
index 000000000000..602497df0876
--- /dev/null
+++ b/emulators/fmsx/distinfo
@@ -0,0 +1 @@
+MD5 (fMSX-1.5.tar.Z) = 484f2a25f2c9c1b7a87d76e6a1ab9e4c
diff --git a/emulators/fmsx/files/fmsx b/emulators/fmsx/files/fmsx
new file mode 100644
index 000000000000..4b29b4dedbcc
--- /dev/null
+++ b/emulators/fmsx/files/fmsx
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd /usr/local/share/fmsx || { echo "cannot cd to /usr/local/share/fmsx" ; exit 1; }
+exec /usr/local/bin/fmsx.bin $@
diff --git a/emulators/fmsx/files/patch-aa b/emulators/fmsx/files/patch-aa
new file mode 100644
index 000000000000..77474bb7b7d0
--- /dev/null
+++ b/emulators/fmsx/files/patch-aa
@@ -0,0 +1,13 @@
+--- Makefile.orig Wed Jul 3 00:49:39 1996
++++ Makefile Mon Feb 24 14:20:26 1997
+@@ -34,8 +34,8 @@
+ # change the -L/usr/X11R6/lib to the directory where X11
+ # libraries libX11.* and libXext.* are located on your system.
+ CC = gcc
+-DEFINES = -DUNIX -DLSB_FIRST -DDEBUG -DMITSHM -DSOUND
+-CFLAGS = -O2 -I/usr/X11/include -L/usr/X11/lib ${DEFINES}
++DEFINES = -DUNIX -DLSB_FIRST -DMITSHM -DSOUND #-DBEBUG
++CFLAGS = -O2 -I${X11BASE}/include -L${X11BASE}/lib ${DEFINES}
+ OBJECTS = fMSX.o MSX.o Z80.o Debug.o Unix.o Sound.o
+
+ # Make the standard distribution: fMSX and DASM.
diff --git a/emulators/fmsx/pkg-comment b/emulators/fmsx/pkg-comment
new file mode 100644
index 000000000000..a3153954f3a9
--- /dev/null
+++ b/emulators/fmsx/pkg-comment
@@ -0,0 +1 @@
+The Portable MSX/MSX2/MSX2+ Emulator
diff --git a/emulators/fmsx/pkg-descr b/emulators/fmsx/pkg-descr
new file mode 100644
index 000000000000..8c3c13680e8b
--- /dev/null
+++ b/emulators/fmsx/pkg-descr
@@ -0,0 +1,24 @@
+
+ ******* fMSX *******
+ The Portable MSX/MSX2/MSX2+ Emulator
+ version 1.5
+
+ by Marat Fayzullin
+
+ email: fms@freeflight.com
+ IRC: RST38h
+ WWW: http://www.freeflight.com/fms/
+
+
+
+ * NEW IN THIS VERSION *
+
+o More stable split screen (Zanac-Ex no longer blinks)
+o RAM mapper fixed *again* (Designer+ works now)
+o V9938 SRCH command fixed
+o MSXDOS2.ROM support
+o PAINTER.ROM support
+o FMPAC.ROM support
+o .PSG file format is updated
+o Serial port support is *not* yet implemented.
+
diff --git a/emulators/fmsx/pkg-plist b/emulators/fmsx/pkg-plist
new file mode 100644
index 000000000000..e13544780f75
--- /dev/null
+++ b/emulators/fmsx/pkg-plist
@@ -0,0 +1,15 @@
+bin/fmsx
+bin/fmsx.bin
+bin/fmsx-dasm
+bin/fmsx-rddsk
+bin/fmsx-wrdsk
+share/fmsx/CMOS.ROM
+share/fmsx/CYRILLIC.FNT
+share/fmsx/DISK.ROM
+share/fmsx/ITALIC.FNT
+share/fmsx/MSX.ROM
+share/fmsx/MSX2.ROM
+share/fmsx/MSX2EXT.ROM
+share/fmsx/MSX2P.ROM
+share/fmsx/MSX2PEXT.ROM
+share/doc/fmsx/fMSX.doc